Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1601823 > unrolled thread

change uprobe_events default ? Was: [PATCH] perf: Rename CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS

Started byAlexei Starovoitov <alexei.starovoitov@gmail.com>
First post2017-03-16 02:00 +0100
Last post2017-03-16 17:40 +0100
Articles 10 — 9 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS Alexei Starovoitov <alexei.starovoitov@gmail.com> - 2017-03-16 02:00 +0100
    Re: change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS David Ahern <dsahern@gmail.com> - 2017-03-16 02:20 +0100
      Re: change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS Namhyung Kim <namhyung@kernel.org> - 2017-03-16 03:50 +0100
    Re: change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS Arnaldo Carvalho de Melo <acme@kernel.org> - 2017-03-16 02:20 +0100
      Re: change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS Srikar Dronamraju <srikar@linux.vnet.ibm.com> - 2017-03-16 06:40 +0100
      Re: change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS "Wangnan (F)" <wangnan0@huawei.com> - 2017-03-16 06:50 +0100
      Re: change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS Ingo Molnar <mingo@kernel.org> - 2017-03-16 07:50 +0100
        Re: change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS Arnaldo Carvalho de Melo <acme@kernel.org> - 2017-03-16 13:40 +0100
      Re: change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS Masami Hiramatsu <mhiramat@kernel.org> - 2017-03-16 08:50 +0100
    [tip:perf/core] uprobes: Default UPROBES_EVENTS to Y tip-bot for Arnaldo Carvalho de Melo <tipbot@zytor.com> - 2017-03-16 17:40 +0100

#1601823 — change uprobe_events default ? Was: [PATCH] perf: Rename CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS

FromAlexei Starovoitov <alexei.starovoitov@gmail.com>
Date2017-03-16 02:00 +0100
Subjectchange uprobe_events default ? Was: [PATCH] perf: Rename CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS
Message-ID<tlrVL-7dT-3@gated-at.bofh.it>
On Thu, Feb 16, 2017 at 05:00:50PM +1100, Anton Blanchard wrote:
> From: Anton Blanchard <anton@samba.org>
> 
> We have uses of CONFIG_UPROBE_EVENT and CONFIG_KPROBE_EVENT as
> well as CONFIG_UPROBE_EVENTS and CONFIG_KPROBE_EVENTS. Consistently
> use the plurals.
> 
> Signed-off-by: Anton Blanchard <anton@samba.org>

this rename made me notice that UPROBE_EVENTS still defaults to 'n'.
this is key feature that all distros enable, so having default 'n'
is kinda saying that it's not something that should be turned on
or used widely. which is obviously not the case.
imo it's time to change it to 'y'.
Thoughts?

[toc] | [next] | [standalone]


#1601828

FromDavid Ahern <dsahern@gmail.com>
Date2017-03-16 02:20 +0100
Message-ID<tlsf7-7A8-3@gated-at.bofh.it>
In reply to#1601823
On 3/15/17 7:06 PM, Arnaldo Carvalho de Melo wrote:
> Added more people to the CC list.
> 
> Em Wed, Mar 15, 2017 at 05:58:19PM -0700, Alexei Starovoitov escreveu:
>> On Thu, Feb 16, 2017 at 05:00:50PM +1100, Anton Blanchard wrote:
>>> We have uses of CONFIG_UPROBE_EVENT and CONFIG_KPROBE_EVENT as
>>> well as CONFIG_UPROBE_EVENTS and CONFIG_KPROBE_EVENTS. Consistently
>>> use the plurals.
>  
>> this rename made me notice that UPROBE_EVENTS still defaults to 'n'.
>> this is key feature that all distros enable, so having default 'n'
>> is kinda saying that it's not something that should be turned on
>> or used widely. which is obviously not the case.
>> imo it's time to change it to 'y'.
>> Thoughts?
> 
> Agreed, I also found it strange that it was disabled by default when I
> recently did a 'make oldconfig' :-\

Debian stretch, Ubuntu 16.10, Fedora 26 all have it enabled. Perhaps it
should default on.

[toc] | [prev] | [next] | [standalone]


#1601892

FromNamhyung Kim <namhyung@kernel.org>
Date2017-03-16 03:50 +0100
Message-ID<tltEe-8qE-13@gated-at.bofh.it>
In reply to#1601828
On Wed, Mar 15, 2017 at 07:10:56PM -0600, David Ahern wrote:
> On 3/15/17 7:06 PM, Arnaldo Carvalho de Melo wrote:
> > Added more people to the CC list.
> > 
> > Em Wed, Mar 15, 2017 at 05:58:19PM -0700, Alexei Starovoitov escreveu:
> >> On Thu, Feb 16, 2017 at 05:00:50PM +1100, Anton Blanchard wrote:
> >>> We have uses of CONFIG_UPROBE_EVENT and CONFIG_KPROBE_EVENT as
> >>> well as CONFIG_UPROBE_EVENTS and CONFIG_KPROBE_EVENTS. Consistently
> >>> use the plurals.
> >  
> >> this rename made me notice that UPROBE_EVENTS still defaults to 'n'.
> >> this is key feature that all distros enable, so having default 'n'
> >> is kinda saying that it's not something that should be turned on
> >> or used widely. which is obviously not the case.
> >> imo it's time to change it to 'y'.
> >> Thoughts?
> > 
> > Agreed, I also found it strange that it was disabled by default when I
> > recently did a 'make oldconfig' :-\
> 
> Debian stretch, Ubuntu 16.10, Fedora 26 all have it enabled. Perhaps it
> should default on.

+1

Archlinux also has it enabled.

Thanks,
Namhyung

[toc] | [prev] | [next] | [standalone]


#1601830

FromArnaldo Carvalho de Melo <acme@kernel.org>
Date2017-03-16 02:20 +0100
Message-ID<tlsf7-7A8-5@gated-at.bofh.it>
In reply to#1601823
Added more people to the CC list.

Em Wed, Mar 15, 2017 at 05:58:19PM -0700, Alexei Starovoitov escreveu:
> On Thu, Feb 16, 2017 at 05:00:50PM +1100, Anton Blanchard wrote:
> > We have uses of CONFIG_UPROBE_EVENT and CONFIG_KPROBE_EVENT as
> > well as CONFIG_UPROBE_EVENTS and CONFIG_KPROBE_EVENTS. Consistently
> > use the plurals.
 
> this rename made me notice that UPROBE_EVENTS still defaults to 'n'.
> this is key feature that all distros enable, so having default 'n'
> is kinda saying that it's not something that should be turned on
> or used widely. which is obviously not the case.
> imo it's time to change it to 'y'.
> Thoughts?

Agreed, I also found it strange that it was disabled by default when I
recently did a 'make oldconfig' :-\

- Arnaldo

[toc] | [prev] | [next] | [standalone]


#1601938

FromSrikar Dronamraju <srikar@linux.vnet.ibm.com>
Date2017-03-16 06:40 +0100
Message-ID<tlwiJ-223-19@gated-at.bofh.it>
In reply to#1601830
> Added more people to the CC list.
> 
> Em Wed, Mar 15, 2017 at 05:58:19PM -0700, Alexei Starovoitov escreveu:
> > On Thu, Feb 16, 2017 at 05:00:50PM +1100, Anton Blanchard wrote:
> > > We have uses of CONFIG_UPROBE_EVENT and CONFIG_KPROBE_EVENT as
> > > well as CONFIG_UPROBE_EVENTS and CONFIG_KPROBE_EVENTS. Consistently
> > > use the plurals.
> 
> > this rename made me notice that UPROBE_EVENTS still defaults to 'n'.
> > this is key feature that all distros enable, so having default 'n'
> > is kinda saying that it's not something that should be turned on
> > or used widely. which is obviously not the case.
> > imo it's time to change it to 'y'.
> > Thoughts?
> 
> Agreed, I also found it strange that it was disabled by default when I
> recently did a 'make oldconfig' :-\

Yes, we could make it default on.

[toc] | [prev] | [next] | [standalone]


#1601955

From"Wangnan (F)" <wangnan0@huawei.com>
Date2017-03-16 06:50 +0100
Message-ID<tlwsp-27G-3@gated-at.bofh.it>
In reply to#1601830

On 2017/3/16 9:06, Arnaldo Carvalho de Melo wrote:
> Added more people to the CC list.
>
> Em Wed, Mar 15, 2017 at 05:58:19PM -0700, Alexei Starovoitov escreveu:
>> On Thu, Feb 16, 2017 at 05:00:50PM +1100, Anton Blanchard wrote:
>>> We have uses of CONFIG_UPROBE_EVENT and CONFIG_KPROBE_EVENT as
>>> well as CONFIG_UPROBE_EVENTS and CONFIG_KPROBE_EVENTS. Consistently
>>> use the plurals.
>   
>> this rename made me notice that UPROBE_EVENTS still defaults to 'n'.
>> this is key feature that all distros enable, so having default 'n'
>> is kinda saying that it's not something that should be turned on
>> or used widely. which is obviously not the case.
>> imo it's time to change it to 'y'.
>> Thoughts?
> Agreed, I also found it strange that it was disabled by default when I
> recently did a 'make oldconfig' :-\
>
> - Arnaldo

+1.

Some internal distros in my company now have started
discussing supporting user space probing. Turning
uprobes on for upstream kernel helps us saving a lot
of discussion.

Thank you.

[toc] | [prev] | [next] | [standalone]


#1601997

FromIngo Molnar <mingo@kernel.org>
Date2017-03-16 07:50 +0100
Message-ID<tlxot-2Mg-7@gated-at.bofh.it>
In reply to#1601830
* Arnaldo Carvalho de Melo <acme@kernel.org> wrote:

> Added more people to the CC list.
> 
> Em Wed, Mar 15, 2017 at 05:58:19PM -0700, Alexei Starovoitov escreveu:
> > On Thu, Feb 16, 2017 at 05:00:50PM +1100, Anton Blanchard wrote:
> > > We have uses of CONFIG_UPROBE_EVENT and CONFIG_KPROBE_EVENT as
> > > well as CONFIG_UPROBE_EVENTS and CONFIG_KPROBE_EVENTS. Consistently
> > > use the plurals.
>  
> > this rename made me notice that UPROBE_EVENTS still defaults to 'n'.
> > this is key feature that all distros enable, so having default 'n'
> > is kinda saying that it's not something that should be turned on
> > or used widely. which is obviously not the case.
> > imo it's time to change it to 'y'.
> > Thoughts?
> 
> Agreed, I also found it strange that it was disabled by default when I
> recently did a 'make oldconfig' :-\

Agreed, someone please send a patch (or feel free to include it in the perf 
tooling tree) to switch the default around.

Thanks,

	Ingo

[toc] | [prev] | [next] | [standalone]


#1602236

FromArnaldo Carvalho de Melo <acme@kernel.org>
Date2017-03-16 13:40 +0100
Message-ID<tlCRb-6NH-5@gated-at.bofh.it>
In reply to#1601997
Em Thu, Mar 16, 2017 at 07:40:55AM +0100, Ingo Molnar escreveu:
> 
> * Arnaldo Carvalho de Melo <acme@kernel.org> wrote:
> 
> > Added more people to the CC list.
> > 
> > Em Wed, Mar 15, 2017 at 05:58:19PM -0700, Alexei Starovoitov escreveu:
> > > On Thu, Feb 16, 2017 at 05:00:50PM +1100, Anton Blanchard wrote:
> > > > We have uses of CONFIG_UPROBE_EVENT and CONFIG_KPROBE_EVENT as
> > > > well as CONFIG_UPROBE_EVENTS and CONFIG_KPROBE_EVENTS. Consistently
> > > > use the plurals.
> >  
> > > this rename made me notice that UPROBE_EVENTS still defaults to 'n'.
> > > this is key feature that all distros enable, so having default 'n'
> > > is kinda saying that it's not something that should be turned on
> > > or used widely. which is obviously not the case.
> > > imo it's time to change it to 'y'.
> > > Thoughts?
> > 
> > Agreed, I also found it strange that it was disabled by default when I
> > recently did a 'make oldconfig' :-\
> 
> Agreed, someone please send a patch (or feel free to include it in the perf 
> tooling tree) to switch the default around.

Ok, will collect the agreements as Acked-by tags and put it in
perf/core.

- Arnaldo

[toc] | [prev] | [next] | [standalone]


#1602038

FromMasami Hiramatsu <mhiramat@kernel.org>
Date2017-03-16 08:50 +0100
Message-ID<tlykx-3qz-9@gated-at.bofh.it>
In reply to#1601830
On Wed, 15 Mar 2017 22:06:51 -0300
Arnaldo Carvalho de Melo <acme@kernel.org> wrote:

> Added more people to the CC list.
> 
> Em Wed, Mar 15, 2017 at 05:58:19PM -0700, Alexei Starovoitov escreveu:
> > On Thu, Feb 16, 2017 at 05:00:50PM +1100, Anton Blanchard wrote:
> > > We have uses of CONFIG_UPROBE_EVENT and CONFIG_KPROBE_EVENT as
> > > well as CONFIG_UPROBE_EVENTS and CONFIG_KPROBE_EVENTS. Consistently
> > > use the plurals.
>  
> > this rename made me notice that UPROBE_EVENTS still defaults to 'n'.
> > this is key feature that all distros enable, so having default 'n'
> > is kinda saying that it's not something that should be turned on
> > or used widely. which is obviously not the case.
> > imo it's time to change it to 'y'.
> > Thoughts?
> 
> Agreed, I also found it strange that it was disabled by default when I
> recently did a 'make oldconfig' :-\

Agreed. Now uprobes is enough stable. (and widely used)

Thanks!


-- 
Masami Hiramatsu <mhiramat@kernel.org>

[toc] | [prev] | [next] | [standalone]


#1602633 — [tip:perf/core] uprobes: Default UPROBES_EVENTS to Y

Fromtip-bot for Arnaldo Carvalho de Melo <tipbot@zytor.com>
Date2017-03-16 17:40 +0100
Subject[tip:perf/core] uprobes: Default UPROBES_EVENTS to Y
Message-ID<tlGBs-10m-17@gated-at.bofh.it>
In reply to#1601823
Commit-ID:  61f35d750683b21e9e3836e309195c79c1daed74
Gitweb:     http://git.kernel.org/tip/61f35d750683b21e9e3836e309195c79c1daed74
Author:     Arnaldo Carvalho de Melo <acme@redhat.com>
AuthorDate: Thu, 16 Mar 2017 12:42:02 -0300
Committer:  Arnaldo Carvalho de Melo <acme@redhat.com>
CommitDate: Thu, 16 Mar 2017 12:42:02 -0300

uprobes: Default UPROBES_EVENTS to Y

As it is already turned on by most distros, so just flip the default to
Y.

Suggested-by: Alexei Starovoitov <alexei.starovoitov@gmail.com>
Acked-by: David Ahern <dsahern@gmail.com>
Acked-by: Ingo Molnar <mingo@kernel.org>
Acked-by: Masami Hiramatsu <mhiramat@kernel.org>
Acked-by: Namhyung Kim <namhyung@kernel.org>
Acked-by: Srikar Dronamraju <srikar@linux.vnet.ibm.com>
Acked-by: Wang Nan <wangnan0@huawei.com>
Cc: Alexander Shishkin <alexander.shishkin@linux.intel.com>
Cc: Anton Blanchard <anton@ozlabs.org>
Cc: David Miller <davem@davemloft.net>
Cc: Hemant Kumar <hemant@linux.vnet.ibm.com>
Cc: Jiri Olsa <jolsa@kernel.org>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Steven Rostedt <rostedt@goodmis.org>
Link: http://lkml.kernel.org/r/20170316005817.GA6805@ast-mbp.thefacebook.com
Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
---
 kernel/trace/Kconfig | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/kernel/trace/Kconfig b/kernel/trace/Kconfig
index d4a06e7..9619b57 100644
--- a/kernel/trace/Kconfig
+++ b/kernel/trace/Kconfig
@@ -455,7 +455,7 @@ config UPROBE_EVENTS
 	select UPROBES
 	select PROBE_EVENTS
 	select TRACING
-	default n
+	default y
 	help
 	  This allows the user to add tracing events on top of userspace
 	  dynamic events (similar to tracepoints) on the fly via the trace

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web