Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1601938

Re: change uprobe_events default ? Was: [PATCH] perf: Rename CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS

From Srikar Dronamraju <srikar@linux.vnet.ibm.com>
Newsgroups linux.kernel
Subject Re: change uprobe_events default ? Was: [PATCH] perf: Rename CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS
Date 2017-03-16 06:40 +0100
Message-ID <tlwiJ-223-19@gated-at.bofh.it> (permalink)
References <tbnqp-283-1@gated-at.bofh.it> <tlrVL-7dT-3@gated-at.bofh.it> <tlsf7-7A8-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


> Added more people to the CC list.
> 
> Em Wed, Mar 15, 2017 at 05:58:19PM -0700, Alexei Starovoitov escreveu:
> > On Thu, Feb 16, 2017 at 05:00:50PM +1100, Anton Blanchard wrote:
> > > We have uses of CONFIG_UPROBE_EVENT and CONFIG_KPROBE_EVENT as
> > > well as CONFIG_UPROBE_EVENTS and CONFIG_KPROBE_EVENTS. Consistently
> > > use the plurals.
> 
> > this rename made me notice that UPROBE_EVENTS still defaults to 'n'.
> > this is key feature that all distros enable, so having default 'n'
> > is kinda saying that it's not something that should be turned on
> > or used widely. which is obviously not the case.
> > imo it's time to change it to 'y'.
> > Thoughts?
> 
> Agreed, I also found it strange that it was disabled by default when I
> recently did a 'make oldconfig' :-\

Yes, we could make it default on.

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS Alexei Starovoitov <alexei.starovoitov@gmail.com> - 2017-03-16 02:00 +0100
  Re: change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS David Ahern <dsahern@gmail.com> - 2017-03-16 02:20 +0100
    Re: change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS Namhyung Kim <namhyung@kernel.org> - 2017-03-16 03:50 +0100
  Re: change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS Arnaldo Carvalho de Melo <acme@kernel.org> - 2017-03-16 02:20 +0100
    Re: change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS Srikar Dronamraju <srikar@linux.vnet.ibm.com> - 2017-03-16 06:40 +0100
    Re: change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS "Wangnan (F)" <wangnan0@huawei.com> - 2017-03-16 06:50 +0100
    Re: change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS Ingo Molnar <mingo@kernel.org> - 2017-03-16 07:50 +0100
      Re: change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS Arnaldo Carvalho de Melo <acme@kernel.org> - 2017-03-16 13:40 +0100
    Re: change uprobe_events default ? Was: [PATCH] perf: Rename  CONFIG_[UK]PROBE_EVENT to CONFIG_[UK]PROBE_EVENTS Masami Hiramatsu <mhiramat@kernel.org> - 2017-03-16 08:50 +0100
  [tip:perf/core] uprobes: Default UPROBES_EVENTS to Y tip-bot for Arnaldo Carvalho de Melo <tipbot@zytor.com> - 2017-03-16 17:40 +0100

csiph-web