Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1598080 > unrolled thread

[PATCH] fpga: bridge: Replace open-coded list_for_each + list_entry

Started byMoritz Fischer <mdf@kernel.org>
First post2017-03-10 21:50 +0100
Last post2017-03-13 20:00 +0100
Articles 2 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH] fpga: bridge: Replace open-coded list_for_each + list_entry Moritz Fischer <mdf@kernel.org> - 2017-03-10 21:50 +0100
    Re: [PATCH] fpga: bridge: Replace open-coded list_for_each + list_entry Alan Tull <delicious.quinoa@gmail.com> - 2017-03-13 20:00 +0100

#1598080 — [PATCH] fpga: bridge: Replace open-coded list_for_each + list_entry

FromMoritz Fischer <mdf@kernel.org>
Date2017-03-10 21:50 +0100
Subject[PATCH] fpga: bridge: Replace open-coded list_for_each + list_entry
Message-ID<tjzE6-Jy-5@gated-at.bofh.it>
Replaces open-coded list_for_each() + list_entry() with macro
list_for_each_entry()

Signed-off-by: Moritz Fischer <mdf@kernel.org>
Cc: Alan Tull <atull@kernel.org>
Cc: linux-fpga@vger.kernel.org
Cc: linux-kernel@vger.kernel.org
---
 drivers/fpga/fpga-bridge.c | 15 ++++-----------
 1 file changed, 4 insertions(+), 11 deletions(-)

diff --git a/drivers/fpga/fpga-bridge.c b/drivers/fpga/fpga-bridge.c
index 33ee83e..cfacd2e 100644
--- a/drivers/fpga/fpga-bridge.c
+++ b/drivers/fpga/fpga-bridge.c
@@ -146,11 +146,9 @@ EXPORT_SYMBOL_GPL(fpga_bridge_put);
 int fpga_bridges_enable(struct list_head *bridge_list)
 {
 	struct fpga_bridge *bridge;
-	struct list_head *node;
 	int ret;
 
-	list_for_each(node, bridge_list) {
-		bridge = list_entry(node, struct fpga_bridge, node);
+	list_for_each_entry(bridge, bridge_list, node) {
 		ret = fpga_bridge_enable(bridge);
 		if (ret)
 			return ret;
@@ -172,11 +170,9 @@ EXPORT_SYMBOL_GPL(fpga_bridges_enable);
 int fpga_bridges_disable(struct list_head *bridge_list)
 {
 	struct fpga_bridge *bridge;
-	struct list_head *node;
 	int ret;
 
-	list_for_each(node, bridge_list) {
-		bridge = list_entry(node, struct fpga_bridge, node);
+	list_for_each_entry(bridge, bridge_list, node) {
 		ret = fpga_bridge_disable(bridge);
 		if (ret)
 			return ret;
@@ -196,13 +192,10 @@ EXPORT_SYMBOL_GPL(fpga_bridges_disable);
  */
 void fpga_bridges_put(struct list_head *bridge_list)
 {
-	struct fpga_bridge *bridge;
-	struct list_head *node, *next;
+	struct fpga_bridge *bridge, *next;
 	unsigned long flags;
 
-	list_for_each_safe(node, next, bridge_list) {
-		bridge = list_entry(node, struct fpga_bridge, node);
-
+	list_for_each_entry_safe(bridge, next, bridge_list, node) {
 		fpga_bridge_put(bridge);
 
 		spin_lock_irqsave(&bridge_list_lock, flags);
-- 
2.7.4

[toc] | [next] | [standalone]


#1599693

FromAlan Tull <delicious.quinoa@gmail.com>
Date2017-03-13 20:00 +0100
Message-ID<tkDmh-4GD-5@gated-at.bofh.it>
In reply to#1598080
On Fri, Mar 10, 2017 at 2:47 PM, Moritz Fischer <mdf@kernel.org> wrote:

Hi Moritz,

Thanks!

Alan

> Replaces open-coded list_for_each() + list_entry() with macro
> list_for_each_entry()
>
> Signed-off-by: Moritz Fischer <mdf@kernel.org>
> Cc: Alan Tull <atull@kernel.org>
> Cc: linux-fpga@vger.kernel.org
> Cc: linux-kernel@vger.kernel.org

Acked-by: Alan Tull <atull@kernel.org>

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web