Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1598363 > unrolled thread

Re: [Outreachy kernel] [PATCH] staging: rtl8192u: Remove typedef phy_ofdm_rx_status_rxsc_sgien_exintfflag

Started byJulia Lawall <julia.lawall@lip6.fr>
First post2017-03-11 17:30 +0100
Last post2017-03-11 18:00 +0100
Articles 3 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [Outreachy kernel] [PATCH] staging: rtl8192u: Remove typedef  phy_ofdm_rx_status_rxsc_sgien_exintfflag Julia Lawall <julia.lawall@lip6.fr> - 2017-03-11 17:30 +0100
    Re: [Outreachy kernel] [PATCH] staging: rtl8192u: Remove typedef phy_ofdm_rx_status_rxsc_sgien_exintfflag SIMRAN SINGHAL <singhalsimran0@gmail.com> - 2017-03-11 17:50 +0100
      Re: [Outreachy kernel] [PATCH] staging: rtl8192u: Remove typedef  phy_ofdm_rx_status_rxsc_sgien_exintfflag Julia Lawall <julia.lawall@lip6.fr> - 2017-03-11 18:00 +0100

#1598363 — Re: [Outreachy kernel] [PATCH] staging: rtl8192u: Remove typedef phy_ofdm_rx_status_rxsc_sgien_exintfflag

FromJulia Lawall <julia.lawall@lip6.fr>
Date2017-03-11 17:30 +0100
SubjectRe: [Outreachy kernel] [PATCH] staging: rtl8192u: Remove typedef phy_ofdm_rx_status_rxsc_sgien_exintfflag
Message-ID<tjS41-5lj-13@gated-at.bofh.it>

On Sat, 11 Mar 2017, simran singhal wrote:

> Remove typdef phy_ofdm_rx_status_rxsc_sgien_exintfflag and replace its uses
> in the code.
>
> Signed-off-by: simran singhal <singhalsimran0@gmail.com>
> ---
>  drivers/staging/rtl8192u/r8192U.h      | 4 ++--
>  drivers/staging/rtl8192u/r8192U_core.c | 4 ++--
>  2 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/staging/rtl8192u/r8192U.h b/drivers/staging/rtl8192u/r8192U.h
> index a7ba8f3..cd3e922 100644
> --- a/drivers/staging/rtl8192u/r8192U.h
> +++ b/drivers/staging/rtl8192u/r8192U.h
> @@ -793,12 +793,12 @@ typedef struct _phy_cck_rx_status_report_819xusb {
>  } phy_sts_cck_819xusb_t;
>
>
> -typedef struct _phy_ofdm_rx_status_rxsc_sgien_exintfflag {
> +struct _phy_ofdm_rx_status_rxsc_sgien_exintfflag {

You should drop the _ at the beginning of the name.  The _ suggests that
he name is a hidden thing, because one was intended to use the typedef.
The is not the case any more, so it would be better to drop the _.

The name of the structure seems to be sort of a concatenation of the names
of the fields.  If you can think of a better name based on how the
structure is used, that could be good to.

julia

>  	u8			reserved:4;
>  	u8			rxsc:2;
>  	u8			sgi_en:1;
>  	u8			ex_intf_flag:1;
> -} phy_ofdm_rx_status_rxsc_sgien_exintfflag;
> +};
>
>  typedef enum _RT_CUSTOMER_ID {
>  	RT_CID_DEFAULT = 0,
> diff --git a/drivers/staging/rtl8192u/r8192U_core.c b/drivers/staging/rtl8192u/r8192U_core.c
> index 13239f4..0d830f6 100644
> --- a/drivers/staging/rtl8192u/r8192U_core.c
> +++ b/drivers/staging/rtl8192u/r8192U_core.c
> @@ -4242,7 +4242,7 @@ static void rtl8192_query_rxphystatus(struct r8192_priv *priv,
>  {
>  	phy_sts_ofdm_819xusb_t *pofdm_buf;
>  	phy_sts_cck_819xusb_t	*pcck_buf;
> -	phy_ofdm_rx_status_rxsc_sgien_exintfflag *prxsc;
> +	struct _phy_ofdm_rx_status_rxsc_sgien_exintfflag *prxsc;
>  	u8	*prxpkt;
>  	u8	i, max_spatial_stream, tmp_rxsnr, tmp_rxevm, rxsc_sgien_exflg;
>  	s8	rx_pwr[4], rx_pwr_all = 0;
> @@ -4432,7 +4432,7 @@ static void rtl8192_query_rxphystatus(struct r8192_priv *priv,
>
>  		/* record rx statistics for debug */
>  		rxsc_sgien_exflg = pofdm_buf->rxsc_sgien_exflg;
> -		prxsc =	(phy_ofdm_rx_status_rxsc_sgien_exintfflag *)
> +		prxsc =	(struct _phy_ofdm_rx_status_rxsc_sgien_exintfflag *)
>  			&rxsc_sgien_exflg;
>  		if (pdrvinfo->BW)	/* 40M channel */
>  			priv->stats.received_bwtype[1 + prxsc->rxsc]++;
> --
> 2.7.4
>
> --
> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@googlegroups.com.
> To post to this group, send email to outreachy-kernel@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/20170311162045.GA21103%40singhal-Inspiron-5558.
> For more options, visit https://groups.google.com/d/optout.
>

[toc] | [next] | [standalone]


#1598367 — Re: [Outreachy kernel] [PATCH] staging: rtl8192u: Remove typedef phy_ofdm_rx_status_rxsc_sgien_exintfflag

FromSIMRAN SINGHAL <singhalsimran0@gmail.com>
Date2017-03-11 17:50 +0100
SubjectRe: [Outreachy kernel] [PATCH] staging: rtl8192u: Remove typedef phy_ofdm_rx_status_rxsc_sgien_exintfflag
Message-ID<tjSnn-5rQ-11@gated-at.bofh.it>
In reply to#1598363
On Sat, Mar 11, 2017 at 9:56 PM, Julia Lawall <julia.lawall@lip6.fr> wrote:
>
>
> On Sat, 11 Mar 2017, simran singhal wrote:
>
>> Remove typdef phy_ofdm_rx_status_rxsc_sgien_exintfflag and replace its uses
>> in the code.
>>
>> Signed-off-by: simran singhal <singhalsimran0@gmail.com>
>> ---
>>  drivers/staging/rtl8192u/r8192U.h      | 4 ++--
>>  drivers/staging/rtl8192u/r8192U_core.c | 4 ++--
>>  2 files changed, 4 insertions(+), 4 deletions(-)
>>
>> diff --git a/drivers/staging/rtl8192u/r8192U.h b/drivers/staging/rtl8192u/r8192U.h
>> index a7ba8f3..cd3e922 100644
>> --- a/drivers/staging/rtl8192u/r8192U.h
>> +++ b/drivers/staging/rtl8192u/r8192U.h
>> @@ -793,12 +793,12 @@ typedef struct _phy_cck_rx_status_report_819xusb {
>>  } phy_sts_cck_819xusb_t;
>>
>>
>> -typedef struct _phy_ofdm_rx_status_rxsc_sgien_exintfflag {
>> +struct _phy_ofdm_rx_status_rxsc_sgien_exintfflag {
>
> You should drop the _ at the beginning of the name.  The _ suggests that
> he name is a hidden thing, because one was intended to use the typedef.
> The is not the case any more, so it would be better to drop the _.
>
> The name of the structure seems to be sort of a concatenation of the names
> of the fields.  If you can think of a better name based on how the
> structure is used, that could be good to.
>
Juila, I think changing the name of the structure is not a good idea as other
structures are also given on the basis of concatenation of the names
of the fields.
So, it will break the consistency.

And I will resend this patch with droping "_" at the beginning.


> julia
>
>>       u8                      reserved:4;
>>       u8                      rxsc:2;
>>       u8                      sgi_en:1;
>>       u8                      ex_intf_flag:1;
>> -} phy_ofdm_rx_status_rxsc_sgien_exintfflag;
>> +};
>>
>>  typedef enum _RT_CUSTOMER_ID {
>>       RT_CID_DEFAULT = 0,
>> diff --git a/drivers/staging/rtl8192u/r8192U_core.c b/drivers/staging/rtl8192u/r8192U_core.c
>> index 13239f4..0d830f6 100644
>> --- a/drivers/staging/rtl8192u/r8192U_core.c
>> +++ b/drivers/staging/rtl8192u/r8192U_core.c
>> @@ -4242,7 +4242,7 @@ static void rtl8192_query_rxphystatus(struct r8192_priv *priv,
>>  {
>>       phy_sts_ofdm_819xusb_t *pofdm_buf;
>>       phy_sts_cck_819xusb_t   *pcck_buf;
>> -     phy_ofdm_rx_status_rxsc_sgien_exintfflag *prxsc;
>> +     struct _phy_ofdm_rx_status_rxsc_sgien_exintfflag *prxsc;
>>       u8      *prxpkt;
>>       u8      i, max_spatial_stream, tmp_rxsnr, tmp_rxevm, rxsc_sgien_exflg;
>>       s8      rx_pwr[4], rx_pwr_all = 0;
>> @@ -4432,7 +4432,7 @@ static void rtl8192_query_rxphystatus(struct r8192_priv *priv,
>>
>>               /* record rx statistics for debug */
>>               rxsc_sgien_exflg = pofdm_buf->rxsc_sgien_exflg;
>> -             prxsc = (phy_ofdm_rx_status_rxsc_sgien_exintfflag *)
>> +             prxsc = (struct _phy_ofdm_rx_status_rxsc_sgien_exintfflag *)
>>                       &rxsc_sgien_exflg;
>>               if (pdrvinfo->BW)       /* 40M channel */
>>                       priv->stats.received_bwtype[1 + prxsc->rxsc]++;
>> --
>> 2.7.4
>>
>> --
>> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
>> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@googlegroups.com.
>> To post to this group, send email to outreachy-kernel@googlegroups.com.
>> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/20170311162045.GA21103%40singhal-Inspiron-5558.
>> For more options, visit https://groups.google.com/d/optout.
>>

[toc] | [prev] | [next] | [standalone]


#1598368

FromJulia Lawall <julia.lawall@lip6.fr>
Date2017-03-11 18:00 +0100
Message-ID<tjSx3-5vu-5@gated-at.bofh.it>
In reply to#1598367

On Sat, 11 Mar 2017, SIMRAN SINGHAL wrote:

> On Sat, Mar 11, 2017 at 9:56 PM, Julia Lawall <julia.lawall@lip6.fr> wrote:
> >
> >
> > On Sat, 11 Mar 2017, simran singhal wrote:
> >
> >> Remove typdef phy_ofdm_rx_status_rxsc_sgien_exintfflag and replace its uses
> >> in the code.
> >>
> >> Signed-off-by: simran singhal <singhalsimran0@gmail.com>
> >> ---
> >>  drivers/staging/rtl8192u/r8192U.h      | 4 ++--
> >>  drivers/staging/rtl8192u/r8192U_core.c | 4 ++--
> >>  2 files changed, 4 insertions(+), 4 deletions(-)
> >>
> >> diff --git a/drivers/staging/rtl8192u/r8192U.h b/drivers/staging/rtl8192u/r8192U.h
> >> index a7ba8f3..cd3e922 100644
> >> --- a/drivers/staging/rtl8192u/r8192U.h
> >> +++ b/drivers/staging/rtl8192u/r8192U.h
> >> @@ -793,12 +793,12 @@ typedef struct _phy_cck_rx_status_report_819xusb {
> >>  } phy_sts_cck_819xusb_t;
> >>
> >>
> >> -typedef struct _phy_ofdm_rx_status_rxsc_sgien_exintfflag {
> >> +struct _phy_ofdm_rx_status_rxsc_sgien_exintfflag {
> >
> > You should drop the _ at the beginning of the name.  The _ suggests that
> > he name is a hidden thing, because one was intended to use the typedef.
> > The is not the case any more, so it would be better to drop the _.
> >
> > The name of the structure seems to be sort of a concatenation of the names
> > of the fields.  If you can think of a better name based on how the
> > structure is used, that could be good to.
> >
> Juila, I think changing the name of the structure is not a good idea as other
> structures are also given on the basis of concatenation of the names
> of the fields.
> So, it will break the consistency.

I think that the name (or rather all the names) will have to be changed
eventually.  It's impractical and unmeaningful.  But perhaps it woud be
too much for this patch, so it's fine to just drop the _.

julia

>
> And I will resend this patch with droping "_" at the beginning.
>
>
> > julia
> >
> >>       u8                      reserved:4;
> >>       u8                      rxsc:2;
> >>       u8                      sgi_en:1;
> >>       u8                      ex_intf_flag:1;
> >> -} phy_ofdm_rx_status_rxsc_sgien_exintfflag;
> >> +};
> >>
> >>  typedef enum _RT_CUSTOMER_ID {
> >>       RT_CID_DEFAULT = 0,
> >> diff --git a/drivers/staging/rtl8192u/r8192U_core.c b/drivers/staging/rtl8192u/r8192U_core.c
> >> index 13239f4..0d830f6 100644
> >> --- a/drivers/staging/rtl8192u/r8192U_core.c
> >> +++ b/drivers/staging/rtl8192u/r8192U_core.c
> >> @@ -4242,7 +4242,7 @@ static void rtl8192_query_rxphystatus(struct r8192_priv *priv,
> >>  {
> >>       phy_sts_ofdm_819xusb_t *pofdm_buf;
> >>       phy_sts_cck_819xusb_t   *pcck_buf;
> >> -     phy_ofdm_rx_status_rxsc_sgien_exintfflag *prxsc;
> >> +     struct _phy_ofdm_rx_status_rxsc_sgien_exintfflag *prxsc;
> >>       u8      *prxpkt;
> >>       u8      i, max_spatial_stream, tmp_rxsnr, tmp_rxevm, rxsc_sgien_exflg;
> >>       s8      rx_pwr[4], rx_pwr_all = 0;
> >> @@ -4432,7 +4432,7 @@ static void rtl8192_query_rxphystatus(struct r8192_priv *priv,
> >>
> >>               /* record rx statistics for debug */
> >>               rxsc_sgien_exflg = pofdm_buf->rxsc_sgien_exflg;
> >> -             prxsc = (phy_ofdm_rx_status_rxsc_sgien_exintfflag *)
> >> +             prxsc = (struct _phy_ofdm_rx_status_rxsc_sgien_exintfflag *)
> >>                       &rxsc_sgien_exflg;
> >>               if (pdrvinfo->BW)       /* 40M channel */
> >>                       priv->stats.received_bwtype[1 + prxsc->rxsc]++;
> >> --
> >> 2.7.4
> >>
> >> --
> >> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
> >> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@googlegroups.com.
> >> To post to this group, send email to outreachy-kernel@googlegroups.com.
> >> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/20170311162045.GA21103%40singhal-Inspiron-5558.
> >> For more options, visit https://groups.google.com/d/optout.
> >>
>
> --
> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@googlegroups.com.
> To post to this group, send email to outreachy-kernel@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/CALrZqyMFOVzDNWABBP2oTN5q7_H7vABWFb5LBt96teurvNQVVg%40mail.gmail.com.
> For more options, visit https://groups.google.com/d/optout.
>

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web