Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1598363

Re: [Outreachy kernel] [PATCH] staging: rtl8192u: Remove typedef phy_ofdm_rx_status_rxsc_sgien_exintfflag

From Julia Lawall <julia.lawall@lip6.fr>
Newsgroups linux.kernel
Subject Re: [Outreachy kernel] [PATCH] staging: rtl8192u: Remove typedef phy_ofdm_rx_status_rxsc_sgien_exintfflag
Date 2017-03-11 17:30 +0100
Message-ID <tjS41-5lj-13@gated-at.bofh.it> (permalink)
References <tjS41-5lj-7@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw



On Sat, 11 Mar 2017, simran singhal wrote:

> Remove typdef phy_ofdm_rx_status_rxsc_sgien_exintfflag and replace its uses
> in the code.
>
> Signed-off-by: simran singhal <singhalsimran0@gmail.com>
> ---
>  drivers/staging/rtl8192u/r8192U.h      | 4 ++--
>  drivers/staging/rtl8192u/r8192U_core.c | 4 ++--
>  2 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/staging/rtl8192u/r8192U.h b/drivers/staging/rtl8192u/r8192U.h
> index a7ba8f3..cd3e922 100644
> --- a/drivers/staging/rtl8192u/r8192U.h
> +++ b/drivers/staging/rtl8192u/r8192U.h
> @@ -793,12 +793,12 @@ typedef struct _phy_cck_rx_status_report_819xusb {
>  } phy_sts_cck_819xusb_t;
>
>
> -typedef struct _phy_ofdm_rx_status_rxsc_sgien_exintfflag {
> +struct _phy_ofdm_rx_status_rxsc_sgien_exintfflag {

You should drop the _ at the beginning of the name.  The _ suggests that
he name is a hidden thing, because one was intended to use the typedef.
The is not the case any more, so it would be better to drop the _.

The name of the structure seems to be sort of a concatenation of the names
of the fields.  If you can think of a better name based on how the
structure is used, that could be good to.

julia

>  	u8			reserved:4;
>  	u8			rxsc:2;
>  	u8			sgi_en:1;
>  	u8			ex_intf_flag:1;
> -} phy_ofdm_rx_status_rxsc_sgien_exintfflag;
> +};
>
>  typedef enum _RT_CUSTOMER_ID {
>  	RT_CID_DEFAULT = 0,
> diff --git a/drivers/staging/rtl8192u/r8192U_core.c b/drivers/staging/rtl8192u/r8192U_core.c
> index 13239f4..0d830f6 100644
> --- a/drivers/staging/rtl8192u/r8192U_core.c
> +++ b/drivers/staging/rtl8192u/r8192U_core.c
> @@ -4242,7 +4242,7 @@ static void rtl8192_query_rxphystatus(struct r8192_priv *priv,
>  {
>  	phy_sts_ofdm_819xusb_t *pofdm_buf;
>  	phy_sts_cck_819xusb_t	*pcck_buf;
> -	phy_ofdm_rx_status_rxsc_sgien_exintfflag *prxsc;
> +	struct _phy_ofdm_rx_status_rxsc_sgien_exintfflag *prxsc;
>  	u8	*prxpkt;
>  	u8	i, max_spatial_stream, tmp_rxsnr, tmp_rxevm, rxsc_sgien_exflg;
>  	s8	rx_pwr[4], rx_pwr_all = 0;
> @@ -4432,7 +4432,7 @@ static void rtl8192_query_rxphystatus(struct r8192_priv *priv,
>
>  		/* record rx statistics for debug */
>  		rxsc_sgien_exflg = pofdm_buf->rxsc_sgien_exflg;
> -		prxsc =	(phy_ofdm_rx_status_rxsc_sgien_exintfflag *)
> +		prxsc =	(struct _phy_ofdm_rx_status_rxsc_sgien_exintfflag *)
>  			&rxsc_sgien_exflg;
>  		if (pdrvinfo->BW)	/* 40M channel */
>  			priv->stats.received_bwtype[1 + prxsc->rxsc]++;
> --
> 2.7.4
>
> --
> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@googlegroups.com.
> To post to this group, send email to outreachy-kernel@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/20170311162045.GA21103%40singhal-Inspiron-5558.
> For more options, visit https://groups.google.com/d/optout.
>

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

Re: [Outreachy kernel] [PATCH] staging: rtl8192u: Remove typedef  phy_ofdm_rx_status_rxsc_sgien_exintfflag Julia Lawall <julia.lawall@lip6.fr> - 2017-03-11 17:30 +0100
  Re: [Outreachy kernel] [PATCH] staging: rtl8192u: Remove typedef phy_ofdm_rx_status_rxsc_sgien_exintfflag SIMRAN SINGHAL <singhalsimran0@gmail.com> - 2017-03-11 17:50 +0100
    Re: [Outreachy kernel] [PATCH] staging: rtl8192u: Remove typedef  phy_ofdm_rx_status_rxsc_sgien_exintfflag Julia Lawall <julia.lawall@lip6.fr> - 2017-03-11 18:00 +0100

csiph-web