Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1670469 > unrolled thread

[PATCH] staging: lustre: lnet: selftest: Change the type of variable to bool

Started bysimran singhal <singhalsimran0@gmail.com>
First post2017-06-20 11:10 +0200
Last post2017-06-23 22:30 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH] staging: lustre: lnet: selftest: Change the type of variable  to bool simran singhal <singhalsimran0@gmail.com> - 2017-06-20 11:10 +0200
    Re: [PATCH] staging: lustre: lnet: selftest: Change the type of  variable to bool Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2017-06-23 22:30 +0200

#1670469 — [PATCH] staging: lustre: lnet: selftest: Change the type of variable to bool

Fromsimran singhal <singhalsimran0@gmail.com>
Date2017-06-20 11:10 +0200
Subject[PATCH] staging: lustre: lnet: selftest: Change the type of variable to bool
Message-ID<tUnkD-6DB-29@gated-at.bofh.it>
This patch changes the type of variable done from int to boolean. As it
is been used as a boolean in the function sfw_test_rpc_done(). It also
makes the code more readable and bool data type also requires less
memory in comparison to int data type.

Signed-off-by: simran singhal <singhalsimran0@gmail.com>
---
 drivers/staging/lustre/lnet/selftest/framework.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/staging/lustre/lnet/selftest/framework.c b/drivers/staging/lustre/lnet/selftest/framework.c
index ef27bff..3789df6 100644
--- a/drivers/staging/lustre/lnet/selftest/framework.c
+++ b/drivers/staging/lustre/lnet/selftest/framework.c
@@ -869,7 +869,7 @@ sfw_test_rpc_done(struct srpc_client_rpc *rpc)
 {
 	struct sfw_test_unit *tsu = rpc->crpc_priv;
 	struct sfw_test_instance *tsi = tsu->tsu_instance;
-	int done = 0;
+	bool done = false;
 
 	tsi->tsi_ops->tso_done_rpc(tsu, rpc);
 
@@ -883,7 +883,7 @@ sfw_test_rpc_done(struct srpc_client_rpc *rpc)
 	/* batch is stopping or loop is done or get error */
 	if (tsi->tsi_stopping || !tsu->tsu_loop ||
 	    (rpc->crpc_status && tsi->tsi_stoptsu_onerr))
-		done = 1;
+		done = true;
 
 	/* dec ref for poster */
 	srpc_client_rpc_decref(rpc);
-- 
2.7.4

[toc] | [next] | [standalone]


#1673835 — Re: [PATCH] staging: lustre: lnet: selftest: Change the type of variable to bool

FromGreg Kroah-Hartman <gregkh@linuxfoundation.org>
Date2017-06-23 22:30 +0200
SubjectRe: [PATCH] staging: lustre: lnet: selftest: Change the type of variable to bool
Message-ID<tVDnk-6P1-33@gated-at.bofh.it>
In reply to#1670469
On Tue, Jun 20, 2017 at 02:36:37PM +0530, simran singhal wrote:
> This patch changes the type of variable done from int to boolean. As it
> is been used as a boolean in the function sfw_test_rpc_done(). It also
> makes the code more readable and bool data type also requires less
> memory in comparison to int data type.

Are you sure it takes less memory?  What is the difference before and
after your patch?  Don't make claims without having a way to back them
up :)

thanks,

greg k-h

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web