Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1673835

Re: [PATCH] staging: lustre: lnet: selftest: Change the type of variable to bool

From Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Newsgroups linux.kernel
Subject Re: [PATCH] staging: lustre: lnet: selftest: Change the type of variable to bool
Date 2017-06-23 22:30 +0200
Message-ID <tVDnk-6P1-33@gated-at.bofh.it> (permalink)
References <tUnkD-6DB-29@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, Jun 20, 2017 at 02:36:37PM +0530, simran singhal wrote:
> This patch changes the type of variable done from int to boolean. As it
> is been used as a boolean in the function sfw_test_rpc_done(). It also
> makes the code more readable and bool data type also requires less
> memory in comparison to int data type.

Are you sure it takes less memory?  What is the difference before and
after your patch?  Don't make claims without having a way to back them
up :)

thanks,

greg k-h

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH] staging: lustre: lnet: selftest: Change the type of variable  to bool simran singhal <singhalsimran0@gmail.com> - 2017-06-20 11:10 +0200
  Re: [PATCH] staging: lustre: lnet: selftest: Change the type of  variable to bool Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2017-06-23 22:30 +0200

csiph-web