Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1671379 > unrolled thread

Re: [PATCH 3/3] fsi/master-gpio: Add external mode

Started byJoel Stanley <joel@jms.id.au>
First post2017-06-21 08:10 +0200
Last post2017-06-22 00:10 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH 3/3] fsi/master-gpio: Add external mode Joel Stanley <joel@jms.id.au> - 2017-06-21 08:10 +0200
    Re: [PATCH 3/3] fsi/master-gpio: Add external mode Jeremy Kerr <jk@ozlabs.org> - 2017-06-22 00:10 +0200

#1671379 — Re: [PATCH 3/3] fsi/master-gpio: Add external mode

FromJoel Stanley <joel@jms.id.au>
Date2017-06-21 08:10 +0200
SubjectRe: [PATCH 3/3] fsi/master-gpio: Add external mode
Message-ID<tUGZY-2ml-7@gated-at.bofh.it>
Hi Jeremy,

On Mon, Jun 19, 2017 at 6:56 PM, Jeremy Kerr <jk@ozlabs.org> wrote:
> This change introduces an 'external mode' for GPIO-based FSI masters,
> +static ssize_t external_mode_show(struct device *dev,
> +               struct device_attribute *attr, char *buf)
> +{
> +       struct fsi_master_gpio *master = dev_get_drvdata(dev);
> +
> +       return snprintf(buf, PAGE_SIZE - 1, "%u",

I gave this a spin on a machine today and noticed we're missing a
newline there. Should this be "%u\n"?

Cheers,

Joel

> +                       master->external_mode ? 1 : 0);
> +}
> +

[toc] | [next] | [standalone]


#1672112

FromJeremy Kerr <jk@ozlabs.org>
Date2017-06-22 00:10 +0200
Message-ID<tUVZ0-3Vj-15@gated-at.bofh.it>
In reply to#1671379
Hi Joel,

>> +static ssize_t external_mode_show(struct device *dev,
>> +               struct device_attribute *attr, char *buf)
>> +{
>> +       struct fsi_master_gpio *master = dev_get_drvdata(dev);
>> +
>> +       return snprintf(buf, PAGE_SIZE - 1, "%u",
> 
> I gave this a spin on a machine today and noticed we're missing a
> newline there. Should this be "%u\n"?

Yep, that'd make things easier to read. v2 coming.

Cheers,


Jeremy

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web