Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1640257 > unrolled thread
| Started by | Xie Qirong <cheerx1994@gmail.com> |
|---|---|
| First post | 2017-05-12 09:40 +0200 |
| Last post | 2017-05-12 11:20 +0200 |
| Articles | 6 — 3 participants |
Back to article view | Back to linux.kernel
[PATCH] brcmfmac: btcoex: replace init_timer with setup_timer Xie Qirong <cheerx1994@gmail.com> - 2017-05-12 09:40 +0200
Re: [PATCH] brcmfmac: btcoex: replace init_timer with setup_timer Kalle Valo <kvalo@codeaurora.org> - 2017-05-12 10:30 +0200
Re: [PATCH] brcmfmac: btcoex: replace init_timer with setup_timer Arend van Spriel <arend.vanspriel@broadcom.com> - 2017-05-12 10:40 +0200
Re: [PATCH] brcmfmac: btcoex: replace init_timer with setup_timer Kalle Valo <kvalo@codeaurora.org> - 2017-05-12 11:00 +0200
Re: [PATCH] brcmfmac: btcoex: replace init_timer with setup_timer Arend van Spriel <arend.vanspriel@broadcom.com> - 2017-05-12 11:20 +0200
Re: [PATCH] brcmfmac: btcoex: replace init_timer with setup_timer Kalle Valo <kvalo@codeaurora.org> - 2017-05-12 11:20 +0200
| From | Xie Qirong <cheerx1994@gmail.com> |
|---|---|
| Date | 2017-05-12 09:40 +0200 |
| Subject | [PATCH] brcmfmac: btcoex: replace init_timer with setup_timer |
| Message-ID | <tGdl8-16h-13@gated-at.bofh.it> |
The combination of init_timer and setting up the data and function field manually is equivalent to calling setup_timer(). This is an api consolidation only and improves readability. Acked-by: Arend van Spriel <arend.vanspriel@broadcom.com> Signed-off-by: Xie Qirong <cheerx1994@gmail.com> --- setup_timer.cocci suggested the following improvement: drivers/net/wireless/broadcom/brcm80211/brcmfmac/btcoex.c:383:1-11: Use setup_timer function for function on line 384. Patch was compile checked with: x86_64_defconfig + CONFIG_BRCMFMAC=y + CONFIG_BRCMFMAC_USB=y + CONFIG_BRCMFMAC_PCIE=y + CONFIG_BRCM_TRACING=y + CONFIG_BRCMDBG=y Kernel version: 4.11.0 (localversion-next is next-20170512) drivers/net/wireless/broadcom/brcm80211/brcmfmac/btcoex.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/net/wireless/broadcom/brcm80211/brcmfmac/btcoex.c b/drivers/net/wireless/broadcom/brcm80211/brcmfmac/btcoex.c index 14a70d4b4e86..3559fb5b8fb0 100644 --- a/drivers/net/wireless/broadcom/brcm80211/brcmfmac/btcoex.c +++ b/drivers/net/wireless/broadcom/brcm80211/brcmfmac/btcoex.c @@ -380,9 +380,7 @@ int brcmf_btcoex_attach(struct brcmf_cfg80211_info *cfg) /* Set up timer for BT */ btci->timer_on = false; btci->timeout = BRCMF_BTCOEX_OPPR_WIN_TIME; - init_timer(&btci->timer); - btci->timer.data = (ulong)btci; - btci->timer.function = brcmf_btcoex_timerfunc; + setup_timer(&btci->timer, brcmf_btcoex_timerfunc, (ulong)btci); btci->cfg = cfg; btci->saved_regs_part1 = false; btci->saved_regs_part2 = false; -- 2.12.2
[toc] | [next] | [standalone]
| From | Kalle Valo <kvalo@codeaurora.org> |
|---|---|
| Date | 2017-05-12 10:30 +0200 |
| Message-ID | <tGe7w-1Ju-9@gated-at.bofh.it> |
| In reply to | #1640257 |
Xie Qirong <cheerx1994@gmail.com> writes: > The combination of init_timer and setting up the data and function field > manually is equivalent to calling setup_timer(). This is an api > consolidation only and improves readability. > > Acked-by: Arend van Spriel <arend.vanspriel@broadcom.com> > Signed-off-by: Xie Qirong <cheerx1994@gmail.com> > --- > > setup_timer.cocci suggested the following improvement: > drivers/net/wireless/broadcom/brcm80211/brcmfmac/btcoex.c:383:1-11: Use > setup_timer function for function on line 384. > > Patch was compile checked with: x86_64_defconfig + CONFIG_BRCMFMAC=y + > CONFIG_BRCMFMAC_USB=y + CONFIG_BRCMFMAC_PCIE=y + CONFIG_BRCM_TRACING=y + > CONFIG_BRCMDBG=y > > Kernel version: 4.11.0 (localversion-next is next-20170512) How is this different from the first version? https://patchwork.kernel.org/patch/9709467/ Always add patch version "[PATCH v2]" and a changelog. I added a section "Frequent problems" to the wiki to mention about these common problems: https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches#patch_version_missing https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches#changelog_missing -- Kalle Valo
[toc] | [prev] | [next] | [standalone]
| From | Arend van Spriel <arend.vanspriel@broadcom.com> |
|---|---|
| Date | 2017-05-12 10:40 +0200 |
| Message-ID | <tGehc-1Nr-21@gated-at.bofh.it> |
| In reply to | #1640308 |
On 5/12/2017 10:19 AM, Kalle Valo wrote: > Xie Qirong <cheerx1994@gmail.com> writes: > >> The combination of init_timer and setting up the data and function field >> manually is equivalent to calling setup_timer(). This is an api >> consolidation only and improves readability. >> >> Acked-by: Arend van Spriel <arend.vanspriel@broadcom.com> >> Signed-off-by: Xie Qirong <cheerx1994@gmail.com> >> --- >> >> setup_timer.cocci suggested the following improvement: >> drivers/net/wireless/broadcom/brcm80211/brcmfmac/btcoex.c:383:1-11: Use >> setup_timer function for function on line 384. >> >> Patch was compile checked with: x86_64_defconfig + CONFIG_BRCMFMAC=y + >> CONFIG_BRCMFMAC_USB=y + CONFIG_BRCMFMAC_PCIE=y + CONFIG_BRCM_TRACING=y + >> CONFIG_BRCMDBG=y >> >> Kernel version: 4.11.0 (localversion-next is next-20170512) > > How is this different from the first version? > > https://patchwork.kernel.org/patch/9709467/ Hi Kalle, This is actually the third version. You are referring to the not-specifically-named "v2" here, but how are you to know ;-) This third version is the same as v1 on which I commented to put the coccinelle output in the commit message. So I would still keep v2 if nothing else changed in v3 apart from my Acked-by: tag. Regards, Arend > Always add patch version "[PATCH v2]" and a changelog. I added a section > "Frequent problems" to the wiki to mention about these common problems: > > https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches#patch_version_missing > > https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches#changelog_missing >
[toc] | [prev] | [next] | [standalone]
| From | Kalle Valo <kvalo@codeaurora.org> |
|---|---|
| Date | 2017-05-12 11:00 +0200 |
| Message-ID | <tGeAx-1Vp-3@gated-at.bofh.it> |
| In reply to | #1640319 |
Arend van Spriel <arend.vanspriel@broadcom.com> writes: > On 5/12/2017 10:19 AM, Kalle Valo wrote: >> Xie Qirong <cheerx1994@gmail.com> writes: >> >>> The combination of init_timer and setting up the data and function field >>> manually is equivalent to calling setup_timer(). This is an api >>> consolidation only and improves readability. >>> >>> Acked-by: Arend van Spriel <arend.vanspriel@broadcom.com> >>> Signed-off-by: Xie Qirong <cheerx1994@gmail.com> >>> --- >>> >>> setup_timer.cocci suggested the following improvement: >>> drivers/net/wireless/broadcom/brcm80211/brcmfmac/btcoex.c:383:1-11: Use >>> setup_timer function for function on line 384. >>> >>> Patch was compile checked with: x86_64_defconfig + CONFIG_BRCMFMAC=y + >>> CONFIG_BRCMFMAC_USB=y + CONFIG_BRCMFMAC_PCIE=y + CONFIG_BRCM_TRACING=y + >>> CONFIG_BRCMDBG=y >>> >>> Kernel version: 4.11.0 (localversion-next is next-20170512) >> >> How is this different from the first version? >> >> https://patchwork.kernel.org/patch/9709467/ > > Hi Kalle, > > This is actually the third version. You are referring to the > not-specifically-named "v2" here, but how are you to know ;-) Exactly :) > This third version is the same as v1 on which I commented to put the > coccinelle output in the commit message. So I would still keep v2 if > nothing else changed in v3 apart from my Acked-by: tag. Ok, but I can easily take v3 (ie. this one) so that you get credit ;) -- Kalle Valo
[toc] | [prev] | [next] | [standalone]
| From | Arend van Spriel <arend.vanspriel@broadcom.com> |
|---|---|
| Date | 2017-05-12 11:20 +0200 |
| Message-ID | <tGeTT-2j8-1@gated-at.bofh.it> |
| In reply to | #1640326 |
On 5/12/2017 10:54 AM, Kalle Valo wrote: > Arend van Spriel <arend.vanspriel@broadcom.com> writes: > >> On 5/12/2017 10:19 AM, Kalle Valo wrote: >>> Xie Qirong <cheerx1994@gmail.com> writes: >>> >>>> The combination of init_timer and setting up the data and function field >>>> manually is equivalent to calling setup_timer(). This is an api >>>> consolidation only and improves readability. >>>> >>>> Acked-by: Arend van Spriel <arend.vanspriel@broadcom.com> >>>> Signed-off-by: Xie Qirong <cheerx1994@gmail.com> >>>> --- >>>> >>>> setup_timer.cocci suggested the following improvement: >>>> drivers/net/wireless/broadcom/brcm80211/brcmfmac/btcoex.c:383:1-11: Use >>>> setup_timer function for function on line 384. >>>> >>>> Patch was compile checked with: x86_64_defconfig + CONFIG_BRCMFMAC=y + >>>> CONFIG_BRCMFMAC_USB=y + CONFIG_BRCMFMAC_PCIE=y + CONFIG_BRCM_TRACING=y + >>>> CONFIG_BRCMDBG=y >>>> >>>> Kernel version: 4.11.0 (localversion-next is next-20170512) >>> >>> How is this different from the first version? >>> >>> https://patchwork.kernel.org/patch/9709467/ >> >> Hi Kalle, >> >> This is actually the third version. You are referring to the >> not-specifically-named "v2" here, but how are you to know ;-) > > Exactly :) > >> This third version is the same as v1 on which I commented to put the >> coccinelle output in the commit message. So I would still keep v2 if >> nothing else changed in v3 apart from my Acked-by: tag. > > Ok, but I can easily take v3 (ie. this one) so that you get credit ;) If you add the coccinelle output in the commit message, ie. above the '---' that would be great. So for both you have to do additional stuff provided you find it useful to have the coccinelle output. :-p Regards, Arend
[toc] | [prev] | [next] | [standalone]
| From | Kalle Valo <kvalo@codeaurora.org> |
|---|---|
| Date | 2017-05-12 11:20 +0200 |
| Message-ID | <tGeTU-2j8-15@gated-at.bofh.it> |
| In reply to | #1640335 |
Arend van Spriel <arend.vanspriel@broadcom.com> writes: >>> This third version is the same as v1 on which I commented to put the >>> coccinelle output in the commit message. So I would still keep v2 if >>> nothing else changed in v3 apart from my Acked-by: tag. >> >> Ok, but I can easily take v3 (ie. this one) so that you get credit ;) > > If you add the coccinelle output in the commit message, ie. above the > '---' that would be great. So for both you have to do additional stuff > provided you find it useful to have the coccinelle output. :-p Sure, I can add that. Thanks to my patchwork script it's actually pretty easy to edit commit logs before it commits them. If only I had time to implement a proper GTK interface for the script... -- Kalle Valo
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web