Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1640308

Re: [PATCH] brcmfmac: btcoex: replace init_timer with setup_timer

From Kalle Valo <kvalo@codeaurora.org>
Newsgroups linux.kernel
Subject Re: [PATCH] brcmfmac: btcoex: replace init_timer with setup_timer
Date 2017-05-12 10:30 +0200
Message-ID <tGe7w-1Ju-9@gated-at.bofh.it> (permalink)
References <tGdl8-16h-13@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Xie Qirong <cheerx1994@gmail.com> writes:

> The combination of init_timer and setting up the data and function field
> manually is equivalent to calling setup_timer(). This is an api
> consolidation only and improves readability.
>
> Acked-by: Arend van Spriel <arend.vanspriel@broadcom.com>
> Signed-off-by: Xie Qirong <cheerx1994@gmail.com>
> ---
>
>  setup_timer.cocci suggested the following improvement:
>  drivers/net/wireless/broadcom/brcm80211/brcmfmac/btcoex.c:383:1-11: Use
>  setup_timer function for function on line 384.
>
>  Patch was compile checked with: x86_64_defconfig + CONFIG_BRCMFMAC=y +
>  CONFIG_BRCMFMAC_USB=y + CONFIG_BRCMFMAC_PCIE=y + CONFIG_BRCM_TRACING=y +
>  CONFIG_BRCMDBG=y
>
>  Kernel version: 4.11.0 (localversion-next is next-20170512)

How is this different from the first version?

https://patchwork.kernel.org/patch/9709467/

Always add patch version "[PATCH v2]" and a changelog. I added a section
"Frequent problems" to the wiki to mention about these common problems:

https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches#patch_version_missing

https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches#changelog_missing

-- 
Kalle Valo

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH] brcmfmac: btcoex: replace init_timer with setup_timer Xie Qirong <cheerx1994@gmail.com> - 2017-05-12 09:40 +0200
  Re: [PATCH] brcmfmac: btcoex: replace init_timer with setup_timer Kalle Valo <kvalo@codeaurora.org> - 2017-05-12 10:30 +0200
    Re: [PATCH] brcmfmac: btcoex: replace init_timer with setup_timer Arend van Spriel <arend.vanspriel@broadcom.com> - 2017-05-12 10:40 +0200
      Re: [PATCH] brcmfmac: btcoex: replace init_timer with setup_timer Kalle Valo <kvalo@codeaurora.org> - 2017-05-12 11:00 +0200
        Re: [PATCH] brcmfmac: btcoex: replace init_timer with setup_timer Arend van Spriel <arend.vanspriel@broadcom.com> - 2017-05-12 11:20 +0200
          Re: [PATCH] brcmfmac: btcoex: replace init_timer with setup_timer Kalle Valo <kvalo@codeaurora.org> - 2017-05-12 11:20 +0200

csiph-web