Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1505003 > unrolled thread

Re: [PATCH v14 2/9] clocksource/drivers/arm_arch_timer: Add a new enum for spi type

Started byMark Rutland <mark.rutland@arm.com>
First post2016-10-20 17:20 +0200
Last post2016-10-26 10:30 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH v14 2/9] clocksource/drivers/arm_arch_timer: Add a new  enum for spi type Mark Rutland <mark.rutland@arm.com> - 2016-10-20 17:20 +0200
    Re: [PATCH v14 2/9] clocksource/drivers/arm_arch_timer: Add a new  enum for spi type Fu Wei <fu.wei@linaro.org> - 2016-10-26 10:30 +0200

#1505003 — Re: [PATCH v14 2/9] clocksource/drivers/arm_arch_timer: Add a new enum for spi type

FromMark Rutland <mark.rutland@arm.com>
Date2016-10-20 17:20 +0200
SubjectRe: [PATCH v14 2/9] clocksource/drivers/arm_arch_timer: Add a new enum for spi type
Message-ID<suniq-T1-17@gated-at.bofh.it>
On Thu, Sep 29, 2016 at 02:17:10AM +0800, fu.wei@linaro.org wrote:
> diff --git a/include/clocksource/arm_arch_timer.h b/include/clocksource/arm_arch_timer.h
> index 6f06481..16dcd10 100644
> --- a/include/clocksource/arm_arch_timer.h
> +++ b/include/clocksource/arm_arch_timer.h
> @@ -45,6 +45,12 @@ enum ppi_nr {
>  	MAX_TIMER_PPI
>  };
>  
> +enum spi_nr {
> +	PHYS_SPI,
> +	VIRT_SPI,
> +	MAX_TIMER_SPI
> +};

Please rename this to arch_timer_spi_nr (as with patch 1 for
s/ppi_nr/arch_timer_ppi_nr/). With that:

Acked-by: Mark Rutland <mark.rutland@arm.com>

Thanks,
Mark.

[toc] | [next] | [standalone]


#1508927

FromFu Wei <fu.wei@linaro.org>
Date2016-10-26 10:30 +0200
Message-ID<swrKW-14e-17@gated-at.bofh.it>
In reply to#1505003
Hi Mark,

On 20 October 2016 at 23:09, Mark Rutland <mark.rutland@arm.com> wrote:
> On Thu, Sep 29, 2016 at 02:17:10AM +0800, fu.wei@linaro.org wrote:
>> diff --git a/include/clocksource/arm_arch_timer.h b/include/clocksource/arm_arch_timer.h
>> index 6f06481..16dcd10 100644
>> --- a/include/clocksource/arm_arch_timer.h
>> +++ b/include/clocksource/arm_arch_timer.h
>> @@ -45,6 +45,12 @@ enum ppi_nr {
>>       MAX_TIMER_PPI
>>  };
>>
>> +enum spi_nr {
>> +     PHYS_SPI,
>> +     VIRT_SPI,
>> +     MAX_TIMER_SPI
>> +};
>
> Please rename this to arch_timer_spi_nr (as with patch 1 for
> s/ppi_nr/arch_timer_ppi_nr/). With that:
>
> Acked-by: Mark Rutland <mark.rutland@arm.com>

OK, NP, done :-)

Great thanks!

>
> Thanks,
> Mark.



-- 
Best regards,

Fu Wei
Software Engineer
Red Hat

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web