Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1498034 > unrolled thread

Re: [PATCH 4/4] virtio_blk: Rename a jump label in virtblk_get_id()

Started by"Michael S. Tsirkin" <mst@redhat.com>
First post2016-10-10 01:40 +0200
Last post2016-10-10 10:30 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH 4/4] virtio_blk: Rename a jump label in virtblk_get_id() "Michael S. Tsirkin" <mst@redhat.com> - 2016-10-10 01:40 +0200
    Re: virtio_blk: Rename a jump label in virtblk_get_id() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-10 10:30 +0200

#1498034 — Re: [PATCH 4/4] virtio_blk: Rename a jump label in virtblk_get_id()

From"Michael S. Tsirkin" <mst@redhat.com>
Date2016-10-10 01:40 +0200
SubjectRe: [PATCH 4/4] virtio_blk: Rename a jump label in virtblk_get_id()
Message-ID<sqvRf-28d-1@gated-at.bofh.it>
On Tue, Sep 13, 2016 at 02:15:20PM +0200, SF Markus Elfring wrote:
> From: Markus Elfring <elfring@users.sourceforge.net>
> Date: Tue, 13 Sep 2016 13:50:56 +0200
> 
> Adjust a jump label according to the current Linux coding style convention.
> 
> Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>

Please don't send me such patches, I'm not really
interested in renaming labels unless it clearly adds
to a significant improvement in readability.

> ---
>  drivers/block/virtio_blk.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/block/virtio_blk.c b/drivers/block/virtio_blk.c
> index 696f452..fef2bd0 100644
> --- a/drivers/block/virtio_blk.c
> +++ b/drivers/block/virtio_blk.c
> @@ -247,10 +247,10 @@ static int virtblk_get_id(struct gendisk *disk, char *id_str)
>  
>  	err = blk_rq_map_kern(q, req, id_str, VIRTIO_BLK_ID_BYTES, GFP_KERNEL);
>  	if (err)
> -		goto out;
> +		goto put_request;
>  
>  	err = blk_execute_rq(vblk->disk->queue, vblk->disk, req, false);
> -out:
> + put_request:
>  	blk_put_request(req);
>  	return err;
>  }
> -- 
> 2.10.0

[toc] | [next] | [standalone]


#1498164 — Re: virtio_blk: Rename a jump label in virtblk_get_id()

FromSF Markus Elfring <elfring@users.sourceforge.net>
Date2016-10-10 10:30 +0200
SubjectRe: virtio_blk: Rename a jump label in virtblk_get_id()
Message-ID<sqE89-7l8-25@gated-at.bofh.it>
In reply to#1498034
> Please don't send me such patches, I'm not really interested in renaming labels

Thanks for your feedback.


> unless it clearly adds to a significant improvement in readability.

Have you got any more concrete conditions for the selection of appropriate
identifiers in this use case according to your software development view?

Regards,
Markus

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web