Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1470167 > unrolled thread
| Started by | Javier Martinez Canillas <javier@osg.samsung.com> |
|---|---|
| First post | 2016-08-25 16:00 +0200 |
| Last post | 2016-09-02 01:50 +0200 |
| Articles | 4 — 2 participants |
Back to article view | Back to linux.kernel
[RESEND PATCH] staging: octeon: Use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-25 16:00 +0200
Re: [RESEND PATCH] staging: octeon: Use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-26 01:00 +0200
Re: [RESEND PATCH] staging: octeon: Use IS_ENABLED() instead of checking for built-in or module Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2016-09-01 17:40 +0200
Re: [RESEND PATCH] staging: octeon: Use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-09-02 01:50 +0200
| From | Javier Martinez Canillas <javier@osg.samsung.com> |
|---|---|
| Date | 2016-08-25 16:00 +0200 |
| Subject | [RESEND PATCH] staging: octeon: Use IS_ENABLED() instead of checking for built-in or module |
| Message-ID | <sa3mh-1Ej-17@gated-at.bofh.it> |
The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
built-in or as a module, use that macro instead of open coding the same.
Using the macro makes the code more readable by helping abstract away some
of the Kconfig built-in and module enable details.
Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>
Acked-by: David Daney <david.daney@cavium.com>
---
Changes since first post:
- Added David Daney Acked-by tag.
- Rebased on top of latest master.
drivers/staging/octeon/ethernet.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/octeon/ethernet.c b/drivers/staging/octeon/ethernet.c
index 2eb97317f631..a473f034b01a 100644
--- a/drivers/staging/octeon/ethernet.c
+++ b/drivers/staging/octeon/ethernet.c
@@ -237,7 +237,7 @@ static int cvm_oct_common_change_mtu(struct net_device *dev, int new_mtu)
{
struct octeon_ethernet *priv = netdev_priv(dev);
int interface = INTERFACE(priv->port);
-#if defined(CONFIG_VLAN_8021Q) || defined(CONFIG_VLAN_8021Q_MODULE)
+#if IS_ENABLED(CONFIG_VLAN_8021Q)
int vlan_bytes = 4;
#else
int vlan_bytes = 0;
--
2.5.5
[toc] | [next] | [standalone]
| From | Javier Martinez Canillas <javier@osg.samsung.com> |
|---|---|
| Date | 2016-08-26 01:00 +0200 |
| Subject | Re: [RESEND PATCH] staging: octeon: Use IS_ENABLED() instead of checking for built-in or module |
| Message-ID | <sabMS-7d8-23@gated-at.bofh.it> |
| In reply to | #1470167 |
Hello David, On 08/25/2016 12:01 PM, David Daney wrote: > On 08/25/2016 06:55 AM, Javier Martinez Canillas wrote: >> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either >> built-in or as a module, use that macro instead of open coding the same. >> >> Using the macro makes the code more readable by helping abstract away some >> of the Kconfig built-in and module enable details. >> >> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com> >> Acked-by: David Daney <david.daney@cavium.com> >> >> --- >> >> Changes since first post: >> - Added David Daney Acked-by tag. >> - Rebased on top of latest master. >> > > You changed something about the patch. In this case the Subject is not "RESEND", but rather "v2". Incorrect Subject lines like this can lead to the patch being inadvertently ignored. > Yes, in fact I thought about adding a v2 suffix instead of RESEND but since I didn't change the patch content (besides merge conflicts resolution), I preferred to add the latter. I can re-spin the patch if that's an issue. > David Daney > Best regards, -- Javier Martinez Canillas Open Source Group Samsung Research America
[toc] | [prev] | [next] | [standalone]
| From | Greg Kroah-Hartman <gregkh@linuxfoundation.org> |
|---|---|
| Date | 2016-09-01 17:40 +0200 |
| Subject | Re: [RESEND PATCH] staging: octeon: Use IS_ENABLED() instead of checking for built-in or module |
| Message-ID | <scCfT-3EJ-17@gated-at.bofh.it> |
| In reply to | #1470482 |
On Thu, Aug 25, 2016 at 06:56:07PM -0400, Javier Martinez Canillas wrote: > Hello David, > > On 08/25/2016 12:01 PM, David Daney wrote: > > On 08/25/2016 06:55 AM, Javier Martinez Canillas wrote: > >> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either > >> built-in or as a module, use that macro instead of open coding the same. > >> > >> Using the macro makes the code more readable by helping abstract away some > >> of the Kconfig built-in and module enable details. > >> > >> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com> > >> Acked-by: David Daney <david.daney@cavium.com> > >> > >> --- > >> > >> Changes since first post: > >> - Added David Daney Acked-by tag. > >> - Rebased on top of latest master. > >> > > > > You changed something about the patch. In this case the Subject is not "RESEND", but rather "v2". Incorrect Subject lines like this can lead to the patch being inadvertently ignored. > > > > Yes, in fact I thought about adding a v2 suffix instead of RESEND but since > I didn't change the patch content (besides merge conflicts resolution), I > preferred to add the latter. > > I can re-spin the patch if that's an issue. Please do. thanks, greg k-h
[toc] | [prev] | [next] | [standalone]
| From | Javier Martinez Canillas <javier@osg.samsung.com> |
|---|---|
| Date | 2016-09-02 01:50 +0200 |
| Subject | Re: [RESEND PATCH] staging: octeon: Use IS_ENABLED() instead of checking for built-in or module |
| Message-ID | <scJU6-8tP-25@gated-at.bofh.it> |
| In reply to | #1474493 |
On 09/01/2016 05:32 PM, Greg Kroah-Hartman wrote: > On Thu, Aug 25, 2016 at 06:56:07PM -0400, Javier Martinez Canillas wrote: >> Hello David, >> >> On 08/25/2016 12:01 PM, David Daney wrote: >>> On 08/25/2016 06:55 AM, Javier Martinez Canillas wrote: >>>> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either >>>> built-in or as a module, use that macro instead of open coding the same. >>>> >>>> Using the macro makes the code more readable by helping abstract away some >>>> of the Kconfig built-in and module enable details. >>>> >>>> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com> >>>> Acked-by: David Daney <david.daney@cavium.com> >>>> >>>> --- >>>> >>>> Changes since first post: >>>> - Added David Daney Acked-by tag. >>>> - Rebased on top of latest master. >>>> >>> >>> You changed something about the patch. In this case the Subject is not "RESEND", but rather "v2". Incorrect Subject lines like this can lead to the patch being inadvertently ignored. >>> >> >> Yes, in fact I thought about adding a v2 suffix instead of RESEND but since >> I didn't change the patch content (besides merge conflicts resolution), I >> preferred to add the latter. >> >> I can re-spin the patch if that's an issue. > > Please do. > Done. > thanks, > > greg k-h > Best regards, -- Javier Martinez Canillas Open Source Group Samsung Research America
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web