Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1470482
| From | Javier Martinez Canillas <javier@osg.samsung.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RESEND PATCH] staging: octeon: Use IS_ENABLED() instead of checking for built-in or module |
| Date | 2016-08-26 01:00 +0200 |
| Message-ID | <sabMS-7d8-23@gated-at.bofh.it> (permalink) |
| References | <sa3mh-1Ej-17@gated-at.bofh.it> <sabMS-7d8-25@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hello David, On 08/25/2016 12:01 PM, David Daney wrote: > On 08/25/2016 06:55 AM, Javier Martinez Canillas wrote: >> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either >> built-in or as a module, use that macro instead of open coding the same. >> >> Using the macro makes the code more readable by helping abstract away some >> of the Kconfig built-in and module enable details. >> >> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com> >> Acked-by: David Daney <david.daney@cavium.com> >> >> --- >> >> Changes since first post: >> - Added David Daney Acked-by tag. >> - Rebased on top of latest master. >> > > You changed something about the patch. In this case the Subject is not "RESEND", but rather "v2". Incorrect Subject lines like this can lead to the patch being inadvertently ignored. > Yes, in fact I thought about adding a v2 suffix instead of RESEND but since I didn't change the patch content (besides merge conflicts resolution), I preferred to add the latter. I can re-spin the patch if that's an issue. > David Daney > Best regards, -- Javier Martinez Canillas Open Source Group Samsung Research America
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[RESEND PATCH] staging: octeon: Use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-25 16:00 +0200
Re: [RESEND PATCH] staging: octeon: Use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-26 01:00 +0200
Re: [RESEND PATCH] staging: octeon: Use IS_ENABLED() instead of checking for built-in or module Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2016-09-01 17:40 +0200
Re: [RESEND PATCH] staging: octeon: Use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-09-02 01:50 +0200
csiph-web