Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1545730 > unrolled thread

Re: [PATCH 03/15] hyperv: use standard bitops

Started byOlaf Hering <olaf@aepfle.de>
First post2016-12-21 13:10 +0100
Last post2016-12-22 13:40 +0100
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH 03/15] hyperv: use standard bitops Olaf Hering <olaf@aepfle.de> - 2016-12-21 13:10 +0100
    Re: [PATCH 03/15] hyperv: use standard bitops Paolo Bonzini <pbonzini@redhat.com> - 2016-12-22 13:40 +0100

#1545730 — Re: [PATCH 03/15] hyperv: use standard bitops

FromOlaf Hering <olaf@aepfle.de>
Date2016-12-21 13:10 +0100
SubjectRe: [PATCH 03/15] hyperv: use standard bitops
Message-ID<sQNSx-3fG-5@gated-at.bofh.it>

[Multipart message — attachments visible in raw view] — view raw

On Tue, Dec 20, Roman Kagan wrote:

Reverting commit 22356585712d ("staging: hv: use sync_bitops when
interacting with the hypervisor") is save because .......

> -		sync_set_bit(channel->monitor_bit,
> +		set_bit(channel->monitor_bit,


Olaf

[toc] | [next] | [standalone]


#1546309

FromPaolo Bonzini <pbonzini@redhat.com>
Date2016-12-22 13:40 +0100
Message-ID<sRaP8-140-27@gated-at.bofh.it>
In reply to#1545730

On 21/12/2016 14:23, Roman Kagan wrote:
> On Wed, Dec 21, 2016 at 01:00:44PM +0100, Olaf Hering wrote:
>> On Tue, Dec 20, Roman Kagan wrote:
>>
>> Reverting commit 22356585712d ("staging: hv: use sync_bitops when
>> interacting with the hypervisor") is save because .......
>>
>>> -		sync_set_bit(channel->monitor_bit,
>>> +		set_bit(channel->monitor_bit,
> 
> It isn't indeed.  I didn't realize there was a UP case where it made a
> difference, and failed to locate the commit where it changed.
> 
> I'll drop this part, thanks.

Perhaps the sync_bitops should be renamed to virt_bitops.  This would
match virt_* memory barriers and would make their usage much more obvious.

Paolo

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web