Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1542477 > unrolled thread
| Started by | "Jason A. Donenfeld" <Jason@zx2c4.com> |
|---|---|
| First post | 2016-12-15 06:00 +0100 |
| Last post | 2016-12-15 10:00 +0100 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
[PATCH] kref: prefer atomic_inc_not_zero to atomic_add_unless "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-15 06:00 +0100
Re: [PATCH] kref: prefer atomic_inc_not_zero to atomic_add_unless Christoph Hellwig <hch@infradead.org> - 2016-12-15 10:00 +0100
| From | "Jason A. Donenfeld" <Jason@zx2c4.com> |
|---|---|
| Date | 2016-12-15 06:00 +0100 |
| Subject | [PATCH] kref: prefer atomic_inc_not_zero to atomic_add_unless |
| Message-ID | <sOwj7-1j4-7@gated-at.bofh.it> |
On most platforms, there exists this ifdef:
#define atomic_inc_not_zero(v) atomic_add_unless((v), 1, 0)
This makes this patch functionally useless. However, on PPC, there is
actually an explicit definition of atomic_inc_not_zero with its own
assembly that is slightly more optimized than atomic_add_unless. So,
this patch changes kref to use atomic_inc_not_zero instead, for PPC and
any future platforms that might provide an explicit implementation.
This also puts this usage of kref more in line with a verbatim reading
of the examples in Paul McKenney's paper [1] in the section titled "2.4
Atomic Counting With Check and Release Memory Barrier", which uses
atomic_inc_not_zero.
[1] http://open-std.org/jtc1/sc22/wg21/docs/papers/2007/n2167.pdf
Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
Reviewed-by: Thomas Hellstrom <thellstrom@vmware.com>
---
This was reviewed favorably 14 months ago but never picked up.
I'm resubmitting it now in hopes that you can finally queue it
up for 4.10.
include/linux/kref.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/linux/kref.h b/include/linux/kref.h
index e15828fd71f1..62f0a84ae94e 100644
--- a/include/linux/kref.h
+++ b/include/linux/kref.h
@@ -133,6 +133,6 @@ static inline int kref_put_mutex(struct kref *kref,
*/
static inline int __must_check kref_get_unless_zero(struct kref *kref)
{
- return atomic_add_unless(&kref->refcount, 1, 0);
+ return atomic_inc_not_zero(&kref->refcount);
}
#endif /* _KREF_H_ */
--
2.11.0
[toc] | [next] | [standalone]
| From | Christoph Hellwig <hch@infradead.org> |
|---|---|
| Date | 2016-12-15 10:00 +0100 |
| Message-ID | <sOA3n-3DP-13@gated-at.bofh.it> |
| In reply to | #1542477 |
It's also way easier to read using atomic_inc_not_zero.. Reviewed-by: Christoph Hellwig <hch@lst.de> Not sure you're sending this to the right maintainers, though. You probably want to include Greg.
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web