Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1521366 > unrolled thread

[PATCH] cpufreq: conservative: Rename get_freq_target() to get_freq_step()

Started byViresh Kumar <viresh.kumar@linaro.org>
First post2016-11-14 08:10 +0100
Last post2016-11-24 02:20 +0100
Articles 2 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH] cpufreq: conservative: Rename get_freq_target() to get_freq_step() Viresh Kumar <viresh.kumar@linaro.org> - 2016-11-14 08:10 +0100
    Re: [PATCH] cpufreq: conservative: Rename get_freq_target() to get_freq_step() "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2016-11-24 02:20 +0100

#1521366 — [PATCH] cpufreq: conservative: Rename get_freq_target() to get_freq_step()

FromViresh Kumar <viresh.kumar@linaro.org>
Date2016-11-14 08:10 +0100
Subject[PATCH] cpufreq: conservative: Rename get_freq_target() to get_freq_step()
Message-ID<sDjyW-3JZ-15@gated-at.bofh.it>
What's returned from this function is the delta by which the frequency
must be increased or decreased and not the final frequency that should
be selected.

Name it properly to match its purpose. Also update the variables used to
store that value.

Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org>
---
 drivers/cpufreq/cpufreq_conservative.c | 22 +++++++++++-----------
 1 file changed, 11 insertions(+), 11 deletions(-)

diff --git a/drivers/cpufreq/cpufreq_conservative.c b/drivers/cpufreq/cpufreq_conservative.c
index fa5ece3915a1..0681fcff5aae 100644
--- a/drivers/cpufreq/cpufreq_conservative.c
+++ b/drivers/cpufreq/cpufreq_conservative.c
@@ -37,16 +37,16 @@ struct cs_dbs_tuners {
 #define DEF_SAMPLING_DOWN_FACTOR		(1)
 #define MAX_SAMPLING_DOWN_FACTOR		(10)
 
-static inline unsigned int get_freq_target(struct cs_dbs_tuners *cs_tuners,
-					   struct cpufreq_policy *policy)
+static inline unsigned int get_freq_step(struct cs_dbs_tuners *cs_tuners,
+					 struct cpufreq_policy *policy)
 {
-	unsigned int freq_target = (cs_tuners->freq_step * policy->max) / 100;
+	unsigned int freq_step = (cs_tuners->freq_step * policy->max) / 100;
 
 	/* max freq cannot be less than 100. But who knows... */
-	if (unlikely(freq_target == 0))
-		freq_target = DEF_FREQUENCY_STEP;
+	if (unlikely(freq_step == 0))
+		freq_step = DEF_FREQUENCY_STEP;
 
-	return freq_target;
+	return freq_step;
 }
 
 /*
@@ -90,7 +90,7 @@ static unsigned int cs_dbs_update(struct cpufreq_policy *policy)
 		if (requested_freq == policy->max)
 			goto out;
 
-		requested_freq += get_freq_target(cs_tuners, policy);
+		requested_freq += get_freq_step(cs_tuners, policy);
 		if (requested_freq > policy->max)
 			requested_freq = policy->max;
 
@@ -106,16 +106,16 @@ static unsigned int cs_dbs_update(struct cpufreq_policy *policy)
 
 	/* Check for frequency decrease */
 	if (load < cs_tuners->down_threshold) {
-		unsigned int freq_target;
+		unsigned int freq_step;
 		/*
 		 * if we cannot reduce the frequency anymore, break out early
 		 */
 		if (requested_freq == policy->min)
 			goto out;
 
-		freq_target = get_freq_target(cs_tuners, policy);
-		if (requested_freq > freq_target)
-			requested_freq -= freq_target;
+		freq_step = get_freq_step(cs_tuners, policy);
+		if (requested_freq > freq_step)
+			requested_freq -= freq_step;
 		else
 			requested_freq = policy->min;
 
-- 
2.7.1.410.g6faf27b

[toc] | [next] | [standalone]


#1528913

From"Rafael J. Wysocki" <rjw@rjwysocki.net>
Date2016-11-24 02:20 +0100
Message-ID<sGQRI-41E-9@gated-at.bofh.it>
In reply to#1521366
On Monday, November 14, 2016 12:30:43 PM Viresh Kumar wrote:
> What's returned from this function is the delta by which the frequency
> must be increased or decreased and not the final frequency that should
> be selected.
> 
> Name it properly to match its purpose. Also update the variables used to
> store that value.
> 
> Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org>

Applied.

Thanks,
Rafael

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web