Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1466789 > unrolled thread
| Started by | SF Markus Elfring <elfring@users.sourceforge.net> |
|---|---|
| First post | 2016-08-20 09:30 +0200 |
| Last post | 2016-08-21 04:20 +0200 |
| Articles | 8 — 5 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
[PATCH 0/2] tun: Fine-tuning for update_filter() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-08-20 09:30 +0200
[PATCH 2/2] tun: Rename a jump label in update_filter() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-08-20 09:40 +0200
Re: [PATCH 2/2] tun: Rename a jump label in update_filter() "Michael S. Tsirkin" <mst@redhat.com> - 2016-08-22 03:50 +0200
Re: [PATCH 2/2] tun: Rename a jump label in update_filter() Mike Rapoport <rppt@linux.vnet.ibm.com> - 2016-08-22 07:30 +0200
[PATCH 1/2] tun: Use memdup_user() rather than duplicating its implementation SF Markus Elfring <elfring@users.sourceforge.net> - 2016-08-20 09:40 +0200
Re: [PATCH 1/2] tun: Use memdup_user() rather than duplicating its implementation Shmulik Ladkani <shmulik.ladkani@gmail.com> - 2016-08-20 13:50 +0200
Re: [PATCH 1/2] tun: Use memdup_user() rather than duplicating its implementation "Michael S. Tsirkin" <mst@redhat.com> - 2016-08-22 03:50 +0200
Re: [PATCH 0/2] tun: Fine-tuning for update_filter() David Miller <davem@davemloft.net> - 2016-08-21 04:20 +0200
| From | SF Markus Elfring <elfring@users.sourceforge.net> |
|---|---|
| Date | 2016-08-20 09:30 +0200 |
| Subject | [PATCH 0/2] tun: Fine-tuning for update_filter() |
| Message-ID | <s88T7-8qJ-1@gated-at.bofh.it> |
From: Markus Elfring <elfring@users.sourceforge.net> Date: Sat, 20 Aug 2016 09:16:16 +0200 A few update suggestions were taken into account from static source code analysis. Markus Elfring (2): Use memdup_user() Rename a jump label drivers/net/tun.c | 16 +++++----------- 1 file changed, 5 insertions(+), 11 deletions(-) -- 2.9.3
[toc] | [next] | [standalone]
| From | SF Markus Elfring <elfring@users.sourceforge.net> |
|---|---|
| Date | 2016-08-20 09:40 +0200 |
| Subject | [PATCH 2/2] tun: Rename a jump label in update_filter() |
| Message-ID | <s892N-8tA-1@gated-at.bofh.it> |
| In reply to | #1466789 |
From: Markus Elfring <elfring@users.sourceforge.net>
Date: Sat, 20 Aug 2016 09:00:34 +0200
Adjust a jump target according to the Linux coding style convention.
Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
---
drivers/net/tun.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/net/tun.c b/drivers/net/tun.c
index a1aeccb..e249428 100644
--- a/drivers/net/tun.c
+++ b/drivers/net/tun.c
@@ -753,7 +753,7 @@ static int update_filter(struct tap_filter *filter, void __user *arg)
for (; n < uf.count; n++) {
if (!is_multicast_ether_addr(addr[n].u)) {
err = 0; /* no filter */
- goto done;
+ goto free_addr;
}
addr_hash_set(filter->mask, addr[n].u);
}
@@ -769,8 +769,7 @@ static int update_filter(struct tap_filter *filter, void __user *arg)
/* Return the number of exact filters */
err = nexact;
-
-done:
+free_addr:
kfree(addr);
return err;
}
--
2.9.3
[toc] | [prev] | [next] | [standalone]
| From | "Michael S. Tsirkin" <mst@redhat.com> |
|---|---|
| Date | 2016-08-22 03:50 +0200 |
| Subject | Re: [PATCH 2/2] tun: Rename a jump label in update_filter() |
| Message-ID | <s8Mxb-84P-5@gated-at.bofh.it> |
| In reply to | #1466792 |
On Sat, Aug 20, 2016 at 09:37:16AM +0200, SF Markus Elfring wrote:
> From: Markus Elfring <elfring@users.sourceforge.net>
> Date: Sat, 20 Aug 2016 09:00:34 +0200
>
> Adjust a jump target according to the Linux coding style convention.
>
> Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
I don't have an opinion of this one. Which convention do you refer to?
> ---
> drivers/net/tun.c | 5 ++---
> 1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/net/tun.c b/drivers/net/tun.c
> index a1aeccb..e249428 100644
> --- a/drivers/net/tun.c
> +++ b/drivers/net/tun.c
> @@ -753,7 +753,7 @@ static int update_filter(struct tap_filter *filter, void __user *arg)
> for (; n < uf.count; n++) {
> if (!is_multicast_ether_addr(addr[n].u)) {
> err = 0; /* no filter */
> - goto done;
> + goto free_addr;
> }
> addr_hash_set(filter->mask, addr[n].u);
> }
> @@ -769,8 +769,7 @@ static int update_filter(struct tap_filter *filter, void __user *arg)
>
> /* Return the number of exact filters */
> err = nexact;
> -
> -done:
> +free_addr:
> kfree(addr);
> return err;
> }
> --
> 2.9.3
[toc] | [prev] | [next] | [standalone]
| From | Mike Rapoport <rppt@linux.vnet.ibm.com> |
|---|---|
| Date | 2016-08-22 07:30 +0200 |
| Subject | Re: [PATCH 2/2] tun: Rename a jump label in update_filter() |
| Message-ID | <s8PY5-22v-1@gated-at.bofh.it> |
| In reply to | #1467301 |
On Mon, Aug 22, 2016 at 04:41:11AM +0300, Michael S. Tsirkin wrote:
> On Sat, Aug 20, 2016 at 09:37:16AM +0200, SF Markus Elfring wrote:
> > From: Markus Elfring <elfring@users.sourceforge.net>
> > Date: Sat, 20 Aug 2016 09:00:34 +0200
> >
> > Adjust a jump target according to the Linux coding style convention.
> >
> > Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
>
> I don't have an opinion of this one. Which convention do you refer to?
Citing Documentation/CodingStyle:
Choose label names which say what the goto does or why the goto exists. An
example of a good name could be "out_buffer:" if the goto frees "buffer".
Avoid using GW-BASIC names like "err1:" and "err2:". Also don't name them after
the goto location like "err_kmalloc_failed:"
>
> > ---
> > drivers/net/tun.c | 5 ++---
> > 1 file changed, 2 insertions(+), 3 deletions(-)
> >
> > diff --git a/drivers/net/tun.c b/drivers/net/tun.c
> > index a1aeccb..e249428 100644
> > --- a/drivers/net/tun.c
> > +++ b/drivers/net/tun.c
> > @@ -753,7 +753,7 @@ static int update_filter(struct tap_filter *filter, void __user *arg)
> > for (; n < uf.count; n++) {
> > if (!is_multicast_ether_addr(addr[n].u)) {
> > err = 0; /* no filter */
> > - goto done;
> > + goto free_addr;
> > }
> > addr_hash_set(filter->mask, addr[n].u);
> > }
> > @@ -769,8 +769,7 @@ static int update_filter(struct tap_filter *filter, void __user *arg)
> >
> > /* Return the number of exact filters */
> > err = nexact;
> > -
> > -done:
> > +free_addr:
> > kfree(addr);
> > return err;
> > }
> > --
> > 2.9.3
>
[toc] | [prev] | [next] | [standalone]
| From | SF Markus Elfring <elfring@users.sourceforge.net> |
|---|---|
| Date | 2016-08-20 09:40 +0200 |
| Subject | [PATCH 1/2] tun: Use memdup_user() rather than duplicating its implementation |
| Message-ID | <s892N-8tA-3@gated-at.bofh.it> |
| In reply to | #1466789 |
From: Markus Elfring <elfring@users.sourceforge.net>
Date: Sat, 20 Aug 2016 08:54:15 +0200
Reuse existing functionality from memdup_user() instead of keeping
duplicate source code.
This issue was detected by using the Coccinelle software.
Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
---
drivers/net/tun.c | 11 +++--------
1 file changed, 3 insertions(+), 8 deletions(-)
diff --git a/drivers/net/tun.c b/drivers/net/tun.c
index 9c8b5bc..a1aeccb 100644
--- a/drivers/net/tun.c
+++ b/drivers/net/tun.c
@@ -731,14 +731,9 @@ static int update_filter(struct tap_filter *filter, void __user *arg)
}
alen = ETH_ALEN * uf.count;
- addr = kmalloc(alen, GFP_KERNEL);
- if (!addr)
- return -ENOMEM;
-
- if (copy_from_user(addr, arg + sizeof(uf), alen)) {
- err = -EFAULT;
- goto done;
- }
+ addr = memdup_user(arg + sizeof(uf), alen);
+ if (IS_ERR(addr))
+ return PTR_ERR(addr);
/* The filter is updated without holding any locks. Which is
* perfectly safe. We disable it first and in the worst
--
2.9.3
[toc] | [prev] | [next] | [standalone]
| From | Shmulik Ladkani <shmulik.ladkani@gmail.com> |
|---|---|
| Date | 2016-08-20 13:50 +0200 |
| Subject | Re: [PATCH 1/2] tun: Use memdup_user() rather than duplicating its implementation |
| Message-ID | <s8cWJ-2p6-1@gated-at.bofh.it> |
| In reply to | #1466793 |
Hi, On Sat, 20 Aug 2016 09:34:56 +0200 SF Markus Elfring <elfring@users.sourceforge.net> wrote: > From: Markus Elfring <elfring@users.sourceforge.net> > Date: Sat, 20 Aug 2016 08:54:15 +0200 > > Reuse existing functionality from memdup_user() instead of keeping > duplicate source code. > > This issue was detected by using the Coccinelle software. > > Signed-off-by: Markus Elfring <elfring@users.sourceforge.net> Reviewed-by: Shmulik Ladkani <shmulik.ladkani@gmail.com>
[toc] | [prev] | [next] | [standalone]
| From | "Michael S. Tsirkin" <mst@redhat.com> |
|---|---|
| Date | 2016-08-22 03:50 +0200 |
| Subject | Re: [PATCH 1/2] tun: Use memdup_user() rather than duplicating its implementation |
| Message-ID | <s8Mxb-84P-13@gated-at.bofh.it> |
| In reply to | #1466793 |
On Sat, Aug 20, 2016 at 09:34:56AM +0200, SF Markus Elfring wrote:
> From: Markus Elfring <elfring@users.sourceforge.net>
> Date: Sat, 20 Aug 2016 08:54:15 +0200
>
> Reuse existing functionality from memdup_user() instead of keeping
> duplicate source code.
>
> This issue was detected by using the Coccinelle software.
>
> Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
Acked-by: Michael S. Tsirkin <mst@redhat.com>
> ---
> drivers/net/tun.c | 11 +++--------
> 1 file changed, 3 insertions(+), 8 deletions(-)
>
> diff --git a/drivers/net/tun.c b/drivers/net/tun.c
> index 9c8b5bc..a1aeccb 100644
> --- a/drivers/net/tun.c
> +++ b/drivers/net/tun.c
> @@ -731,14 +731,9 @@ static int update_filter(struct tap_filter *filter, void __user *arg)
> }
>
> alen = ETH_ALEN * uf.count;
> - addr = kmalloc(alen, GFP_KERNEL);
> - if (!addr)
> - return -ENOMEM;
> -
> - if (copy_from_user(addr, arg + sizeof(uf), alen)) {
> - err = -EFAULT;
> - goto done;
> - }
> + addr = memdup_user(arg + sizeof(uf), alen);
> + if (IS_ERR(addr))
> + return PTR_ERR(addr);
>
> /* The filter is updated without holding any locks. Which is
> * perfectly safe. We disable it first and in the worst
> --
> 2.9.3
[toc] | [prev] | [next] | [standalone]
| From | David Miller <davem@davemloft.net> |
|---|---|
| Date | 2016-08-21 04:20 +0200 |
| Message-ID | <s8qwF-2Ob-1@gated-at.bofh.it> |
| In reply to | #1466789 |
From: SF Markus Elfring <elfring@users.sourceforge.net> Date: Sat, 20 Aug 2016 09:27:39 +0200 > A few update suggestions were taken into account > from static source code analysis. Series applied.
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web