Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1467372
| From | Mike Rapoport <rppt@linux.vnet.ibm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 2/2] tun: Rename a jump label in update_filter() |
| Date | 2016-08-22 07:30 +0200 |
| Message-ID | <s8PY5-22v-1@gated-at.bofh.it> (permalink) |
| References | <qEuGl-43C-5@gated-at.bofh.it> <s88T7-8qJ-1@gated-at.bofh.it> <s892N-8tA-1@gated-at.bofh.it> <s8Mxb-84P-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, Aug 22, 2016 at 04:41:11AM +0300, Michael S. Tsirkin wrote:
> On Sat, Aug 20, 2016 at 09:37:16AM +0200, SF Markus Elfring wrote:
> > From: Markus Elfring <elfring@users.sourceforge.net>
> > Date: Sat, 20 Aug 2016 09:00:34 +0200
> >
> > Adjust a jump target according to the Linux coding style convention.
> >
> > Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
>
> I don't have an opinion of this one. Which convention do you refer to?
Citing Documentation/CodingStyle:
Choose label names which say what the goto does or why the goto exists. An
example of a good name could be "out_buffer:" if the goto frees "buffer".
Avoid using GW-BASIC names like "err1:" and "err2:". Also don't name them after
the goto location like "err_kmalloc_failed:"
>
> > ---
> > drivers/net/tun.c | 5 ++---
> > 1 file changed, 2 insertions(+), 3 deletions(-)
> >
> > diff --git a/drivers/net/tun.c b/drivers/net/tun.c
> > index a1aeccb..e249428 100644
> > --- a/drivers/net/tun.c
> > +++ b/drivers/net/tun.c
> > @@ -753,7 +753,7 @@ static int update_filter(struct tap_filter *filter, void __user *arg)
> > for (; n < uf.count; n++) {
> > if (!is_multicast_ether_addr(addr[n].u)) {
> > err = 0; /* no filter */
> > - goto done;
> > + goto free_addr;
> > }
> > addr_hash_set(filter->mask, addr[n].u);
> > }
> > @@ -769,8 +769,7 @@ static int update_filter(struct tap_filter *filter, void __user *arg)
> >
> > /* Return the number of exact filters */
> > err = nexact;
> > -
> > -done:
> > +free_addr:
> > kfree(addr);
> > return err;
> > }
> > --
> > 2.9.3
>
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/2] tun: Fine-tuning for update_filter() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-08-20 09:30 +0200
[PATCH 2/2] tun: Rename a jump label in update_filter() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-08-20 09:40 +0200
Re: [PATCH 2/2] tun: Rename a jump label in update_filter() "Michael S. Tsirkin" <mst@redhat.com> - 2016-08-22 03:50 +0200
Re: [PATCH 2/2] tun: Rename a jump label in update_filter() Mike Rapoport <rppt@linux.vnet.ibm.com> - 2016-08-22 07:30 +0200
[PATCH 1/2] tun: Use memdup_user() rather than duplicating its implementation SF Markus Elfring <elfring@users.sourceforge.net> - 2016-08-20 09:40 +0200
Re: [PATCH 1/2] tun: Use memdup_user() rather than duplicating its implementation Shmulik Ladkani <shmulik.ladkani@gmail.com> - 2016-08-20 13:50 +0200
Re: [PATCH 1/2] tun: Use memdup_user() rather than duplicating its implementation "Michael S. Tsirkin" <mst@redhat.com> - 2016-08-22 03:50 +0200
Re: [PATCH 0/2] tun: Fine-tuning for update_filter() David Miller <davem@davemloft.net> - 2016-08-21 04:20 +0200
csiph-web