Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1462714 > unrolled thread
| Started by | SF Markus Elfring <elfring@users.sourceforge.net> |
|---|---|
| First post | 2016-08-15 13:20 +0200 |
| Last post | 2016-08-17 11:50 +0200 |
| Articles | 7 — 3 participants |
Back to article view | Back to linux.kernel
[PATCH] backlight-tosa: Delete owner assignment SF Markus Elfring <elfring@users.sourceforge.net> - 2016-08-15 13:20 +0200
Re: [PATCH] backlight-tosa: Delete owner assignment Vegard Nossum <vegard.nossum@gmail.com> - 2016-08-15 13:40 +0200
Re: backlight-tosa: Delete owner assignment SF Markus Elfring <elfring@users.sourceforge.net> - 2016-08-15 15:30 +0200
Re: backlight-tosa: Delete owner assignment Vegard Nossum <vegard.nossum@gmail.com> - 2016-08-15 15:40 +0200
Re: [PATCH] backlight-tosa: Delete owner assignment Lee Jones <lee.jones@linaro.org> - 2016-08-15 15:50 +0200
[PATCH v2] backlight-tosa: Delete unnecessary assignment for the field "owner" SF Markus Elfring <elfring@users.sourceforge.net> - 2016-08-16 17:20 +0200
Re: [PATCH v2] backlight-tosa: Delete unnecessary assignment for the field "owner" Lee Jones <lee.jones@linaro.org> - 2016-08-17 11:50 +0200
| From | SF Markus Elfring <elfring@users.sourceforge.net> |
|---|---|
| Date | 2016-08-15 13:20 +0200 |
| Subject | [PATCH] backlight-tosa: Delete owner assignment |
| Message-ID | <s6o5Y-4S0-9@gated-at.bofh.it> |
From: Markus Elfring <elfring@users.sourceforge.net>
Date: Mon, 15 Aug 2016 13:03:29 +0200
The field "owner" is set by core. Thus delete an extra initialisation.
Generated by: scripts/coccinelle/api/platform_no_drv_owner.cocci
Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
---
drivers/video/backlight/tosa_bl.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/video/backlight/tosa_bl.c b/drivers/video/backlight/tosa_bl.c
index 83742d8..9706759 100644
--- a/drivers/video/backlight/tosa_bl.c
+++ b/drivers/video/backlight/tosa_bl.c
@@ -163,7 +163,6 @@ MODULE_DEVICE_TABLE(i2c, tosa_bl_id);
static struct i2c_driver tosa_bl_driver = {
.driver = {
.name = "tosa-bl",
- .owner = THIS_MODULE,
.pm = &tosa_bl_pm_ops,
},
.probe = tosa_bl_probe,
--
2.9.2
[toc] | [next] | [standalone]
| From | Vegard Nossum <vegard.nossum@gmail.com> |
|---|---|
| Date | 2016-08-15 13:40 +0200 |
| Message-ID | <s6opk-4ZP-11@gated-at.bofh.it> |
| In reply to | #1462714 |
On 15 August 2016 at 13:12, SF Markus Elfring <elfring@users.sourceforge.net> wrote: > From: Markus Elfring <elfring@users.sourceforge.net> > Date: Mon, 15 Aug 2016 13:03:29 +0200 > > The field "owner" is set by core. Thus delete an extra initialisation. Hi, Just a small nit on the patch title: "delete owner assignment" is virtually useless as a title because it has no meaning without the broader context and only describes the literal change. It's like naming a patch "add a line" or "change the code"; it serves no purpose. How about "backlight-tosa: delete _unnecessary_ assignment"? This immediately communicates the reason for/intent of the patch (there is unnecessary code, thus we can simplify it). (Sorry about singling out this patch and the apparent bikeshedding, this comment obviously applies to a lot of patches by a lot of authors!) Thanks, Vegard
[toc] | [prev] | [next] | [standalone]
| From | SF Markus Elfring <elfring@users.sourceforge.net> |
|---|---|
| Date | 2016-08-15 15:30 +0200 |
| Subject | Re: backlight-tosa: Delete owner assignment |
| Message-ID | <s6q7L-68h-3@gated-at.bofh.it> |
| In reply to | #1462718 |
>> The field "owner" is set by core. Thus delete an extra initialisation. > > Just a small nit on the patch title: "delete owner assignment" is > virtually useless as a title because it has no meaning without the > broader context and only describes the literal change. It's like > naming a patch "add a line" or "change the code"; > it serves no purpose. I have got an other impression. Do you want that I add any more background information to the commit message? > How about "backlight-tosa: delete _unnecessary_ assignment"? Will the underlined key word trigger any related software development concerns? Would another look be needed on how the usage of the mentioned data structure element was reduced over time? Regards, Markus
[toc] | [prev] | [next] | [standalone]
| From | Vegard Nossum <vegard.nossum@gmail.com> |
|---|---|
| Date | 2016-08-15 15:40 +0200 |
| Subject | Re: backlight-tosa: Delete owner assignment |
| Message-ID | <s6qhs-6cc-21@gated-at.bofh.it> |
| In reply to | #1462778 |
On 15 August 2016 at 15:25, SF Markus Elfring <elfring@users.sourceforge.net> wrote: >>> The field "owner" is set by core. Thus delete an extra initialisation. >> >> Just a small nit on the patch title: "delete owner assignment" is >> virtually useless as a title because it has no meaning without the >> broader context and only describes the literal change. It's like >> naming a patch "add a line" or "change the code"; >> it serves no purpose. > > I have got an other impression. > > Do you want that I add any more background information to the > commit message? No, the rest of the commit message is fine. I was only concerned about the patch title (the first line) since that's what appears frequently in patch lists (cgit, shortlogs, email/archives), etc. >> How about "backlight-tosa: delete _unnecessary_ assignment"? > > Will the underlined key word trigger any related software > development concerns? No, the emphasis was just for the email, I wouldn't put that in the actual commit log. > Would another look be needed on how the usage of the mentioned data > structure element was reduced over time? No, it's fine, it's really just about the patch title :-) Thanks, Vegard
[toc] | [prev] | [next] | [standalone]
| From | Lee Jones <lee.jones@linaro.org> |
|---|---|
| Date | 2016-08-15 15:50 +0200 |
| Message-ID | <s6qr7-6fG-13@gated-at.bofh.it> |
| In reply to | #1462718 |
On Mon, 15 Aug 2016, Vegard Nossum wrote: > On 15 August 2016 at 13:12, SF Markus Elfring > <elfring@users.sourceforge.net> wrote: > > From: Markus Elfring <elfring@users.sourceforge.net> > > Date: Mon, 15 Aug 2016 13:03:29 +0200 > > > > The field "owner" is set by core. Thus delete an extra initialisation. > > Hi, > > Just a small nit on the patch title: "delete owner assignment" is > virtually useless as a title because it has no meaning without the > broader context and only describes the literal change. It's like > naming a patch "add a line" or "change the code"; it serves no > purpose. > > How about "backlight-tosa: delete _unnecessary_ assignment"? This > immediately communicates the reason for/intent of the patch (there is > unnecessary code, thus we can simplify it). backlight-tosa: Do not manually assign THIS_MODULE to .owner This is unnecessary because ... > (Sorry about singling out this patch and the apparent bikeshedding, > this comment obviously applies to a lot of patches by a lot of > authors!) > > Thanks, > > > Vegard -- Lee Jones Linaro STMicroelectronics Landing Team Lead Linaro.org │ Open source software for ARM SoCs Follow Linaro: Facebook | Twitter | Blog
[toc] | [prev] | [next] | [standalone]
| From | SF Markus Elfring <elfring@users.sourceforge.net> |
|---|---|
| Date | 2016-08-16 17:20 +0200 |
| Subject | [PATCH v2] backlight-tosa: Delete unnecessary assignment for the field "owner" |
| Message-ID | <s6OjL-4IB-17@gated-at.bofh.it> |
| In reply to | #1462718 |
From: Markus Elfring <elfring@users.sourceforge.net>
Date: Tue, 16 Aug 2016 17:10:12 +0200
The field "owner" is set by the core.
Thus delete an unneeded initialisation.
Generated by: scripts/coccinelle/api/platform_no_drv_owner.cocci
Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
---
v2: The commit message was adjusted.
drivers/video/backlight/tosa_bl.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/video/backlight/tosa_bl.c b/drivers/video/backlight/tosa_bl.c
index 83742d8..9706759 100644
--- a/drivers/video/backlight/tosa_bl.c
+++ b/drivers/video/backlight/tosa_bl.c
@@ -163,7 +163,6 @@ MODULE_DEVICE_TABLE(i2c, tosa_bl_id);
static struct i2c_driver tosa_bl_driver = {
.driver = {
.name = "tosa-bl",
- .owner = THIS_MODULE,
.pm = &tosa_bl_pm_ops,
},
.probe = tosa_bl_probe,
--
2.9.2
[toc] | [prev] | [next] | [standalone]
| From | Lee Jones <lee.jones@linaro.org> |
|---|---|
| Date | 2016-08-17 11:50 +0200 |
| Subject | Re: [PATCH v2] backlight-tosa: Delete unnecessary assignment for the field "owner" |
| Message-ID | <s75DX-7DZ-1@gated-at.bofh.it> |
| In reply to | #1463881 |
On Tue, 16 Aug 2016, SF Markus Elfring wrote:
> From: Markus Elfring <elfring@users.sourceforge.net>
> Date: Tue, 16 Aug 2016 17:10:12 +0200
>
> The field "owner" is set by the core.
> Thus delete an unneeded initialisation.
>
> Generated by: scripts/coccinelle/api/platform_no_drv_owner.cocci
> Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
> ---
>
> v2: The commit message was adjusted.
>
> drivers/video/backlight/tosa_bl.c | 1 -
> 1 file changed, 1 deletion(-)
Applied, thanks.
> diff --git a/drivers/video/backlight/tosa_bl.c b/drivers/video/backlight/tosa_bl.c
> index 83742d8..9706759 100644
> --- a/drivers/video/backlight/tosa_bl.c
> +++ b/drivers/video/backlight/tosa_bl.c
> @@ -163,7 +163,6 @@ MODULE_DEVICE_TABLE(i2c, tosa_bl_id);
> static struct i2c_driver tosa_bl_driver = {
> .driver = {
> .name = "tosa-bl",
> - .owner = THIS_MODULE,
> .pm = &tosa_bl_pm_ops,
> },
> .probe = tosa_bl_probe,
--
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web