Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1455393 > unrolled thread

Re: [PATCH v2] HID: use IS_ENABLED() instead of checking for built-in or module

Started byJiri Kosina <jikos@kernel.org>
First post2016-08-02 21:00 +0200
Last post2016-08-02 21:00 +0200
Articles 1 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH v2] HID: use IS_ENABLED() instead of checking for built-in  or module Jiri Kosina <jikos@kernel.org> - 2016-08-02 21:00 +0200

#1455393 — Re: [PATCH v2] HID: use IS_ENABLED() instead of checking for built-in or module

FromJiri Kosina <jikos@kernel.org>
Date2016-08-02 21:00 +0200
SubjectRe: [PATCH v2] HID: use IS_ENABLED() instead of checking for built-in or module
Message-ID<s1N4Z-8oW-23@gated-at.bofh.it>
On Thu, 21 Jul 2016, Javier Martinez Canillas wrote:

> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
> built-in or as a module, use that macro instead of open coding the same.
> 
> Using the macro makes the code more readable by helping abstract away some
> of the Kconfig built-in and module enable details.

Applied, thanks.

-- 
Jiri Kosina
SUSE Labs

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web