Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1455393

Re: [PATCH v2] HID: use IS_ENABLED() instead of checking for built-in or module

From Jiri Kosina <jikos@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH v2] HID: use IS_ENABLED() instead of checking for built-in or module
Date 2016-08-02 21:00 +0200
Message-ID <s1N4Z-8oW-23@gated-at.bofh.it> (permalink)
References <rXo5d-Qr-35@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Thu, 21 Jul 2016, Javier Martinez Canillas wrote:

> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
> built-in or as a module, use that macro instead of open coding the same.
> 
> Using the macro makes the code more readable by helping abstract away some
> of the Kconfig built-in and module enable details.

Applied, thanks.

-- 
Jiri Kosina
SUSE Labs

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

Re: [PATCH v2] HID: use IS_ENABLED() instead of checking for built-in  or module Jiri Kosina <jikos@kernel.org> - 2016-08-02 21:00 +0200

csiph-web