Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1453787 > unrolled thread
| Started by | Baole Ni <baolex.ni@intel.com> |
|---|---|
| First post | 2016-08-02 13:30 +0200 |
| Last post | 2016-08-02 19:10 +0200 |
| Articles | 3 — 3 participants |
Back to article view | Back to linux.kernel
[PATCH 0122/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 13:30 +0200
Re: [PATCH 0122/1285] Replace numeric parameter like 0444 with macro Alan Stern <stern@rowland.harvard.edu> - 2016-08-02 16:10 +0200
Re: [PATCH 0122/1285] Replace numeric parameter like 0444 with macro Jiri Slaby <jslaby@suse.cz> - 2016-08-02 19:10 +0200
| From | Baole Ni <baolex.ni@intel.com> |
|---|---|
| Date | 2016-08-02 13:30 +0200 |
| Subject | [PATCH 0122/1285] Replace numeric parameter like 0444 with macro |
| Message-ID | <s1G3v-3Jf-7@gated-at.bofh.it> |
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
drivers/cpufreq/powernow-k7.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/cpufreq/powernow-k7.c b/drivers/cpufreq/powernow-k7.c
index 9f013ed..2c7d73a 100644
--- a/drivers/cpufreq/powernow-k7.c
+++ b/drivers/cpufreq/powernow-k7.c
@@ -683,7 +683,7 @@ static void __exit powernow_exit(void)
cpufreq_unregister_driver(&powernow_driver);
}
-module_param(acpi_force, int, 0444);
+module_param(acpi_force, int, S_IRUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(acpi_force, "Force ACPI to be used.");
MODULE_AUTHOR("Dave Jones");
--
2.9.2
[toc] | [next] | [standalone]
| From | Alan Stern <stern@rowland.harvard.edu> |
|---|---|
| Date | 2016-08-02 16:10 +0200 |
| Message-ID | <s1Iym-5ut-39@gated-at.bofh.it> |
| In reply to | #1453787 |
On Tue, 2 Aug 2016, Baole Ni wrote: > I find that the developers often just specified the numeric value > when calling a macro which is defined with a parameter for access permission. > As we know, these numeric value for access permission have had the corresponding macro, > and that using macro can improve the robustness and readability of the code, > thus, I suggest replacing the numeric parameter with the macro. This reasoning is highly questionable. How does using a macro improve either robustness or readability? > Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com> > Signed-off-by: Baole Ni <baolex.ni@intel.com> > --- > drivers/cpufreq/powernow-k7.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/cpufreq/powernow-k7.c b/drivers/cpufreq/powernow-k7.c > index 9f013ed..2c7d73a 100644 > --- a/drivers/cpufreq/powernow-k7.c > +++ b/drivers/cpufreq/powernow-k7.c > @@ -683,7 +683,7 @@ static void __exit powernow_exit(void) > cpufreq_unregister_driver(&powernow_driver); > } > > -module_param(acpi_force, int, 0444); > +module_param(acpi_force, int, S_IRUSR | S_IRGRP | S_IROTH); This is an excellent example. To me, 0444 is _much_ more readable and understandable than S_IRUSR | S_IRGRP | S_IROTH. Alan Stern
[toc] | [prev] | [next] | [standalone]
| From | Jiri Slaby <jslaby@suse.cz> |
|---|---|
| Date | 2016-08-02 19:10 +0200 |
| Message-ID | <s1Lmy-7qe-31@gated-at.bofh.it> |
| In reply to | #1454489 |
On 08/02/2016, 03:57 PM, Alan Stern wrote: >> --- a/drivers/cpufreq/powernow-k7.c >> +++ b/drivers/cpufreq/powernow-k7.c >> @@ -683,7 +683,7 @@ static void __exit powernow_exit(void) >> cpufreq_unregister_driver(&powernow_driver); >> } >> >> -module_param(acpi_force, int, 0444); >> +module_param(acpi_force, int, S_IRUSR | S_IRGRP | S_IROTH); > > This is an excellent example. To me, 0444 is _much_ more readable and > understandable than S_IRUSR | S_IRGRP | S_IROTH. If anything, that should be S_IRUGO. However, I personally prefer numbers over macros too. thanks, -- js suse labs
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web