Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1455066
| From | Jiri Slaby <jslaby@suse.cz> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 0122/1285] Replace numeric parameter like 0444 with macro |
| Date | 2016-08-02 19:10 +0200 |
| Message-ID | <s1Lmy-7qe-31@gated-at.bofh.it> (permalink) |
| References | <s1Iym-5ut-39@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 08/02/2016, 03:57 PM, Alan Stern wrote: >> --- a/drivers/cpufreq/powernow-k7.c >> +++ b/drivers/cpufreq/powernow-k7.c >> @@ -683,7 +683,7 @@ static void __exit powernow_exit(void) >> cpufreq_unregister_driver(&powernow_driver); >> } >> >> -module_param(acpi_force, int, 0444); >> +module_param(acpi_force, int, S_IRUSR | S_IRGRP | S_IROTH); > > This is an excellent example. To me, 0444 is _much_ more readable and > understandable than S_IRUSR | S_IRGRP | S_IROTH. If anything, that should be S_IRUGO. However, I personally prefer numbers over macros too. thanks, -- js suse labs
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 0122/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 13:30 +0200
Re: [PATCH 0122/1285] Replace numeric parameter like 0444 with macro Alan Stern <stern@rowland.harvard.edu> - 2016-08-02 16:10 +0200
Re: [PATCH 0122/1285] Replace numeric parameter like 0444 with macro Jiri Slaby <jslaby@suse.cz> - 2016-08-02 19:10 +0200
csiph-web