Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1393508 > unrolled thread

[PATCH 1/2] pinctrl: nomadik: hide nmk_gpio_get_mode when unused

Started byArnd Bergmann <arnd@arndb.de>
First post2016-05-03 17:30 +0200
Last post2016-05-09 12:00 +0200
Articles 4 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH 1/2] pinctrl: nomadik: hide nmk_gpio_get_mode when unused Arnd Bergmann <arnd@arndb.de> - 2016-05-03 17:30 +0200
    [PATCH 2/2] pinctrl: ns2: rename pinctrl_utils_dt_free_map Arnd Bergmann <arnd@arndb.de> - 2016-05-03 17:30 +0200
      Re: [PATCH 2/2] pinctrl: ns2: rename pinctrl_utils_dt_free_map Linus Walleij <linus.walleij@linaro.org> - 2016-05-09 12:00 +0200
    Re: [PATCH 1/2] pinctrl: nomadik: hide nmk_gpio_get_mode when unused Linus Walleij <linus.walleij@linaro.org> - 2016-05-09 12:00 +0200

#1393508 — [PATCH 1/2] pinctrl: nomadik: hide nmk_gpio_get_mode when unused

FromArnd Bergmann <arnd@arndb.de>
Date2016-05-03 17:30 +0200
Subject[PATCH 1/2] pinctrl: nomadik: hide nmk_gpio_get_mode when unused
Message-ID<ruKqR-24h-1@gated-at.bofh.it>
nmk_gpio_get_mode is only used in one place, and that is conditionally
compiled if DEBUG_FS is enabled. A recent cleanup has marked the
definition 'static', which now leads to a warning:

drivers/pinctrl/nomadik/pinctrl-nomadik.c:614:12: error: 'nmk_gpio_get_mode' defined but not used [-Werror=unused-function]
 static int nmk_gpio_get_mode(struct nmk_gpio_chip *nmk_chip, int offset)
            ^~~~~~~~~~~~~~~~~

Moving the function itself inside the #ifdef shuts it up again.

Signed-off-by: Arnd Bergmann <arnd@arndb.de>
Fixes: 5e81e0a0913c ("pinctrl: nomadik: use BIT() with offsets consequently")
---
 drivers/pinctrl/nomadik/pinctrl-nomadik.c | 27 +++++++++++++--------------
 1 file changed, 13 insertions(+), 14 deletions(-)

diff --git a/drivers/pinctrl/nomadik/pinctrl-nomadik.c b/drivers/pinctrl/nomadik/pinctrl-nomadik.c
index e5c71acd9506..ccbfc325c778 100644
--- a/drivers/pinctrl/nomadik/pinctrl-nomadik.c
+++ b/drivers/pinctrl/nomadik/pinctrl-nomadik.c
@@ -611,20 +611,6 @@ static int __maybe_unused nmk_prcm_gpiocr_get_mode(struct pinctrl_dev *pctldev,
 	return NMK_GPIO_ALT_C;
 }
 
-static int nmk_gpio_get_mode(struct nmk_gpio_chip *nmk_chip, int offset)
-{
-	u32 afunc, bfunc;
-
-	clk_enable(nmk_chip->clk);
-
-	afunc = readl(nmk_chip->addr + NMK_GPIO_AFSLA) & BIT(offset);
-	bfunc = readl(nmk_chip->addr + NMK_GPIO_AFSLB) & BIT(offset);
-
-	clk_disable(nmk_chip->clk);
-
-	return (afunc ? NMK_GPIO_ALT_A : 0) | (bfunc ? NMK_GPIO_ALT_B : 0);
-}
-
 /* IRQ functions */
 
 static void nmk_gpio_irq_ack(struct irq_data *d)
@@ -929,6 +915,19 @@ static int nmk_gpio_make_output(struct gpio_chip *chip, unsigned offset,
 }
 
 #ifdef CONFIG_DEBUG_FS
+static int nmk_gpio_get_mode(struct nmk_gpio_chip *nmk_chip, int offset)
+{
+	u32 afunc, bfunc;
+
+	clk_enable(nmk_chip->clk);
+
+	afunc = readl(nmk_chip->addr + NMK_GPIO_AFSLA) & BIT(offset);
+	bfunc = readl(nmk_chip->addr + NMK_GPIO_AFSLB) & BIT(offset);
+
+	clk_disable(nmk_chip->clk);
+
+	return (afunc ? NMK_GPIO_ALT_A : 0) | (bfunc ? NMK_GPIO_ALT_B : 0);
+}
 
 #include <linux/seq_file.h>
 
-- 
2.7.0

[toc] | [next] | [standalone]


#1393527 — [PATCH 2/2] pinctrl: ns2: rename pinctrl_utils_dt_free_map

FromArnd Bergmann <arnd@arndb.de>
Date2016-05-03 17:30 +0200
Subject[PATCH 2/2] pinctrl: ns2: rename pinctrl_utils_dt_free_map
Message-ID<ruKqT-24h-49@gated-at.bofh.it>
In reply to#1393508
A conflict of two patches caused a build error when a function got renamed
but a new user appeared in the other patch:

drivers/pinctrl/bcm/pinctrl-ns2-mux.c:540:17: error: 'pinctrl_utils_dt_free_map' undeclared here (not in a function)
  .dt_free_map = pinctrl_utils_dt_free_map,
                 ^~~~~~~~~~~~~~~~~~~~~~~~~

This renames the new user of pinctrl_utils_dt_free_map accordingly.

Signed-off-by: Arnd Bergmann <arnd@arndb.de>
Fixes: d32f7fd3bbc3 ("pinctrl: Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map")
Fixes: b5aa1006e4a9 ("pinctrl: ns2: add pinmux driver support for Broadcom NS2 SoC")
---
 drivers/pinctrl/bcm/pinctrl-ns2-mux.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/pinctrl/bcm/pinctrl-ns2-mux.c b/drivers/pinctrl/bcm/pinctrl-ns2-mux.c
index 1fd57db52d7b..3fefd14acc3e 100644
--- a/drivers/pinctrl/bcm/pinctrl-ns2-mux.c
+++ b/drivers/pinctrl/bcm/pinctrl-ns2-mux.c
@@ -537,7 +537,7 @@ static struct pinctrl_ops ns2_pinctrl_ops = {
 	.get_group_pins = ns2_get_group_pins,
 	.pin_dbg_show = ns2_pin_dbg_show,
 	.dt_node_to_map = pinconf_generic_dt_node_to_map_pin,
-	.dt_free_map = pinctrl_utils_dt_free_map,
+	.dt_free_map = pinctrl_utils_free_map,
 };
 
 static int ns2_get_functions_count(struct pinctrl_dev *pctrl_dev)
-- 
2.7.0

[toc] | [prev] | [next] | [standalone]


#1396895 — Re: [PATCH 2/2] pinctrl: ns2: rename pinctrl_utils_dt_free_map

FromLinus Walleij <linus.walleij@linaro.org>
Date2016-05-09 12:00 +0200
SubjectRe: [PATCH 2/2] pinctrl: ns2: rename pinctrl_utils_dt_free_map
Message-ID<rwQ8N-2SQ-1@gated-at.bofh.it>
In reply to#1393527
On Tue, May 3, 2016 at 5:26 PM, Arnd Bergmann <arnd@arndb.de> wrote:

> A conflict of two patches caused a build error when a function got renamed
> but a new user appeared in the other patch:
>
> drivers/pinctrl/bcm/pinctrl-ns2-mux.c:540:17: error: 'pinctrl_utils_dt_free_map' undeclared here (not in a function)
>   .dt_free_map = pinctrl_utils_dt_free_map,
>                  ^~~~~~~~~~~~~~~~~~~~~~~~~
>
> This renames the new user of pinctrl_utils_dt_free_map accordingly.
>
> Signed-off-by: Arnd Bergmann <arnd@arndb.de>
> Fixes: d32f7fd3bbc3 ("pinctrl: Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map")
> Fixes: b5aa1006e4a9 ("pinctrl: ns2: add pinmux driver support for Broadcom NS2 SoC")

Patch applied.

Sorry for taking so long. Mail Swamp.

Yours,
Linus Walleij

[toc] | [prev] | [next] | [standalone]


#1396899

FromLinus Walleij <linus.walleij@linaro.org>
Date2016-05-09 12:00 +0200
Message-ID<rwQ8P-2SQ-31@gated-at.bofh.it>
In reply to#1393508
On Tue, May 3, 2016 at 5:26 PM, Arnd Bergmann <arnd@arndb.de> wrote:

> nmk_gpio_get_mode is only used in one place, and that is conditionally
> compiled if DEBUG_FS is enabled. A recent cleanup has marked the
> definition 'static', which now leads to a warning:
>
> drivers/pinctrl/nomadik/pinctrl-nomadik.c:614:12: error: 'nmk_gpio_get_mode' defined but not used [-Werror=unused-function]
>  static int nmk_gpio_get_mode(struct nmk_gpio_chip *nmk_chip, int offset)
>             ^~~~~~~~~~~~~~~~~
>
> Moving the function itself inside the #ifdef shuts it up again.
>
> Signed-off-by: Arnd Bergmann <arnd@arndb.de>
> Fixes: 5e81e0a0913c ("pinctrl: nomadik: use BIT() with offsets consequently")

Patch applied!

Yours,
Linus Walleij

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web