Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1393527

[PATCH 2/2] pinctrl: ns2: rename pinctrl_utils_dt_free_map

From Arnd Bergmann <arnd@arndb.de>
Newsgroups linux.kernel
Subject [PATCH 2/2] pinctrl: ns2: rename pinctrl_utils_dt_free_map
Date 2016-05-03 17:30 +0200
Message-ID <ruKqT-24h-49@gated-at.bofh.it> (permalink)
References <ruKqR-24h-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


A conflict of two patches caused a build error when a function got renamed
but a new user appeared in the other patch:

drivers/pinctrl/bcm/pinctrl-ns2-mux.c:540:17: error: 'pinctrl_utils_dt_free_map' undeclared here (not in a function)
  .dt_free_map = pinctrl_utils_dt_free_map,
                 ^~~~~~~~~~~~~~~~~~~~~~~~~

This renames the new user of pinctrl_utils_dt_free_map accordingly.

Signed-off-by: Arnd Bergmann <arnd@arndb.de>
Fixes: d32f7fd3bbc3 ("pinctrl: Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map")
Fixes: b5aa1006e4a9 ("pinctrl: ns2: add pinmux driver support for Broadcom NS2 SoC")
---
 drivers/pinctrl/bcm/pinctrl-ns2-mux.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/pinctrl/bcm/pinctrl-ns2-mux.c b/drivers/pinctrl/bcm/pinctrl-ns2-mux.c
index 1fd57db52d7b..3fefd14acc3e 100644
--- a/drivers/pinctrl/bcm/pinctrl-ns2-mux.c
+++ b/drivers/pinctrl/bcm/pinctrl-ns2-mux.c
@@ -537,7 +537,7 @@ static struct pinctrl_ops ns2_pinctrl_ops = {
 	.get_group_pins = ns2_get_group_pins,
 	.pin_dbg_show = ns2_pin_dbg_show,
 	.dt_node_to_map = pinconf_generic_dt_node_to_map_pin,
-	.dt_free_map = pinctrl_utils_dt_free_map,
+	.dt_free_map = pinctrl_utils_free_map,
 };
 
 static int ns2_get_functions_count(struct pinctrl_dev *pctrl_dev)
-- 
2.7.0

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 1/2] pinctrl: nomadik: hide nmk_gpio_get_mode when unused Arnd Bergmann <arnd@arndb.de> - 2016-05-03 17:30 +0200
  [PATCH 2/2] pinctrl: ns2: rename pinctrl_utils_dt_free_map Arnd Bergmann <arnd@arndb.de> - 2016-05-03 17:30 +0200
    Re: [PATCH 2/2] pinctrl: ns2: rename pinctrl_utils_dt_free_map Linus Walleij <linus.walleij@linaro.org> - 2016-05-09 12:00 +0200
  Re: [PATCH 1/2] pinctrl: nomadik: hide nmk_gpio_get_mode when unused Linus Walleij <linus.walleij@linaro.org> - 2016-05-09 12:00 +0200

csiph-web