Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1374816 > unrolled thread

Re: [patch] power/max8925: freeing wrong variable

Started bySebastian Reichel <sre@kernel.org>
First post2016-04-10 18:30 +0200
Last post2016-04-10 18:30 +0200
Articles 1 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [patch] power/max8925: freeing wrong variable Sebastian Reichel <sre@kernel.org> - 2016-04-10 18:30 +0200

#1374816 — Re: [patch] power/max8925: freeing wrong variable

FromSebastian Reichel <sre@kernel.org>
Date2016-04-10 18:30 +0200
SubjectRe: [patch] power/max8925: freeing wrong variable
Message-ID<rmqpl-7ON-31@gated-at.bofh.it>

[Multipart message — attachments visible in raw view] — view raw

Hi,

On Fri, Mar 18, 2016 at 08:40:16AM +0300, Dan Carpenter wrote:
> We were freeing "info->battery" instead of "info->usb", which leads to
> an OOps and a resource leak.
> 
> The labels were wonky, "out_battery" did release the battery but out_usb
> did not release usb.  I was introducing a call to free usb so it sort
> conflicted with existing misleading name.  I renamed them.
> 
> Signed-off-by: Dan Carpenter <dan.carpenter@oracle.com>

Thanks, queued.

-- Sebastian

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web