Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1374816

Re: [patch] power/max8925: freeing wrong variable

From Sebastian Reichel <sre@kernel.org>
Newsgroups linux.kernel
Subject Re: [patch] power/max8925: freeing wrong variable
Date 2016-04-10 18:30 +0200
Message-ID <rmqpl-7ON-31@gated-at.bofh.it> (permalink)
References <rdVsl-1kZ-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


[Multipart message — attachments visible in raw view] - view raw

Hi,

On Fri, Mar 18, 2016 at 08:40:16AM +0300, Dan Carpenter wrote:
> We were freeing "info->battery" instead of "info->usb", which leads to
> an OOps and a resource leak.
> 
> The labels were wonky, "out_battery" did release the battery but out_usb
> did not release usb.  I was introducing a call to free usb so it sort
> conflicted with existing misleading name.  I renamed them.
> 
> Signed-off-by: Dan Carpenter <dan.carpenter@oracle.com>

Thanks, queued.

-- Sebastian

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

Re: [patch] power/max8925: freeing wrong variable Sebastian Reichel <sre@kernel.org> - 2016-04-10 18:30 +0200

csiph-web