Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1371471 > unrolled thread

[PATCH 15/27] bcache: super: use bio_set_vec_table()

Started byMing Lei <tom.leiming@gmail.com>
First post2016-04-05 14:10 +0200
Last post2016-04-05 14:20 +0200
Articles 11 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH 15/27] bcache: super: use bio_set_vec_table() Ming Lei <tom.leiming@gmail.com> - 2016-04-05 14:10 +0200
    [PATCH 18/27] dm: dm-io.c: use bio_get_base_vec() Ming Lei <tom.leiming@gmail.com> - 2016-04-05 14:10 +0200
    [PATCH 22/27] fs: logfs: convert to bio_add_page() in sync_request() Ming Lei <tom.leiming@gmail.com> - 2016-04-05 14:10 +0200
      Re: [PATCH 22/27] fs: logfs: convert to bio_add_page() in  sync_request() Christoph Hellwig <hch@infradead.org> - 2016-04-05 15:00 +0200
    [PATCH 19/27] dm: dm.c: replace 'bio->bi_vcnt == 1' with !bio_multiple_segments Ming Lei <tom.leiming@gmail.com> - 2016-04-05 14:10 +0200
    [PATCH 26/27] kernel/power/swap.c: use bio_get_base_vec() Ming Lei <tom.leiming@gmail.com> - 2016-04-05 14:20 +0200
      Re: [PATCH 26/27] kernel/power/swap.c: use bio_get_base_vec() Christoph Hellwig <hch@infradead.org> - 2016-04-05 15:00 +0200
        Re: [PATCH 26/27] kernel/power/swap.c: use bio_get_base_vec() Ming Lei <tom.leiming@gmail.com> - 2016-04-05 15:20 +0200
    [PATCH 25/27] fs: logfs: remove unnecesary check Ming Lei <tom.leiming@gmail.com> - 2016-04-05 14:20 +0200
    [PATCH 27/27] mm: page_io.c: use bio_get_base_vec() Ming Lei <tom.leiming@gmail.com> - 2016-04-05 14:20 +0200
    [PATCH 24/27] fs: logfs: use bio_add_page() in do_erase() Ming Lei <tom.leiming@gmail.com> - 2016-04-05 14:20 +0200

#1371471 — [PATCH 15/27] bcache: super: use bio_set_vec_table()

FromMing Lei <tom.leiming@gmail.com>
Date2016-04-05 14:10 +0200
Subject[PATCH 15/27] bcache: super: use bio_set_vec_table()
Message-ID<rkxXX-36a-3@gated-at.bofh.it>
Signed-off-by: Ming Lei <tom.leiming@gmail.com>
---
 drivers/md/bcache/super.c | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)

diff --git a/drivers/md/bcache/super.c b/drivers/md/bcache/super.c
index a296425..3f649c9 100644
--- a/drivers/md/bcache/super.c
+++ b/drivers/md/bcache/super.c
@@ -1151,8 +1151,7 @@ static void register_bdev(struct cache_sb *sb, struct page *sb_page,
 	dc->bdev->bd_holder = dc;
 
 	bio_init(&dc->sb_bio);
-	dc->sb_bio.bi_max_vecs	= 1;
-	dc->sb_bio.bi_io_vec	= dc->sb_bio.bi_inline_vecs;
+	bio_set_vec_table(&dc->sb_bio, dc->sb_bio.bi_inline_vecs, 1);
 	dc->sb_bio.bi_io_vec[0].bv_page = sb_page;
 	get_page(sb_page);
 
@@ -1812,8 +1811,8 @@ static int cache_alloc(struct cache_sb *sb, struct cache *ca)
 	kobject_init(&ca->kobj, &bch_cache_ktype);
 
 	bio_init(&ca->journal.bio);
-	ca->journal.bio.bi_max_vecs = 8;
-	ca->journal.bio.bi_io_vec = ca->journal.bio.bi_inline_vecs;
+	bio_set_vec_table(&ca->journal.bio,
+			  ca->journal.bio.bi_inline_vecs, 8);
 
 	free = roundup_pow_of_two(ca->sb.nbuckets) >> 10;
 
@@ -1850,8 +1849,7 @@ static int register_cache(struct cache_sb *sb, struct page *sb_page,
 	ca->bdev->bd_holder = ca;
 
 	bio_init(&ca->sb_bio);
-	ca->sb_bio.bi_max_vecs	= 1;
-	ca->sb_bio.bi_io_vec	= ca->sb_bio.bi_inline_vecs;
+	bio_set_vec_table(&ca->sb_bio, ca->sb_bio.bi_inline_vecs, 1);
 	ca->sb_bio.bi_io_vec[0].bv_page = sb_page;
 	get_page(sb_page);
 
-- 
1.9.1

[toc] | [next] | [standalone]


#1371477 — [PATCH 18/27] dm: dm-io.c: use bio_get_base_vec()

FromMing Lei <tom.leiming@gmail.com>
Date2016-04-05 14:10 +0200
Subject[PATCH 18/27] dm: dm-io.c: use bio_get_base_vec()
Message-ID<rkxY0-36a-57@gated-at.bofh.it>
In reply to#1371471
Signed-off-by: Ming Lei <tom.leiming@gmail.com>
---
 drivers/md/dm-io.c | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/drivers/md/dm-io.c b/drivers/md/dm-io.c
index 06d426e..6b0e466 100644
--- a/drivers/md/dm-io.c
+++ b/drivers/md/dm-io.c
@@ -221,7 +221,12 @@ static void bio_dp_init(struct dpages *dp, struct bio *bio)
 {
 	dp->get_page = bio_get_page;
 	dp->next_page = bio_next_page;
-	dp->context_ptr = __bvec_iter_bvec(bio->bi_io_vec, bio->bi_iter);
+
+	/*
+	 * need to fix both bio_get_page() and bio_next_page()
+	 * before multipage bvecs
+	 */
+	dp->context_ptr = bio_get_base_vec(bio);
 	dp->context_u = bio->bi_iter.bi_bvec_done;
 }
 
-- 
1.9.1

[toc] | [prev] | [next] | [standalone]


#1371478 — [PATCH 22/27] fs: logfs: convert to bio_add_page() in sync_request()

FromMing Lei <tom.leiming@gmail.com>
Date2016-04-05 14:10 +0200
Subject[PATCH 22/27] fs: logfs: convert to bio_add_page() in sync_request()
Message-ID<rkxY0-36a-63@gated-at.bofh.it>
In reply to#1371471
Signed-off-by: Ming Lei <tom.leiming@gmail.com>
---
 fs/logfs/dev_bdev.c | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

diff --git a/fs/logfs/dev_bdev.c b/fs/logfs/dev_bdev.c
index bc422bc9..957c237 100644
--- a/fs/logfs/dev_bdev.c
+++ b/fs/logfs/dev_bdev.c
@@ -21,13 +21,10 @@ static int sync_request(struct page *page, struct block_device *bdev, int rw)
 
 	bio_init(&bio);
 	bio_set_vec_table(&bio, &bio_vec, 1);
-	bio_vec.bv_page = page;
-	bio_vec.bv_len = PAGE_SIZE;
-	bio_vec.bv_offset = 0;
-	bio.bi_vcnt = 1;
 	bio.bi_bdev = bdev;
 	bio.bi_iter.bi_sector = page->index * (PAGE_SIZE >> 9);
-	bio.bi_iter.bi_size = PAGE_SIZE;
+
+	bio_add_page(&bio, page, PAGE_SIZE, 0);
 
 	return submit_bio_wait(rw, &bio);
 }
-- 
1.9.1

[toc] | [prev] | [next] | [standalone]


#1371530 — Re: [PATCH 22/27] fs: logfs: convert to bio_add_page() in sync_request()

FromChristoph Hellwig <hch@infradead.org>
Date2016-04-05 15:00 +0200
SubjectRe: [PATCH 22/27] fs: logfs: convert to bio_add_page() in sync_request()
Message-ID<rkyKl-3D8-1@gated-at.bofh.it>
In reply to#1371478
Looks fine,

Reviewed-by: Christoph Hellwig <hch@lst.de>

[toc] | [prev] | [next] | [standalone]


#1371480 — [PATCH 19/27] dm: dm.c: replace 'bio->bi_vcnt == 1' with !bio_multiple_segments

FromMing Lei <tom.leiming@gmail.com>
Date2016-04-05 14:10 +0200
Subject[PATCH 19/27] dm: dm.c: replace 'bio->bi_vcnt == 1' with !bio_multiple_segments
Message-ID<rkxY0-36a-67@gated-at.bofh.it>
In reply to#1371471
Signed-off-by: Ming Lei <tom.leiming@gmail.com>
---
 drivers/md/dm.c | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/drivers/md/dm.c b/drivers/md/dm.c
index be49057..4c34f88 100644
--- a/drivers/md/dm.c
+++ b/drivers/md/dm.c
@@ -2172,7 +2172,8 @@ static void dm_request_fn(struct request_queue *q)
 			pos = blk_rq_pos(rq);
 
 		if ((dm_request_peeked_before_merge_deadline(md) &&
-		     md_in_flight(md) && rq->bio && rq->bio->bi_vcnt == 1 &&
+		     md_in_flight(md) && rq->bio &&
+		     !bio_multiple_segments(rq->bio) &&
 		     md->last_rq_pos == pos && md->last_rq_rw == rq_data_dir(rq)) ||
 		    (ti->type->busy && ti->type->busy(ti))) {
 			blk_delay_queue(q, HZ / 100);
-- 
1.9.1

[toc] | [prev] | [next] | [standalone]


#1371490 — [PATCH 26/27] kernel/power/swap.c: use bio_get_base_vec()

FromMing Lei <tom.leiming@gmail.com>
Date2016-04-05 14:20 +0200
Subject[PATCH 26/27] kernel/power/swap.c: use bio_get_base_vec()
Message-ID<rky7E-3bC-23@gated-at.bofh.it>
In reply to#1371471
Signed-off-by: Ming Lei <tom.leiming@gmail.com>
---
 kernel/power/swap.c | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

diff --git a/kernel/power/swap.c b/kernel/power/swap.c
index 12cd989..cedf752 100644
--- a/kernel/power/swap.c
+++ b/kernel/power/swap.c
@@ -230,7 +230,15 @@ static void hib_init_batch(struct hib_bio_batch *hb)
 static void hib_end_io(struct bio *bio)
 {
 	struct hib_bio_batch *hb = bio->bi_private;
-	struct page *page = bio->bi_io_vec[0].bv_page;
+
+	/*
+	 * Single bvec bio.
+	 *
+	 * For accessing page pointed to by the 1st bvec, it
+	 * works too after multipage bvecs.
+	 */
+	struct bio_vec *bvec = bio_get_base_vec(bio);
+	struct page *page = bvec->bv_page;
 
 	if (bio->bi_error) {
 		printk(KERN_ALERT "Read-error on swap-device (%u:%u:%Lu)\n",
-- 
1.9.1

[toc] | [prev] | [next] | [standalone]


#1371540 — Re: [PATCH 26/27] kernel/power/swap.c: use bio_get_base_vec()

FromChristoph Hellwig <hch@infradead.org>
Date2016-04-05 15:00 +0200
SubjectRe: [PATCH 26/27] kernel/power/swap.c: use bio_get_base_vec()
Message-ID<rkyKm-3D8-35@gated-at.bofh.it>
In reply to#1371490
I really don't like all these bio_get_base_vec uses.  The end_io
handlers generall want to iterate over all pages in the bio, with
a special case where all of them is the fixed number one.

So What I think we'll need is a bio_for_each_page, and if there is
any good justification for it as special version of the single
page case.

[toc] | [prev] | [next] | [standalone]


#1371558 — Re: [PATCH 26/27] kernel/power/swap.c: use bio_get_base_vec()

FromMing Lei <tom.leiming@gmail.com>
Date2016-04-05 15:20 +0200
SubjectRe: [PATCH 26/27] kernel/power/swap.c: use bio_get_base_vec()
Message-ID<rkz3H-45b-5@gated-at.bofh.it>
In reply to#1371540
On Tue, Apr 5, 2016 at 8:56 PM, Christoph Hellwig <hch@infradead.org> wrote:
> I really don't like all these bio_get_base_vec uses.  The end_io
> handlers generall want to iterate over all pages in the bio, with
> a special case where all of them is the fixed number one.
>
> So What I think we'll need is a bio_for_each_page, and if there is
> any good justification for it as special version of the single
> page case.

I thought about that too, and bio_get_base_vec() can be thought as
the special version too, IMO.  Actually it is just about the name of
the helper, do you have a better name or other idea for such issue?

There are about ten such usages, as found in this patchset.


Thanks,
Ming Lei

[toc] | [prev] | [next] | [standalone]


#1371493 — [PATCH 25/27] fs: logfs: remove unnecesary check

FromMing Lei <tom.leiming@gmail.com>
Date2016-04-05 14:20 +0200
Subject[PATCH 25/27] fs: logfs: remove unnecesary check
Message-ID<rky7E-3bC-33@gated-at.bofh.it>
In reply to#1371471
The check on bio->bi_vcnt doesn't make sense in erase_end_io().

Signed-off-by: Ming Lei <tom.leiming@gmail.com>
---
 fs/logfs/dev_bdev.c | 1 -
 1 file changed, 1 deletion(-)

diff --git a/fs/logfs/dev_bdev.c b/fs/logfs/dev_bdev.c
index db04231..3d9cde7 100644
--- a/fs/logfs/dev_bdev.c
+++ b/fs/logfs/dev_bdev.c
@@ -144,7 +144,6 @@ static void erase_end_io(struct bio *bio)
 	struct logfs_super *super = logfs_super(sb); 
 
 	BUG_ON(bio->bi_error); /* FIXME: Retry io or write elsewhere */ 
-	BUG_ON(bio->bi_vcnt == 0); 
 	bio_put(bio); 
 	if (atomic_dec_and_test(&super->s_pending_writes))
 		wake_up(&wq); 
-- 
1.9.1

[toc] | [prev] | [next] | [standalone]


#1371498 — [PATCH 27/27] mm: page_io.c: use bio_get_base_vec()

FromMing Lei <tom.leiming@gmail.com>
Date2016-04-05 14:20 +0200
Subject[PATCH 27/27] mm: page_io.c: use bio_get_base_vec()
Message-ID<rky7G-3bC-47@gated-at.bofh.it>
In reply to#1371471
Signed-off-by: Ming Lei <tom.leiming@gmail.com>
---
 mm/page_io.c | 18 ++++++++++++++++--
 1 file changed, 16 insertions(+), 2 deletions(-)

diff --git a/mm/page_io.c b/mm/page_io.c
index 18aac78..b5a6baf 100644
--- a/mm/page_io.c
+++ b/mm/page_io.c
@@ -43,7 +43,14 @@ static struct bio *get_swap_bio(gfp_t gfp_flags,
 
 void end_swap_bio_write(struct bio *bio)
 {
-	struct page *page = bio->bi_io_vec[0].bv_page;
+	/*
+	 * Single bvec bio.
+	 *
+	 * For accessing page pointed to by the 1st bvec, it
+	 * works too after multipage bvecs.
+	 */
+	struct bio_vec *bvec = bio_get_base_vec(bio);
+	struct page *page = bvec->bv_page;
 
 	if (bio->bi_error) {
 		SetPageError(page);
@@ -116,7 +123,14 @@ static void swap_slot_free_notify(struct page *page)
 
 static void end_swap_bio_read(struct bio *bio)
 {
-	struct page *page = bio->bi_io_vec[0].bv_page;
+	/*
+	 * Single bvec bio.
+	 *
+	 * For accessing page pointed to by the 1st bvec, it
+	 * works too after multipage bvecs.
+	 */
+	struct bio_vec *bvec = bio_get_base_vec(bio);
+	struct page *page = bvec->bv_page;
 
 	if (bio->bi_error) {
 		SetPageError(page);
-- 
1.9.1

[toc] | [prev] | [next] | [standalone]


#1371499 — [PATCH 24/27] fs: logfs: use bio_add_page() in do_erase()

FromMing Lei <tom.leiming@gmail.com>
Date2016-04-05 14:20 +0200
Subject[PATCH 24/27] fs: logfs: use bio_add_page() in do_erase()
Message-ID<rky7G-3bC-45@gated-at.bofh.it>
In reply to#1371471
Also code gets simplified a bit.

Signed-off-by: Ming Lei <tom.leiming@gmail.com>
---
 fs/logfs/dev_bdev.c | 45 ++++++++++++++++++---------------------------
 1 file changed, 18 insertions(+), 27 deletions(-)

diff --git a/fs/logfs/dev_bdev.c b/fs/logfs/dev_bdev.c
index 1df84e0..db04231 100644
--- a/fs/logfs/dev_bdev.c
+++ b/fs/logfs/dev_bdev.c
@@ -154,47 +154,38 @@ static int do_erase(struct super_block *sb, u64 ofs, pgoff_t index,
 		size_t nr_pages)
 {
 	struct logfs_super *super = logfs_super(sb);
-	struct bio *bio;
+	struct bio *bio = NULL;
 	unsigned int max_pages;
-	int i;
+	int i, ret;
 
 	max_pages = min_t(size_t, nr_pages, BIO_MAX_PAGES);
 
-	bio = bio_alloc(GFP_NOFS, max_pages);
-	BUG_ON(!bio);
-
 	for (i = 0; i < nr_pages; i++) {
-		if (i >= max_pages) {
-			/* Block layer cannot split bios :( */
-			bio->bi_vcnt = i;
-			bio->bi_iter.bi_size = i * PAGE_SIZE;
+		if (!bio) {
+			bio = bio_alloc(GFP_NOFS, max_pages);
+			BUG_ON(!bio);
+
 			bio->bi_bdev = super->s_bdev;
 			bio->bi_iter.bi_sector = ofs >> 9;
 			bio->bi_private = sb;
 			bio->bi_end_io = erase_end_io;
+		}
+
+		ret = bio_add_page(bio, super->s_erase_page, PAGE_SIZE, 0);
+		if (!ret) {
+			/* Block layer cannot split bios :( */
+			ofs += bio->bi_iter.bi_size;
 			atomic_inc(&super->s_pending_writes);
 			submit_bio(WRITE, bio);
 
-			ofs += i * PAGE_SIZE;
-			index += i;
-			nr_pages -= i;
-			i = 0;
-
-			bio = bio_alloc(GFP_NOFS, max_pages);
-			BUG_ON(!bio);
+			bio = NULL;
 		}
-		bio->bi_io_vec[i].bv_page = super->s_erase_page;
-		bio->bi_io_vec[i].bv_len = PAGE_SIZE;
-		bio->bi_io_vec[i].bv_offset = 0;
 	}
-	bio->bi_vcnt = nr_pages;
-	bio->bi_iter.bi_size = nr_pages * PAGE_SIZE;
-	bio->bi_bdev = super->s_bdev;
-	bio->bi_iter.bi_sector = ofs >> 9;
-	bio->bi_private = sb;
-	bio->bi_end_io = erase_end_io;
-	atomic_inc(&super->s_pending_writes);
-	submit_bio(WRITE, bio);
+
+	if (bio) {
+		atomic_inc(&super->s_pending_writes);
+		submit_bio(WRITE, bio);
+	}
 	return 0;
 }
 
-- 
1.9.1

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web