Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1371558

Re: [PATCH 26/27] kernel/power/swap.c: use bio_get_base_vec()

From Ming Lei <tom.leiming@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH 26/27] kernel/power/swap.c: use bio_get_base_vec()
Date 2016-04-05 15:20 +0200
Message-ID <rkz3H-45b-5@gated-at.bofh.it> (permalink)
References <rkxXX-36a-3@gated-at.bofh.it> <rky7E-3bC-23@gated-at.bofh.it> <rkyKm-3D8-35@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, Apr 5, 2016 at 8:56 PM, Christoph Hellwig <hch@infradead.org> wrote:
> I really don't like all these bio_get_base_vec uses.  The end_io
> handlers generall want to iterate over all pages in the bio, with
> a special case where all of them is the fixed number one.
>
> So What I think we'll need is a bio_for_each_page, and if there is
> any good justification for it as special version of the single
> page case.

I thought about that too, and bio_get_base_vec() can be thought as
the special version too, IMO.  Actually it is just about the name of
the helper, do you have a better name or other idea for such issue?

There are about ten such usages, as found in this patchset.


Thanks,
Ming Lei

Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 15/27] bcache: super: use bio_set_vec_table() Ming Lei <tom.leiming@gmail.com> - 2016-04-05 14:10 +0200
  [PATCH 18/27] dm: dm-io.c: use bio_get_base_vec() Ming Lei <tom.leiming@gmail.com> - 2016-04-05 14:10 +0200
  [PATCH 22/27] fs: logfs: convert to bio_add_page() in sync_request() Ming Lei <tom.leiming@gmail.com> - 2016-04-05 14:10 +0200
    Re: [PATCH 22/27] fs: logfs: convert to bio_add_page() in  sync_request() Christoph Hellwig <hch@infradead.org> - 2016-04-05 15:00 +0200
  [PATCH 19/27] dm: dm.c: replace 'bio->bi_vcnt == 1' with !bio_multiple_segments Ming Lei <tom.leiming@gmail.com> - 2016-04-05 14:10 +0200
  [PATCH 26/27] kernel/power/swap.c: use bio_get_base_vec() Ming Lei <tom.leiming@gmail.com> - 2016-04-05 14:20 +0200
    Re: [PATCH 26/27] kernel/power/swap.c: use bio_get_base_vec() Christoph Hellwig <hch@infradead.org> - 2016-04-05 15:00 +0200
      Re: [PATCH 26/27] kernel/power/swap.c: use bio_get_base_vec() Ming Lei <tom.leiming@gmail.com> - 2016-04-05 15:20 +0200
  [PATCH 25/27] fs: logfs: remove unnecesary check Ming Lei <tom.leiming@gmail.com> - 2016-04-05 14:20 +0200
  [PATCH 27/27] mm: page_io.c: use bio_get_base_vec() Ming Lei <tom.leiming@gmail.com> - 2016-04-05 14:20 +0200
  [PATCH 24/27] fs: logfs: use bio_add_page() in do_erase() Ming Lei <tom.leiming@gmail.com> - 2016-04-05 14:20 +0200

csiph-web