Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1354733 > unrolled thread

[PATCH v2 1/3] crypto: s5p-sss - Minor coding cleanups

Started byKrzysztof Kozlowski <k.kozlowski@samsung.com>
First post2016-03-10 02:40 +0100
Last post2016-03-14 23:40 +0100
Articles 3 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH v2 1/3] crypto: s5p-sss - Minor coding cleanups Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-03-10 02:40 +0100
    [PATCH v2 3/3] crypto: s5p-sss - Sort the headers to improve  readability Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-03-10 02:40 +0100
      Re: [PATCH v2 3/3] crypto: s5p-sss - Sort the headers to improve  readability Vladimir Zapolskiy <vz@mleia.com> - 2016-03-14 23:40 +0100

#1354733 — [PATCH v2 1/3] crypto: s5p-sss - Minor coding cleanups

FromKrzysztof Kozlowski <k.kozlowski@samsung.com>
Date2016-03-10 02:40 +0100
Subject[PATCH v2 1/3] crypto: s5p-sss - Minor coding cleanups
Message-ID<raXK1-88R-3@gated-at.bofh.it>
From: Krzysztof Kozlowski <krzk@kernel.org>

Remove unneeded inclusion of delay.h and get rid of indentation from
labels.

Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
Acked-by: Vladimir Zapolskiy <vz@mleia.com>

---

Changes since v1:
1. Add Vladimir's acked-by.
---
 drivers/crypto/s5p-sss.c | 15 +++++++--------
 1 file changed, 7 insertions(+), 8 deletions(-)

diff --git a/drivers/crypto/s5p-sss.c b/drivers/crypto/s5p-sss.c
index 5f161a9777e3..60f835455a41 100644
--- a/drivers/crypto/s5p-sss.c
+++ b/drivers/crypto/s5p-sss.c
@@ -11,7 +11,6 @@
  *
  */
 
-#include <linux/delay.h>
 #include <linux/err.h>
 #include <linux/module.h>
 #include <linux/init.h>
@@ -284,7 +283,7 @@ static int s5p_set_outdata(struct s5p_aes_dev *dev, struct scatterlist *sg)
 	dev->sg_dst = sg;
 	err = 0;
 
- exit:
+exit:
 	return err;
 }
 
@@ -310,7 +309,7 @@ static int s5p_set_indata(struct s5p_aes_dev *dev, struct scatterlist *sg)
 	dev->sg_src = sg;
 	err = 0;
 
- exit:
+exit:
 	return err;
 }
 
@@ -452,10 +451,10 @@ static void s5p_aes_crypt_start(struct s5p_aes_dev *dev, unsigned long mode)
 
 	return;
 
- outdata_error:
+outdata_error:
 	s5p_unset_indata(dev);
 
- indata_error:
+indata_error:
 	s5p_aes_complete(dev, err);
 	spin_unlock_irqrestore(&dev->lock, flags);
 }
@@ -506,7 +505,7 @@ static int s5p_aes_handle_req(struct s5p_aes_dev *dev,
 
 	tasklet_schedule(&dev->tasklet);
 
- exit:
+exit:
 	return err;
 }
 
@@ -705,7 +704,7 @@ static int s5p_aes_probe(struct platform_device *pdev)
 
 	return 0;
 
- err_algs:
+err_algs:
 	dev_err(dev, "can't register '%s': %d\n", algs[i].cra_name, err);
 
 	for (j = 0; j < i; j++)
@@ -713,7 +712,7 @@ static int s5p_aes_probe(struct platform_device *pdev)
 
 	tasklet_kill(&pdata->tasklet);
 
- err_irq:
+err_irq:
 	clk_disable_unprepare(pdata->clk);
 
 	s5p_dev = NULL;
-- 
2.5.0

[toc] | [next] | [standalone]


#1354734 — [PATCH v2 3/3] crypto: s5p-sss - Sort the headers to improve readability

FromKrzysztof Kozlowski <k.kozlowski@samsung.com>
Date2016-03-10 02:40 +0100
Subject[PATCH v2 3/3] crypto: s5p-sss - Sort the headers to improve readability
Message-ID<raXK2-88R-15@gated-at.bofh.it>
In reply to#1354733
Sort the headers alphabetically to improve readability and to spot
duplications easier.

Suggested-by: Vladimir Zapolskiy <vz@mleia.com>
Signed-off-by: Krzysztof Kozlowski <k.kozlowski@samsung.com>

---

Changes since v1:
1. New patch.

My email differs from one used in previous patches because this time I
am sending this from work.
---
 drivers/crypto/s5p-sss.c | 20 ++++++++++----------
 1 file changed, 10 insertions(+), 10 deletions(-)

diff --git a/drivers/crypto/s5p-sss.c b/drivers/crypto/s5p-sss.c
index bac1f4593f98..46fbeb933939 100644
--- a/drivers/crypto/s5p-sss.c
+++ b/drivers/crypto/s5p-sss.c
@@ -11,23 +11,23 @@
  *
  */
 
+#include <linux/clk.h>
+#include <linux/crypto.h>
+#include <linux/dma-mapping.h>
 #include <linux/err.h>
-#include <linux/module.h>
-#include <linux/init.h>
 #include <linux/errno.h>
+#include <linux/init.h>
+#include <linux/interrupt.h>
+#include <linux/io.h>
 #include <linux/kernel.h>
-#include <linux/clk.h>
+#include <linux/module.h>
+#include <linux/of.h>
 #include <linux/platform_device.h>
 #include <linux/scatterlist.h>
-#include <linux/dma-mapping.h>
-#include <linux/io.h>
-#include <linux/of.h>
-#include <linux/crypto.h>
-#include <linux/interrupt.h>
 
-#include <crypto/algapi.h>
-#include <crypto/aes.h>
 #include <crypto/ctr.h>
+#include <crypto/aes.h>
+#include <crypto/algapi.h>
 #include <crypto/scatterwalk.h>
 
 #define _SBF(s, v)                      ((v) << (s))
-- 
2.5.0

[toc] | [prev] | [next] | [standalone]


#1357656 — Re: [PATCH v2 3/3] crypto: s5p-sss - Sort the headers to improve readability

FromVladimir Zapolskiy <vz@mleia.com>
Date2016-03-14 23:40 +0100
SubjectRe: [PATCH v2 3/3] crypto: s5p-sss - Sort the headers to improve readability
Message-ID<rcJjA-1AB-11@gated-at.bofh.it>
In reply to#1354734
On 10.03.2016 03:31, Krzysztof Kozlowski wrote:
> Sort the headers alphabetically to improve readability and to spot
> duplications easier.
> 
> Suggested-by: Vladimir Zapolskiy <vz@mleia.com>
> Signed-off-by: Krzysztof Kozlowski <k.kozlowski@samsung.com>
> 
> ---
> 
> Changes since v1:
> 1. New patch.
> 
> My email differs from one used in previous patches because this time I
> am sending this from work.
> ---
>  drivers/crypto/s5p-sss.c | 20 ++++++++++----------
>  1 file changed, 10 insertions(+), 10 deletions(-)
> 
> diff --git a/drivers/crypto/s5p-sss.c b/drivers/crypto/s5p-sss.c
> index bac1f4593f98..46fbeb933939 100644
> --- a/drivers/crypto/s5p-sss.c
> +++ b/drivers/crypto/s5p-sss.c
> @@ -11,23 +11,23 @@
>   *
>   */
>  
> +#include <linux/clk.h>
> +#include <linux/crypto.h>
> +#include <linux/dma-mapping.h>
>  #include <linux/err.h>
> -#include <linux/module.h>
> -#include <linux/init.h>
>  #include <linux/errno.h>
> +#include <linux/init.h>
> +#include <linux/interrupt.h>
> +#include <linux/io.h>
>  #include <linux/kernel.h>
> -#include <linux/clk.h>
> +#include <linux/module.h>
> +#include <linux/of.h>
>  #include <linux/platform_device.h>
>  #include <linux/scatterlist.h>
> -#include <linux/dma-mapping.h>
> -#include <linux/io.h>
> -#include <linux/of.h>
> -#include <linux/crypto.h>
> -#include <linux/interrupt.h>
>  
> -#include <crypto/algapi.h>
> -#include <crypto/aes.h>
>  #include <crypto/ctr.h>
> +#include <crypto/aes.h>
> +#include <crypto/algapi.h>
>  #include <crypto/scatterwalk.h>
>  
>  #define _SBF(s, v)                      ((v) << (s))
> 

Acked-by: Vladimir Zapolskiy <vz@mleia.com>

--
With best wishes,
Vladimir

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web