Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1357656

Re: [PATCH v2 3/3] crypto: s5p-sss - Sort the headers to improve readability

From Vladimir Zapolskiy <vz@mleia.com>
Newsgroups linux.kernel
Subject Re: [PATCH v2 3/3] crypto: s5p-sss - Sort the headers to improve readability
Date 2016-03-14 23:40 +0100
Message-ID <rcJjA-1AB-11@gated-at.bofh.it> (permalink)
References <raXK1-88R-3@gated-at.bofh.it> <raXK2-88R-15@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 10.03.2016 03:31, Krzysztof Kozlowski wrote:
> Sort the headers alphabetically to improve readability and to spot
> duplications easier.
> 
> Suggested-by: Vladimir Zapolskiy <vz@mleia.com>
> Signed-off-by: Krzysztof Kozlowski <k.kozlowski@samsung.com>
> 
> ---
> 
> Changes since v1:
> 1. New patch.
> 
> My email differs from one used in previous patches because this time I
> am sending this from work.
> ---
>  drivers/crypto/s5p-sss.c | 20 ++++++++++----------
>  1 file changed, 10 insertions(+), 10 deletions(-)
> 
> diff --git a/drivers/crypto/s5p-sss.c b/drivers/crypto/s5p-sss.c
> index bac1f4593f98..46fbeb933939 100644
> --- a/drivers/crypto/s5p-sss.c
> +++ b/drivers/crypto/s5p-sss.c
> @@ -11,23 +11,23 @@
>   *
>   */
>  
> +#include <linux/clk.h>
> +#include <linux/crypto.h>
> +#include <linux/dma-mapping.h>
>  #include <linux/err.h>
> -#include <linux/module.h>
> -#include <linux/init.h>
>  #include <linux/errno.h>
> +#include <linux/init.h>
> +#include <linux/interrupt.h>
> +#include <linux/io.h>
>  #include <linux/kernel.h>
> -#include <linux/clk.h>
> +#include <linux/module.h>
> +#include <linux/of.h>
>  #include <linux/platform_device.h>
>  #include <linux/scatterlist.h>
> -#include <linux/dma-mapping.h>
> -#include <linux/io.h>
> -#include <linux/of.h>
> -#include <linux/crypto.h>
> -#include <linux/interrupt.h>
>  
> -#include <crypto/algapi.h>
> -#include <crypto/aes.h>
>  #include <crypto/ctr.h>
> +#include <crypto/aes.h>
> +#include <crypto/algapi.h>
>  #include <crypto/scatterwalk.h>
>  
>  #define _SBF(s, v)                      ((v) << (s))
> 

Acked-by: Vladimir Zapolskiy <vz@mleia.com>

--
With best wishes,
Vladimir

Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

[PATCH v2 1/3] crypto: s5p-sss - Minor coding cleanups Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-03-10 02:40 +0100
  [PATCH v2 3/3] crypto: s5p-sss - Sort the headers to improve  readability Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-03-10 02:40 +0100
    Re: [PATCH v2 3/3] crypto: s5p-sss - Sort the headers to improve  readability Vladimir Zapolskiy <vz@mleia.com> - 2016-03-14 23:40 +0100

csiph-web