Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1439428 > unrolled thread

[PATCH] leds: leds-gpio: Set of_node for created LED devices

Started byRafał Miłecki <zajec5@gmail.com>
First post2016-07-08 15:00 +0200
Last post2016-07-11 10:30 +0200
Articles 5 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH] leds: leds-gpio: Set of_node for created LED devices Rafał Miłecki <zajec5@gmail.com> - 2016-07-08 15:00 +0200
    Re: [PATCH] leds: leds-gpio: Set of_node for created LED devices Jacek Anaszewski <j.anaszewski@samsung.com> - 2016-07-11 09:40 +0200
      Re: [PATCH] leds: leds-gpio: Set of_node for created LED devices Rafał Miłecki <zajec5@gmail.com> - 2016-07-11 10:00 +0200
        Re: [PATCH] leds: leds-gpio: Set of_node for created LED devices Rafał Miłecki <zajec5@gmail.com> - 2016-07-11 10:30 +0200
        Re: [PATCH] leds: leds-gpio: Set of_node for created LED devices Jacek Anaszewski <j.anaszewski@samsung.com> - 2016-07-11 10:30 +0200

#1439428 — [PATCH] leds: leds-gpio: Set of_node for created LED devices

FromRafał Miłecki <zajec5@gmail.com>
Date2016-07-08 15:00 +0200
Subject[PATCH] leds: leds-gpio: Set of_node for created LED devices
Message-ID<rSDxU-4TG-17@gated-at.bofh.it>
When working with Device Tree we iterate over children of "gpio-leds"
compatible node and create LED device for each of them. We take care of
all common DT properties (label, default trigger, state, etc.), however
some triggers may want to support more of them.

It could be useful for timer trigger to support setting delay on/off
values with Device Tree property. Or for transient trigger to support
e.g. duration property.

We obviously should handle such properties in triggers, not in generic
code. To let trigger drivers read properties from DT node we need to set
of_node to point the relevant node. This change allows using all kind of
of helpers in e.g. "activate" callbacks.

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
---
 drivers/leds/leds-gpio.c | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/drivers/leds/leds-gpio.c b/drivers/leds/leds-gpio.c
index 8229f06..9b991d4 100644
--- a/drivers/leds/leds-gpio.c
+++ b/drivers/leds/leds-gpio.c
@@ -165,6 +165,7 @@ static struct gpio_leds_priv *gpio_leds_create(struct platform_device *pdev)
 		return ERR_PTR(-ENOMEM);
 
 	device_for_each_child_node(dev, child) {
+		struct gpio_led_data *led_dat = &priv->leds[priv->num_leds];
 		struct gpio_led led = {};
 		const char *state = NULL;
 
@@ -205,12 +206,12 @@ static struct gpio_leds_priv *gpio_leds_create(struct platform_device *pdev)
 		if (fwnode_property_present(child, "panic-indicator"))
 			led.panic_indicator = 1;
 
-		ret = create_gpio_led(&led, &priv->leds[priv->num_leds],
-				      dev, NULL);
+		ret = create_gpio_led(&led, led_dat, dev, NULL);
 		if (ret < 0) {
 			fwnode_handle_put(child);
 			goto err;
 		}
+		led_dat->cdev.dev->of_node = np;
 		priv->num_leds++;
 	}
 
-- 
1.8.4.5

[toc] | [next] | [standalone]


#1440318

FromJacek Anaszewski <j.anaszewski@samsung.com>
Date2016-07-11 09:40 +0200
Message-ID<rTDYS-3YK-5@gated-at.bofh.it>
In reply to#1439428
Hi Rafał,

Thanks for the patch.

On 07/08/2016 02:53 PM, Rafał Miłecki wrote:
> When working with Device Tree we iterate over children of "gpio-leds"
> compatible node and create LED device for each of them. We take care of
> all common DT properties (label, default trigger, state, etc.), however
> some triggers may want to support more of them.
>
> It could be useful for timer trigger to support setting delay on/off
> values with Device Tree property. Or for transient trigger to support
> e.g. duration property.
>
> We obviously should handle such properties in triggers, not in generic
> code. To let trigger drivers read properties from DT node we need to set
> of_node to point the relevant node. This change allows using all kind of
> of helpers in e.g. "activate" callbacks.
>
> Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
> ---
>   drivers/leds/leds-gpio.c | 5 +++--
>   1 file changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/leds/leds-gpio.c b/drivers/leds/leds-gpio.c
> index 8229f06..9b991d4 100644
> --- a/drivers/leds/leds-gpio.c
> +++ b/drivers/leds/leds-gpio.c
> @@ -165,6 +165,7 @@ static struct gpio_leds_priv *gpio_leds_create(struct platform_device *pdev)
>   		return ERR_PTR(-ENOMEM);
>
>   	device_for_each_child_node(dev, child) {
> +		struct gpio_led_data *led_dat = &priv->leds[priv->num_leds];

This seems to be an unrelated change.

>   		struct gpio_led led = {};
>   		const char *state = NULL;
>
> @@ -205,12 +206,12 @@ static struct gpio_leds_priv *gpio_leds_create(struct platform_device *pdev)
>   		if (fwnode_property_present(child, "panic-indicator"))
>   			led.panic_indicator = 1;
>
> -		ret = create_gpio_led(&led, &priv->leds[priv->num_leds],
> -				      dev, NULL);
> +		ret = create_gpio_led(&led, led_dat, dev, NULL);
>   		if (ret < 0) {
>   			fwnode_handle_put(child);
>   			goto err;
>   		}
> +		led_dat->cdev.dev->of_node = np;
>   		priv->num_leds++;
>   	}
>
>


-- 
Best regards,
Jacek Anaszewski

[toc] | [prev] | [next] | [standalone]


#1440335

FromRafał Miłecki <zajec5@gmail.com>
Date2016-07-11 10:00 +0200
Message-ID<rTEie-45r-19@gated-at.bofh.it>
In reply to#1440318
On 07/11/2016 09:34 AM, Jacek Anaszewski wrote:
> On 07/08/2016 02:53 PM, Rafał Miłecki wrote:
>> When working with Device Tree we iterate over children of "gpio-leds"
>> compatible node and create LED device for each of them. We take care of
>> all common DT properties (label, default trigger, state, etc.), however
>> some triggers may want to support more of them.
>>
>> It could be useful for timer trigger to support setting delay on/off
>> values with Device Tree property. Or for transient trigger to support
>> e.g. duration property.
>>
>> We obviously should handle such properties in triggers, not in generic
>> code. To let trigger drivers read properties from DT node we need to set
>> of_node to point the relevant node. This change allows using all kind of
>> of helpers in e.g. "activate" callbacks.
>>
>> Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
>> ---
>>   drivers/leds/leds-gpio.c | 5 +++--
>>   1 file changed, 3 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/leds/leds-gpio.c b/drivers/leds/leds-gpio.c
>> index 8229f06..9b991d4 100644
>> --- a/drivers/leds/leds-gpio.c
>> +++ b/drivers/leds/leds-gpio.c
>> @@ -165,6 +165,7 @@ static struct gpio_leds_priv *gpio_leds_create(struct platform_device *pdev)
>>           return ERR_PTR(-ENOMEM);
>>
>>       device_for_each_child_node(dev, child) {
>> +        struct gpio_led_data *led_dat = &priv->leds[priv->num_leds];
>
> This seems to be an unrelated change.

We already got
&priv->leds[priv->num_leds]
and I needed to add
priv->leds[priv->num_leds].cdev.dev->of_node

I didn't want to duplicate code accessing so deep struct, so I added a helper.

Is that a good explanation? Or would you like me to change this code?

[toc] | [prev] | [next] | [standalone]


#1440352

FromRafał Miłecki <zajec5@gmail.com>
Date2016-07-11 10:30 +0200
Message-ID<rTELf-4vb-3@gated-at.bofh.it>
In reply to#1440335
On 07/11/2016 10:20 AM, Jacek Anaszewski wrote:
> On 07/11/2016 09:52 AM, Rafał Miłecki wrote:
>> On 07/11/2016 09:34 AM, Jacek Anaszewski wrote:
>>> On 07/08/2016 02:53 PM, Rafał Miłecki wrote:
>>>> When working with Device Tree we iterate over children of "gpio-leds"
>>>> compatible node and create LED device for each of them. We take care of
>>>> all common DT properties (label, default trigger, state, etc.), however
>>>> some triggers may want to support more of them.
>>>>
>>>> It could be useful for timer trigger to support setting delay on/off
>>>> values with Device Tree property. Or for transient trigger to support
>>>> e.g. duration property.
>>>>
>>>> We obviously should handle such properties in triggers, not in generic
>>>> code. To let trigger drivers read properties from DT node we need to set
>>>> of_node to point the relevant node. This change allows using all kind of
>>>> of helpers in e.g. "activate" callbacks.
>>>>
>>>> Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
>>>> ---
>>>>   drivers/leds/leds-gpio.c | 5 +++--
>>>>   1 file changed, 3 insertions(+), 2 deletions(-)
>>>>
>>>> diff --git a/drivers/leds/leds-gpio.c b/drivers/leds/leds-gpio.c
>>>> index 8229f06..9b991d4 100644
>>>> --- a/drivers/leds/leds-gpio.c
>>>> +++ b/drivers/leds/leds-gpio.c
>>>> @@ -165,6 +165,7 @@ static struct gpio_leds_priv
>>>> *gpio_leds_create(struct platform_device *pdev)
>>>>           return ERR_PTR(-ENOMEM);
>>>>
>>>>       device_for_each_child_node(dev, child) {
>>>> +        struct gpio_led_data *led_dat = &priv->leds[priv->num_leds];
>>>
>>> This seems to be an unrelated change.
>>
>> We already got
>> &priv->leds[priv->num_leds]
>> and I needed to add
>> priv->leds[priv->num_leds].cdev.dev->of_node
>>
>> I didn't want to duplicate code accessing so deep struct, so I added a
>> helper.
>>
>> Is that a good explanation? Or would you like me to change this code?
>
> Ah, I missed that. Patch applied.

Thanks :)

[toc] | [prev] | [next] | [standalone]


#1440357

FromJacek Anaszewski <j.anaszewski@samsung.com>
Date2016-07-11 10:30 +0200
Message-ID<rTELf-4vb-5@gated-at.bofh.it>
In reply to#1440335
On 07/11/2016 09:52 AM, Rafał Miłecki wrote:
> On 07/11/2016 09:34 AM, Jacek Anaszewski wrote:
>> On 07/08/2016 02:53 PM, Rafał Miłecki wrote:
>>> When working with Device Tree we iterate over children of "gpio-leds"
>>> compatible node and create LED device for each of them. We take care of
>>> all common DT properties (label, default trigger, state, etc.), however
>>> some triggers may want to support more of them.
>>>
>>> It could be useful for timer trigger to support setting delay on/off
>>> values with Device Tree property. Or for transient trigger to support
>>> e.g. duration property.
>>>
>>> We obviously should handle such properties in triggers, not in generic
>>> code. To let trigger drivers read properties from DT node we need to set
>>> of_node to point the relevant node. This change allows using all kind of
>>> of helpers in e.g. "activate" callbacks.
>>>
>>> Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
>>> ---
>>>   drivers/leds/leds-gpio.c | 5 +++--
>>>   1 file changed, 3 insertions(+), 2 deletions(-)
>>>
>>> diff --git a/drivers/leds/leds-gpio.c b/drivers/leds/leds-gpio.c
>>> index 8229f06..9b991d4 100644
>>> --- a/drivers/leds/leds-gpio.c
>>> +++ b/drivers/leds/leds-gpio.c
>>> @@ -165,6 +165,7 @@ static struct gpio_leds_priv
>>> *gpio_leds_create(struct platform_device *pdev)
>>>           return ERR_PTR(-ENOMEM);
>>>
>>>       device_for_each_child_node(dev, child) {
>>> +        struct gpio_led_data *led_dat = &priv->leds[priv->num_leds];
>>
>> This seems to be an unrelated change.
>
> We already got
> &priv->leds[priv->num_leds]
> and I needed to add
> priv->leds[priv->num_leds].cdev.dev->of_node
>
> I didn't want to duplicate code accessing so deep struct, so I added a
> helper.
>
> Is that a good explanation? Or would you like me to change this code?

Ah, I missed that. Patch applied.

Thanks,
Jacek Anaszewski

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web