Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1440352
| From | Rafał Miłecki <zajec5@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] leds: leds-gpio: Set of_node for created LED devices |
| Date | 2016-07-11 10:30 +0200 |
| Message-ID | <rTELf-4vb-3@gated-at.bofh.it> (permalink) |
| References | <rSDxU-4TG-17@gated-at.bofh.it> <rTDYS-3YK-5@gated-at.bofh.it> <rTEie-45r-19@gated-at.bofh.it> <rTELf-4vb-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 07/11/2016 10:20 AM, Jacek Anaszewski wrote:
> On 07/11/2016 09:52 AM, Rafał Miłecki wrote:
>> On 07/11/2016 09:34 AM, Jacek Anaszewski wrote:
>>> On 07/08/2016 02:53 PM, Rafał Miłecki wrote:
>>>> When working with Device Tree we iterate over children of "gpio-leds"
>>>> compatible node and create LED device for each of them. We take care of
>>>> all common DT properties (label, default trigger, state, etc.), however
>>>> some triggers may want to support more of them.
>>>>
>>>> It could be useful for timer trigger to support setting delay on/off
>>>> values with Device Tree property. Or for transient trigger to support
>>>> e.g. duration property.
>>>>
>>>> We obviously should handle such properties in triggers, not in generic
>>>> code. To let trigger drivers read properties from DT node we need to set
>>>> of_node to point the relevant node. This change allows using all kind of
>>>> of helpers in e.g. "activate" callbacks.
>>>>
>>>> Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
>>>> ---
>>>> drivers/leds/leds-gpio.c | 5 +++--
>>>> 1 file changed, 3 insertions(+), 2 deletions(-)
>>>>
>>>> diff --git a/drivers/leds/leds-gpio.c b/drivers/leds/leds-gpio.c
>>>> index 8229f06..9b991d4 100644
>>>> --- a/drivers/leds/leds-gpio.c
>>>> +++ b/drivers/leds/leds-gpio.c
>>>> @@ -165,6 +165,7 @@ static struct gpio_leds_priv
>>>> *gpio_leds_create(struct platform_device *pdev)
>>>> return ERR_PTR(-ENOMEM);
>>>>
>>>> device_for_each_child_node(dev, child) {
>>>> + struct gpio_led_data *led_dat = &priv->leds[priv->num_leds];
>>>
>>> This seems to be an unrelated change.
>>
>> We already got
>> &priv->leds[priv->num_leds]
>> and I needed to add
>> priv->leds[priv->num_leds].cdev.dev->of_node
>>
>> I didn't want to duplicate code accessing so deep struct, so I added a
>> helper.
>>
>> Is that a good explanation? Or would you like me to change this code?
>
> Ah, I missed that. Patch applied.
Thanks :)
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] leds: leds-gpio: Set of_node for created LED devices Rafał Miłecki <zajec5@gmail.com> - 2016-07-08 15:00 +0200
Re: [PATCH] leds: leds-gpio: Set of_node for created LED devices Jacek Anaszewski <j.anaszewski@samsung.com> - 2016-07-11 09:40 +0200
Re: [PATCH] leds: leds-gpio: Set of_node for created LED devices Rafał Miłecki <zajec5@gmail.com> - 2016-07-11 10:00 +0200
Re: [PATCH] leds: leds-gpio: Set of_node for created LED devices Rafał Miłecki <zajec5@gmail.com> - 2016-07-11 10:30 +0200
Re: [PATCH] leds: leds-gpio: Set of_node for created LED devices Jacek Anaszewski <j.anaszewski@samsung.com> - 2016-07-11 10:30 +0200
csiph-web