Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1435378 > unrolled thread

[PATCH] iio: dac: mcp4725: Remove unneeded conversions to bool

Started by"Andrew F. Davis" <afd@ti.com>
First post2016-07-01 16:40 +0200
Last post2016-07-01 17:20 +0200
Articles 3 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH] iio: dac: mcp4725: Remove unneeded conversions to bool "Andrew F. Davis" <afd@ti.com> - 2016-07-01 16:40 +0200
    Re: [PATCH] iio: dac: mcp4725: Remove unneeded conversions to bool Peter Meerwald-Stadler <pmeerw@pmeerw.net> - 2016-07-01 17:10 +0200
      Re: [PATCH] iio: dac: mcp4725: Remove unneeded conversions to bool "Andrew F. Davis" <afd@ti.com> - 2016-07-01 17:20 +0200

#1435378 — [PATCH] iio: dac: mcp4725: Remove unneeded conversions to bool

From"Andrew F. Davis" <afd@ti.com>
Date2016-07-01 16:40 +0200
Subject[PATCH] iio: dac: mcp4725: Remove unneeded conversions to bool
Message-ID<rQ7LQ-7MG-1@gated-at.bofh.it>
Found with scripts/coccinelle/misc/boolconv.cocci.

Signed-off-by: Andrew F. Davis <afd@ti.com>
---
 drivers/iio/dac/mcp4725.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/iio/dac/mcp4725.c b/drivers/iio/dac/mcp4725.c
index cca935c..c3bb3fd 100644
--- a/drivers/iio/dac/mcp4725.c
+++ b/drivers/iio/dac/mcp4725.c
@@ -361,7 +361,7 @@ static int mcp4725_probe(struct i2c_client *client,
 		return err;
 	}
 	pd = (inbuf[0] >> 1) & 0x3;
-	data->powerdown = pd > 0 ? true : false;
+	data->powerdown = pd > 0;
 	data->powerdown_mode = pd ? pd - 1 : 2; /* largest register to gnd */
 	data->dac_value = (inbuf[1] << 4) | (inbuf[2] >> 4);
 
-- 
2.9.0

[toc] | [next] | [standalone]


#1435409

FromPeter Meerwald-Stadler <pmeerw@pmeerw.net>
Date2016-07-01 17:10 +0200
Message-ID<rQ8eT-8cq-53@gated-at.bofh.it>
In reply to#1435378
> Found with scripts/coccinelle/misc/boolconv.cocci.

I'd argue that

        pd = (inbuf[0] >> 1) & 0x3;
        if (pd) {
                data->powerdown = true;
                data->powerdown_mode = pd - 1;
        } else {
                data->powerdown = false;
                data->powerdown_mode = 2; /* largest register to gnd */
        }

is less compact but probably easier to read/understand;

> Signed-off-by: Andrew F. Davis <afd@ti.com>

but I'm fine with the proposed patch as well to make cocci happy

regards, p.

> ---
>  drivers/iio/dac/mcp4725.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/iio/dac/mcp4725.c b/drivers/iio/dac/mcp4725.c
> index cca935c..c3bb3fd 100644
> --- a/drivers/iio/dac/mcp4725.c
> +++ b/drivers/iio/dac/mcp4725.c
> @@ -361,7 +361,7 @@ static int mcp4725_probe(struct i2c_client *client,
>  		return err;
>  	}
>  	pd = (inbuf[0] >> 1) & 0x3;
> -	data->powerdown = pd > 0 ? true : false;
> +	data->powerdown = pd > 0;
>  	data->powerdown_mode = pd ? pd - 1 : 2; /* largest register to gnd */
>  	data->dac_value = (inbuf[1] << 4) | (inbuf[2] >> 4);
>  
> 

-- 

Peter Meerwald-Stadler
+43-664-2444418 (mobile)

[toc] | [prev] | [next] | [standalone]


#1435413

From"Andrew F. Davis" <afd@ti.com>
Date2016-07-01 17:20 +0200
Message-ID<rQ8ox-8fN-5@gated-at.bofh.it>
In reply to#1435409
On 07/01/2016 10:03 AM, Peter Meerwald-Stadler wrote:
> 
>> Found with scripts/coccinelle/misc/boolconv.cocci.
> 
> I'd argue that
> 
>         pd = (inbuf[0] >> 1) & 0x3;
>         if (pd) {
>                 data->powerdown = true;
>                 data->powerdown_mode = pd - 1;
>         } else {
>                 data->powerdown = false;
>                 data->powerdown_mode = 2; /* largest register to gnd */
>         }
> 
> is less compact but probably easier to read/understand;
> 

I agree, this is a much better fix. Would you like to submit this
version as a patch?

Andrew

>> Signed-off-by: Andrew F. Davis <afd@ti.com>
> 
> but I'm fine with the proposed patch as well to make cocci happy
> 
> regards, p.
> 
>> ---
>>  drivers/iio/dac/mcp4725.c | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/drivers/iio/dac/mcp4725.c b/drivers/iio/dac/mcp4725.c
>> index cca935c..c3bb3fd 100644
>> --- a/drivers/iio/dac/mcp4725.c
>> +++ b/drivers/iio/dac/mcp4725.c
>> @@ -361,7 +361,7 @@ static int mcp4725_probe(struct i2c_client *client,
>>  		return err;
>>  	}
>>  	pd = (inbuf[0] >> 1) & 0x3;
>> -	data->powerdown = pd > 0 ? true : false;
>> +	data->powerdown = pd > 0;
>>  	data->powerdown_mode = pd ? pd - 1 : 2; /* largest register to gnd */
>>  	data->dac_value = (inbuf[1] << 4) | (inbuf[2] >> 4);
>>  
>>
> 

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web