Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1435409

Re: [PATCH] iio: dac: mcp4725: Remove unneeded conversions to bool

From Peter Meerwald-Stadler <pmeerw@pmeerw.net>
Newsgroups linux.kernel
Subject Re: [PATCH] iio: dac: mcp4725: Remove unneeded conversions to bool
Date 2016-07-01 17:10 +0200
Message-ID <rQ8eT-8cq-53@gated-at.bofh.it> (permalink)
References <rQ7LQ-7MG-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


> Found with scripts/coccinelle/misc/boolconv.cocci.

I'd argue that

        pd = (inbuf[0] >> 1) & 0x3;
        if (pd) {
                data->powerdown = true;
                data->powerdown_mode = pd - 1;
        } else {
                data->powerdown = false;
                data->powerdown_mode = 2; /* largest register to gnd */
        }

is less compact but probably easier to read/understand;

> Signed-off-by: Andrew F. Davis <afd@ti.com>

but I'm fine with the proposed patch as well to make cocci happy

regards, p.

> ---
>  drivers/iio/dac/mcp4725.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/iio/dac/mcp4725.c b/drivers/iio/dac/mcp4725.c
> index cca935c..c3bb3fd 100644
> --- a/drivers/iio/dac/mcp4725.c
> +++ b/drivers/iio/dac/mcp4725.c
> @@ -361,7 +361,7 @@ static int mcp4725_probe(struct i2c_client *client,
>  		return err;
>  	}
>  	pd = (inbuf[0] >> 1) & 0x3;
> -	data->powerdown = pd > 0 ? true : false;
> +	data->powerdown = pd > 0;
>  	data->powerdown_mode = pd ? pd - 1 : 2; /* largest register to gnd */
>  	data->dac_value = (inbuf[1] << 4) | (inbuf[2] >> 4);
>  
> 

-- 

Peter Meerwald-Stadler
+43-664-2444418 (mobile)

Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH] iio: dac: mcp4725: Remove unneeded conversions to bool "Andrew F. Davis" <afd@ti.com> - 2016-07-01 16:40 +0200
  Re: [PATCH] iio: dac: mcp4725: Remove unneeded conversions to bool Peter Meerwald-Stadler <pmeerw@pmeerw.net> - 2016-07-01 17:10 +0200
    Re: [PATCH] iio: dac: mcp4725: Remove unneeded conversions to bool "Andrew F. Davis" <afd@ti.com> - 2016-07-01 17:20 +0200

csiph-web