Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1430835 > unrolled thread

[PATCH] powerpc/fadump: trivial fix of spelling mistake, clean up message

Started byColin King <colin.king@canonical.com>
First post2016-06-24 19:50 +0200
Last post2016-06-28 06:00 +0200
Articles 8 — 4 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH] powerpc/fadump: trivial fix of spelling mistake, clean up message Colin King <colin.king@canonical.com> - 2016-06-24 19:50 +0200
    Re: powerpc/fadump: trivial fix of spelling mistake, clean up message Michael Ellerman <mpe@ellerman.id.au> - 2016-06-26 06:20 +0200
      Re: powerpc/fadump: trivial fix of spelling mistake, clean up message Colin Ian King <colin.king@canonical.com> - 2016-06-27 12:40 +0200
        Re: powerpc/fadump: trivial fix of spelling mistake, clean up  message Joe Perches <joe@perches.com> - 2016-06-27 13:00 +0200
          Re: powerpc/fadump: trivial fix of spelling mistake, clean up  message Michael Ellerman <mpe@ellerman.id.au> - 2016-06-27 13:30 +0200
            Re: powerpc/fadump: trivial fix of spelling mistake, clean up  message Joe Perches <joe@perches.com> - 2016-06-27 13:40 +0200
            Re: powerpc/fadump: trivial fix of spelling mistake, clean up message Colin Ian King <colin.king@canonical.com> - 2016-06-27 13:40 +0200
              Re: powerpc/fadump: trivial fix of spelling mistake, clean up  message Michael Ellerman <mpe@ellerman.id.au> - 2016-06-28 06:00 +0200

#1430835 — [PATCH] powerpc/fadump: trivial fix of spelling mistake, clean up message

FromColin King <colin.king@canonical.com>
Date2016-06-24 19:50 +0200
Subject[PATCH] powerpc/fadump: trivial fix of spelling mistake, clean up message
Message-ID<rNDoS-2OX-15@gated-at.bofh.it>
From: Colin Ian King <colin.king@canonical.com>

trivial fix to spelling mistake "rgistration" and minor clean up
of the printk error message

Signed-off-by: Colin Ian King <colin.king@canonical.com>
---
 arch/powerpc/kernel/fadump.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/powerpc/kernel/fadump.c b/arch/powerpc/kernel/fadump.c
index 3cb3b02a..0358f5b 100644
--- a/arch/powerpc/kernel/fadump.c
+++ b/arch/powerpc/kernel/fadump.c
@@ -1010,7 +1010,7 @@ static int fadump_invalidate_dump(struct fadump_mem_struct *fdm)
 
 	if (rc) {
 		printk(KERN_ERR "Failed to invalidate firmware-assisted dump "
-			"rgistration. unexpected error(%d).\n", rc);
+			"registration. Unexpected error (%d).\n", rc);
 		return rc;
 	}
 	fw_dump.dump_active = 0;
-- 
2.8.1

[toc] | [next] | [standalone]


#1431326 — Re: powerpc/fadump: trivial fix of spelling mistake, clean up message

FromMichael Ellerman <mpe@ellerman.id.au>
Date2016-06-26 06:20 +0200
SubjectRe: powerpc/fadump: trivial fix of spelling mistake, clean up message
Message-ID<rO9I5-6oK-9@gated-at.bofh.it>
In reply to#1430835
On Fri, 2016-24-06 at 17:43:00 UTC, Colin King wrote:
> From: Colin Ian King <colin.king@canonical.com>
> 
> trivial fix to spelling mistake "rgistration" and minor clean up
> of the printk error message

Can you also:
 - use pr_err()
 - unsplit the message, ie. keep the string all on one line.

cheers

[toc] | [prev] | [next] | [standalone]


#1431915 — Re: powerpc/fadump: trivial fix of spelling mistake, clean up message

FromColin Ian King <colin.king@canonical.com>
Date2016-06-27 12:40 +0200
SubjectRe: powerpc/fadump: trivial fix of spelling mistake, clean up message
Message-ID<rOC7o-7sH-39@gated-at.bofh.it>
In reply to#1431326
On 26/06/16 05:19, Michael Ellerman wrote:
> On Fri, 2016-24-06 at 17:43:00 UTC, Colin King wrote:
>> From: Colin Ian King <colin.king@canonical.com>
>>
>> trivial fix to spelling mistake "rgistration" and minor clean up
>> of the printk error message
> 
> Can you also:
>  - use pr_err()
>  - unsplit the message, ie. keep the string all on one line.

I can unsplit the string, but checkpatch will complain about that, so
I'm not sure if that's preferred or not.

WARNING: line over 80 characters

Colin

[toc] | [prev] | [next] | [standalone]


#1431920 — Re: powerpc/fadump: trivial fix of spelling mistake, clean up message

FromJoe Perches <joe@perches.com>
Date2016-06-27 13:00 +0200
SubjectRe: powerpc/fadump: trivial fix of spelling mistake, clean up message
Message-ID<rOCqJ-7A9-17@gated-at.bofh.it>
In reply to#1431915
On Mon, 2016-06-27 at 11:38 +0100, Colin Ian King wrote:
> On 26/06/16 05:19, Michael Ellerman wrote:
> > On Fri, 2016-24-06 at 17:43:00 UTC, Colin King wrote:
[]
> > > trivial fix to spelling mistake "rgistration" and minor clean up
> > > of the printk error message
> > Can you also:
> >  - use pr_err()
> >  - unsplit the message, ie. keep the string all on one line.
> I can unsplit the string, but checkpatch will complain about that, so
> I'm not sure if that's preferred or not.
> 
> WARNING: line over 80 characters

If the statement is wrapped after the format,
then checkpatch shouldn't complain.

	pr_err("Failed to invalidate firmware-assisted dump registration. Unexpected error (%d).\n",
	       rc);

[toc] | [prev] | [next] | [standalone]


#1431952 — Re: powerpc/fadump: trivial fix of spelling mistake, clean up message

FromMichael Ellerman <mpe@ellerman.id.au>
Date2016-06-27 13:30 +0200
SubjectRe: powerpc/fadump: trivial fix of spelling mistake, clean up message
Message-ID<rOCTM-809-29@gated-at.bofh.it>
In reply to#1431920
On Mon, 2016-06-27 at 03:51 -0700, Joe Perches wrote:
> On Mon, 2016-06-27 at 11:38 +0100, Colin Ian King wrote:
> > On 26/06/16 05:19, Michael Ellerman wrote:
> > > On Fri, 2016-24-06 at 17:43:00 UTC, Colin King wrote:
> > > > trivial fix to spelling mistake "rgistration" and minor clean up
> > > > of the printk error message
> > > Can you also:
> > >  - use pr_err()
> > >  - unsplit the message, ie. keep the string all on one line.
> > I can unsplit the string, but checkpatch will complain about that, so
> > I'm not sure if that's preferred or not.
> > 
> > WARNING: line over 80 characters
> 
> If the statement is wrapped after the format,
> then checkpatch shouldn't complain.
> 
> 	pr_err("Failed to invalidate firmware-assisted dump registration. Unexpected error (%d).\n",
> 	       rc);

But that's not actually any more readable, so just ignore checkpatch in this
case IMHO. It's a guide, not the gospel.

cheers

[toc] | [prev] | [next] | [standalone]


#1431958 — Re: powerpc/fadump: trivial fix of spelling mistake, clean up message

FromJoe Perches <joe@perches.com>
Date2016-06-27 13:40 +0200
SubjectRe: powerpc/fadump: trivial fix of spelling mistake, clean up message
Message-ID<rOD3s-83w-1@gated-at.bofh.it>
In reply to#1431952
On Mon, 2016-06-27 at 21:20 +1000, Michael Ellerman wrote:
> On Mon, 2016-06-27 at 03:51 -0700, Joe Perches wrote:
> > 
> > On Mon, 2016-06-27 at 11:38 +0100, Colin Ian King wrote:
> > > 
> > > On 26/06/16 05:19, Michael Ellerman wrote:
> > > > 
> > > > On Fri, 2016-24-06 at 17:43:00 UTC, Colin King wrote:
> > > > > 
> > > > > trivial fix to spelling mistake "rgistration" and minor clean up
> > > > > of the printk error message
> > > > Can you also:
> > > >  - use pr_err()
> > > >  - unsplit the message, ie. keep the string all on one line.
> > > I can unsplit the string, but checkpatch will complain about that, so
> > > I'm not sure if that's preferred or not.
> > > 
> > > WARNING: line over 80 characters
> > If the statement is wrapped after the format,
> > then checkpatch shouldn't complain.
> > 
> > 	pr_err("Failed to invalidate firmware-assisted dump registration. Unexpected error (%d).\n",
> > 	       rc);
> But that's not actually any more readable, so just ignore checkpatch in this
> case IMHO. It's a guide, not the gospel.

Absolutely.  Ignore checkpatch whenever appropriate.

There are relatively few lines in kernel source that
have printk arguments post format that extend beyond
80 columns though and standardization is also good.

cheers back.

[toc] | [prev] | [next] | [standalone]


#1431968 — Re: powerpc/fadump: trivial fix of spelling mistake, clean up message

FromColin Ian King <colin.king@canonical.com>
Date2016-06-27 13:40 +0200
SubjectRe: powerpc/fadump: trivial fix of spelling mistake, clean up message
Message-ID<rOD3s-83w-33@gated-at.bofh.it>
In reply to#1431952
On 27/06/16 12:20, Michael Ellerman wrote:
> On Mon, 2016-06-27 at 03:51 -0700, Joe Perches wrote:
>> On Mon, 2016-06-27 at 11:38 +0100, Colin Ian King wrote:
>>> On 26/06/16 05:19, Michael Ellerman wrote:
>>>> On Fri, 2016-24-06 at 17:43:00 UTC, Colin King wrote:
>>>>> trivial fix to spelling mistake "rgistration" and minor clean up
>>>>> of the printk error message
>>>> Can you also:
>>>>  - use pr_err()
>>>>  - unsplit the message, ie. keep the string all on one line.
>>> I can unsplit the string, but checkpatch will complain about that, so
>>> I'm not sure if that's preferred or not.
>>>
>>> WARNING: line over 80 characters
>>
>> If the statement is wrapped after the format,
>> then checkpatch shouldn't complain.
>>
>> 	pr_err("Failed to invalidate firmware-assisted dump registration. Unexpected error (%d).\n",
>> 	       rc);
> 
> But that's not actually any more readable, so just ignore checkpatch in this
> case IMHO. It's a guide, not the gospel.
> 
> cheers
> 
OK, so shall I'll send a V3 w/o the spit and the pr_err fix?

[toc] | [prev] | [next] | [standalone]


#1432441 — Re: powerpc/fadump: trivial fix of spelling mistake, clean up message

FromMichael Ellerman <mpe@ellerman.id.au>
Date2016-06-28 06:00 +0200
SubjectRe: powerpc/fadump: trivial fix of spelling mistake, clean up message
Message-ID<rOSlP-1qN-1@gated-at.bofh.it>
In reply to#1431968
On Mon, 2016-06-27 at 12:34 +0100, Colin Ian King wrote:
> On 27/06/16 12:20, Michael Ellerman wrote:
> > On Mon, 2016-06-27 at 03:51 -0700, Joe Perches wrote:
> > > On Mon, 2016-06-27 at 11:38 +0100, Colin Ian King wrote:
> > > > On 26/06/16 05:19, Michael Ellerman wrote:
> > > > > On Fri, 2016-24-06 at 17:43:00 UTC, Colin King wrote:
> > > > > > trivial fix to spelling mistake "rgistration" and minor clean up
> > > > > > of the printk error message
> > > > > Can you also:
> > > > >  - use pr_err()
> > > > >  - unsplit the message, ie. keep the string all on one line.
> > > > I can unsplit the string, but checkpatch will complain about that, so
> > > > I'm not sure if that's preferred or not.
> > > > 
> > > > WARNING: line over 80 characters
> > > 
> > > If the statement is wrapped after the format,
> > > then checkpatch shouldn't complain.
> > > 
> > > 	pr_err("Failed to invalidate firmware-assisted dump registration. Unexpected error (%d).\n",
> > > 	       rc);
> > 
> > But that's not actually any more readable, so just ignore checkpatch in this
> > case IMHO. It's a guide, not the gospel.
>
> OK, so shall I'll send a V3 w/o the spit and the pr_err fix?

Nah that's fine, I already grabbed v2.

cheers

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web