Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1420245 > unrolled thread

Re: [PATCH 05/11] clk: imx: refine the powerup_set bit of clk-pllv3

Started byShawn Guo <shawnguo@kernel.org>
First post2016-06-12 13:40 +0200
Last post2016-06-12 17:00 +0200
Articles 5 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH 05/11] clk: imx: refine the powerup_set bit of clk-pllv3 Shawn Guo <shawnguo@kernel.org> - 2016-06-12 13:40 +0200
    Re: [PATCH 05/11] clk: imx: refine the powerup_set bit of clk-pllv3 Dong Aisheng <dongas86@gmail.com> - 2016-06-12 14:00 +0200
    Re: [PATCH 05/11] clk: imx: refine the powerup_set bit of clk-pllv3 Dong Aisheng <dongas86@gmail.com> - 2016-06-12 14:20 +0200
      Re: [PATCH 05/11] clk: imx: refine the powerup_set bit of clk-pllv3 Shawn Guo <shawnguo@kernel.org> - 2016-06-12 15:40 +0200
        Re: [PATCH 05/11] clk: imx: refine the powerup_set bit of clk-pllv3 Dong Aisheng <dongas86@gmail.com> - 2016-06-12 17:00 +0200

#1420245 — Re: [PATCH 05/11] clk: imx: refine the powerup_set bit of clk-pllv3

FromShawn Guo <shawnguo@kernel.org>
Date2016-06-12 13:40 +0200
SubjectRe: [PATCH 05/11] clk: imx: refine the powerup_set bit of clk-pllv3
Message-ID<rJbUd-854-23@gated-at.bofh.it>
On Wed, Jun 08, 2016 at 10:33:34PM +0800, Dong Aisheng wrote:
> There's a powerdown bit already, so let's change the name of
> powerup_set bit to power_invert to reflects the power polarity
> to make it less confusing.
> 
> Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
> ---
>  drivers/clk/imx/clk-pllv3.c | 14 +++++++-------
>  1 file changed, 7 insertions(+), 7 deletions(-)
> 
> diff --git a/drivers/clk/imx/clk-pllv3.c b/drivers/clk/imx/clk-pllv3.c
> index eea2b1b3791e..3fdfb6d2cc71 100644
> --- a/drivers/clk/imx/clk-pllv3.c
> +++ b/drivers/clk/imx/clk-pllv3.c
> @@ -29,8 +29,8 @@
>   * struct clk_pllv3 - IMX PLL clock version 3
>   * @clk_hw:	 clock source
>   * @base:	 base address of PLL registers
> - * @powerup_set: set POWER bit to power up the PLL
> - * @powerdown:   pll powerdown offset bit
> + * @powerdown:	 pll powerdown bit offset

I think 'powerdown' is more confusing here.  I prefer to rename it to
something like 'power_mask' and keep 'powerdown' as it is.

Shawn

> + * @power_invert: set powerdown bit to power up the PLL
>   * @div_mask:	 mask of divider bits
>   * @div_shift:	 shift of divider bits
>   *
> @@ -40,7 +40,7 @@
>  struct clk_pllv3 {
>  	struct clk_hw	hw;
>  	void __iomem	*base;
> -	bool		powerup_set;
> +	bool		power_invert;
>  	u32		powerdown;
>  	u32		div_mask;
>  	u32		div_shift;
> @@ -55,7 +55,7 @@ static int clk_pllv3_wait_lock(struct clk_pllv3 *pll)
>  	u32 val = readl_relaxed(pll->base) & pll->powerdown;
>  
>  	/* No need to wait for lock when pll is not powered up */
> -	if ((pll->powerup_set && !val) || (!pll->powerup_set && val))
> +	if ((pll->power_invert && !val) || (!pll->power_invert && val))
>  		return 0;
>  
>  	/* Wait for PLL to lock */
> @@ -76,7 +76,7 @@ static int clk_pllv3_prepare(struct clk_hw *hw)
>  	u32 val;
>  
>  	val = readl_relaxed(pll->base);
> -	if (pll->powerup_set)
> +	if (pll->power_invert)
>  		val |= pll->powerdown;
>  	else
>  		val &= ~pll->powerdown;
> @@ -91,7 +91,7 @@ static void clk_pllv3_unprepare(struct clk_hw *hw)
>  	u32 val;
>  
>  	val = readl_relaxed(pll->base);
> -	if (pll->powerup_set)
> +	if (pll->power_invert)
>  		val &= ~pll->powerdown;
>  	else
>  		val |= pll->powerdown;
> @@ -326,7 +326,7 @@ struct clk *imx_clk_pllv3(enum imx_pllv3_type type, const char *name,
>  		pll->div_shift = 1;
>  	case IMX_PLLV3_USB:
>  		ops = &clk_pllv3_ops;
> -		pll->powerup_set = true;
> +		pll->power_invert = true;
>  		break;
>  	case IMX_PLLV3_AV:
>  		ops = &clk_pllv3_av_ops;
> -- 
> 1.9.1
> 
> 
> _______________________________________________
> linux-arm-kernel mailing list
> linux-arm-kernel@lists.infradead.org
> http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

[toc] | [next] | [standalone]


#1420252

FromDong Aisheng <dongas86@gmail.com>
Date2016-06-12 14:00 +0200
Message-ID<rJcdA-8bT-9@gated-at.bofh.it>
In reply to#1420245
Hi Shawn,

On Sun, Jun 12, 2016 at 07:36:27PM +0800, Shawn Guo wrote:
> On Wed, Jun 08, 2016 at 10:33:34PM +0800, Dong Aisheng wrote:
> > There's a powerdown bit already, so let's change the name of
> > powerup_set bit to power_invert to reflects the power polarity
> > to make it less confusing.
> > 
> > Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
> > ---
> >  drivers/clk/imx/clk-pllv3.c | 14 +++++++-------
> >  1 file changed, 7 insertions(+), 7 deletions(-)
> > 
> > diff --git a/drivers/clk/imx/clk-pllv3.c b/drivers/clk/imx/clk-pllv3.c
> > index eea2b1b3791e..3fdfb6d2cc71 100644
> > --- a/drivers/clk/imx/clk-pllv3.c
> > +++ b/drivers/clk/imx/clk-pllv3.c
> > @@ -29,8 +29,8 @@
> >   * struct clk_pllv3 - IMX PLL clock version 3
> >   * @clk_hw:	 clock source
> >   * @base:	 base address of PLL registers
> > - * @powerup_set: set POWER bit to power up the PLL
> > - * @powerdown:   pll powerdown offset bit
> > + * @powerdown:	 pll powerdown bit offset
> 
> I think 'powerdown' is more confusing here.  I prefer to rename it to
> something like 'power_mask' and keep 'powerdown' as it is.
> 

A bit confused, you mean rename which one?
powerdown bit is defined by the spec so i just keep it.

Since *invert is wildly used in gpio subsystem, so i
change the powerup_set to power_invert to indicate the invert using
of powerdown bit.

Regards
Dong Aisheng

> Shawn
> 
> > + * @power_invert: set powerdown bit to power up the PLL
> >   * @div_mask:	 mask of divider bits
> >   * @div_shift:	 shift of divider bits
> >   *
> > @@ -40,7 +40,7 @@
> >  struct clk_pllv3 {
> >  	struct clk_hw	hw;
> >  	void __iomem	*base;
> > -	bool		powerup_set;
> > +	bool		power_invert;
> >  	u32		powerdown;
> >  	u32		div_mask;
> >  	u32		div_shift;
> > @@ -55,7 +55,7 @@ static int clk_pllv3_wait_lock(struct clk_pllv3 *pll)
> >  	u32 val = readl_relaxed(pll->base) & pll->powerdown;
> >  
> >  	/* No need to wait for lock when pll is not powered up */
> > -	if ((pll->powerup_set && !val) || (!pll->powerup_set && val))
> > +	if ((pll->power_invert && !val) || (!pll->power_invert && val))
> >  		return 0;
> >  
> >  	/* Wait for PLL to lock */
> > @@ -76,7 +76,7 @@ static int clk_pllv3_prepare(struct clk_hw *hw)
> >  	u32 val;
> >  
> >  	val = readl_relaxed(pll->base);
> > -	if (pll->powerup_set)
> > +	if (pll->power_invert)
> >  		val |= pll->powerdown;
> >  	else
> >  		val &= ~pll->powerdown;
> > @@ -91,7 +91,7 @@ static void clk_pllv3_unprepare(struct clk_hw *hw)
> >  	u32 val;
> >  
> >  	val = readl_relaxed(pll->base);
> > -	if (pll->powerup_set)
> > +	if (pll->power_invert)
> >  		val &= ~pll->powerdown;
> >  	else
> >  		val |= pll->powerdown;
> > @@ -326,7 +326,7 @@ struct clk *imx_clk_pllv3(enum imx_pllv3_type type, const char *name,
> >  		pll->div_shift = 1;
> >  	case IMX_PLLV3_USB:
> >  		ops = &clk_pllv3_ops;
> > -		pll->powerup_set = true;
> > +		pll->power_invert = true;
> >  		break;
> >  	case IMX_PLLV3_AV:
> >  		ops = &clk_pllv3_av_ops;
> > -- 
> > 1.9.1
> > 
> > 
> > _______________________________________________
> > linux-arm-kernel mailing list
> > linux-arm-kernel@lists.infradead.org
> > http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
> --
> To unsubscribe from this list: send the line "unsubscribe linux-clk" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

[toc] | [prev] | [next] | [standalone]


#1420256

FromDong Aisheng <dongas86@gmail.com>
Date2016-06-12 14:20 +0200
Message-ID<rJcwW-7R-15@gated-at.bofh.it>
In reply to#1420245
On Sun, Jun 12, 2016 at 07:36:27PM +0800, Shawn Guo wrote:
> On Wed, Jun 08, 2016 at 10:33:34PM +0800, Dong Aisheng wrote:
> > There's a powerdown bit already, so let's change the name of
> > powerup_set bit to power_invert to reflects the power polarity
> > to make it less confusing.
> > 
> > Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
> > ---
> >  drivers/clk/imx/clk-pllv3.c | 14 +++++++-------
> >  1 file changed, 7 insertions(+), 7 deletions(-)
> > 
> > diff --git a/drivers/clk/imx/clk-pllv3.c b/drivers/clk/imx/clk-pllv3.c
> > index eea2b1b3791e..3fdfb6d2cc71 100644
> > --- a/drivers/clk/imx/clk-pllv3.c
> > +++ b/drivers/clk/imx/clk-pllv3.c
> > @@ -29,8 +29,8 @@
> >   * struct clk_pllv3 - IMX PLL clock version 3
> >   * @clk_hw:	 clock source
> >   * @base:	 base address of PLL registers
> > - * @powerup_set: set POWER bit to power up the PLL
> > - * @powerdown:   pll powerdown offset bit
> > + * @powerdown:	 pll powerdown bit offset
> 
> I think 'powerdown' is more confusing here.  I prefer to rename it to
> something like 'power_mask' and keep 'powerdown' as it is.
> 

I understand your point.
How about using power_bit and powerup_set?
* @power_bit:   pll power bit offset
* @powerup_set: set power_bit to power up the PLL

Regards
Dong Aisheng

> Shawn
> 
> > + * @power_invert: set powerdown bit to power up the PLL
> >   * @div_mask:	 mask of divider bits
> >   * @div_shift:	 shift of divider bits
> >   *
> > @@ -40,7 +40,7 @@
> >  struct clk_pllv3 {
> >  	struct clk_hw	hw;
> >  	void __iomem	*base;
> > -	bool		powerup_set;
> > +	bool		power_invert;
> >  	u32		powerdown;
> >  	u32		div_mask;
> >  	u32		div_shift;
> > @@ -55,7 +55,7 @@ static int clk_pllv3_wait_lock(struct clk_pllv3 *pll)
> >  	u32 val = readl_relaxed(pll->base) & pll->powerdown;
> >  
> >  	/* No need to wait for lock when pll is not powered up */
> > -	if ((pll->powerup_set && !val) || (!pll->powerup_set && val))
> > +	if ((pll->power_invert && !val) || (!pll->power_invert && val))
> >  		return 0;
> >  
> >  	/* Wait for PLL to lock */
> > @@ -76,7 +76,7 @@ static int clk_pllv3_prepare(struct clk_hw *hw)
> >  	u32 val;
> >  
> >  	val = readl_relaxed(pll->base);
> > -	if (pll->powerup_set)
> > +	if (pll->power_invert)
> >  		val |= pll->powerdown;
> >  	else
> >  		val &= ~pll->powerdown;
> > @@ -91,7 +91,7 @@ static void clk_pllv3_unprepare(struct clk_hw *hw)
> >  	u32 val;
> >  
> >  	val = readl_relaxed(pll->base);
> > -	if (pll->powerup_set)
> > +	if (pll->power_invert)
> >  		val &= ~pll->powerdown;
> >  	else
> >  		val |= pll->powerdown;
> > @@ -326,7 +326,7 @@ struct clk *imx_clk_pllv3(enum imx_pllv3_type type, const char *name,
> >  		pll->div_shift = 1;
> >  	case IMX_PLLV3_USB:
> >  		ops = &clk_pllv3_ops;
> > -		pll->powerup_set = true;
> > +		pll->power_invert = true;
> >  		break;
> >  	case IMX_PLLV3_AV:
> >  		ops = &clk_pllv3_av_ops;
> > -- 
> > 1.9.1
> > 
> > 
> > _______________________________________________
> > linux-arm-kernel mailing list
> > linux-arm-kernel@lists.infradead.org
> > http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
> --
> To unsubscribe from this list: send the line "unsubscribe linux-clk" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

[toc] | [prev] | [next] | [standalone]


#1420273

FromShawn Guo <shawnguo@kernel.org>
Date2016-06-12 15:40 +0200
Message-ID<rJdMm-Nl-17@gated-at.bofh.it>
In reply to#1420256
On Sun, Jun 12, 2016 at 08:13:03PM +0800, Dong Aisheng wrote:
> I understand your point.
> How about using power_bit and powerup_set?
> * @power_bit:   pll power bit offset

I'm fine with the name, but the comment should be fixed, since we are
actually using it as a bit mask instead of offset.

Shawn

> * @powerup_set: set power_bit to power up the PLL

[toc] | [prev] | [next] | [standalone]


#1420284

FromDong Aisheng <dongas86@gmail.com>
Date2016-06-12 17:00 +0200
Message-ID<rJf1L-1vg-11@gated-at.bofh.it>
In reply to#1420273
On Sun, Jun 12, 2016 at 9:29 PM, Shawn Guo <shawnguo@kernel.org> wrote:
> On Sun, Jun 12, 2016 at 08:13:03PM +0800, Dong Aisheng wrote:
>> I understand your point.
>> How about using power_bit and powerup_set?
>> * @power_bit:   pll power bit offset
>
> I'm fine with the name, but the comment should be fixed, since we are
> actually using it as a bit mask instead of offset.
>

Yes, i can change to:
* @power_bit:   pll power bit mask
* @powerup_set: set power_bit to power up the PLL

Regards
Dong Aisheng

> Shawn
>
>> * @powerup_set: set power_bit to power up the PLL
>

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web