Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1342196 > unrolled thread

[PATCH v17 4/9] x86/objtool: Add STACK_FRAME_NON_STANDARD macro

Started byJosh Poimboeuf <jpoimboe@redhat.com>
First post2016-02-24 17:40 +0100
Last post2016-02-25 21:30 +0100
Articles 3 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  [PATCH v17 4/9] x86/objtool: Add STACK_FRAME_NON_STANDARD macro Josh Poimboeuf <jpoimboe@redhat.com> - 2016-02-24 17:40 +0100
    Re: [PATCH v17 4/9] x86/objtool: Add STACK_FRAME_NON_STANDARD macro Ingo Molnar <mingo@kernel.org> - 2016-02-25 09:00 +0100
      Re: [PATCH v17 4/9] x86/objtool: Add STACK_FRAME_NON_STANDARD macro Josh Poimboeuf <jpoimboe@redhat.com> - 2016-02-25 21:30 +0100

#1342196 — [PATCH v17 4/9] x86/objtool: Add STACK_FRAME_NON_STANDARD macro

FromJosh Poimboeuf <jpoimboe@redhat.com>
Date2016-02-24 17:40 +0100
Subject[PATCH v17 4/9] x86/objtool: Add STACK_FRAME_NON_STANDARD macro
Message-ID<r5KDO-7ce-61@gated-at.bofh.it>
Add a new objtool ignore macro, STACK_FRAME_NON_STANDARD, which can be
used to tell objtool to skip validation of a function.

Signed-off-by: Josh Poimboeuf <jpoimboe@redhat.com>
---
 MAINTAINERS                   |  1 +
 arch/x86/kernel/vmlinux.lds.S |  5 ++++-
 include/linux/objtool.h       | 22 ++++++++++++++++++++++
 3 files changed, 27 insertions(+), 1 deletion(-)
 create mode 100644 include/linux/objtool.h

diff --git a/MAINTAINERS b/MAINTAINERS
index 7c7cebd..43a940e 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -7782,6 +7782,7 @@ OBJTOOL
 M:	Josh Poimboeuf <jpoimboe@redhat.com>
 S:	Supported
 F:	tools/objtool/
+F:	include/linux/objtool.h
 
 OMAP SUPPORT
 M:	Tony Lindgren <tony@atomide.com>
diff --git a/arch/x86/kernel/vmlinux.lds.S b/arch/x86/kernel/vmlinux.lds.S
index 92dc211..6038fe0 100644
--- a/arch/x86/kernel/vmlinux.lds.S
+++ b/arch/x86/kernel/vmlinux.lds.S
@@ -343,7 +343,10 @@ SECTIONS
 
 	/* Sections to be discarded */
 	DISCARDS
-	/DISCARD/ : { *(.eh_frame) }
+	/DISCARD/ : {
+		*(.eh_frame)
+		*(__objtool_ignore_*)
+	}
 }
 
 
diff --git a/include/linux/objtool.h b/include/linux/objtool.h
new file mode 100644
index 0000000..cce9d67
--- /dev/null
+++ b/include/linux/objtool.h
@@ -0,0 +1,22 @@
+#ifndef _LINUX_OBJTOOL_H
+#define _LINUX_OBJTOOL_H
+
+#ifdef CONFIG_STACK_VALIDATION
+/*
+ * This C macro tells objtool to ignore the function when doing stack metadata
+ * validation.  It should only be used in special cases where you're 100% sure
+ * it won't affect the reliability of frame pointers and kernel stack traces.
+ *
+ * For more information, see tools/objtool/Documentation/stack-validation.txt.
+ */
+#define STACK_FRAME_NON_STANDARD(_func) \
+	static void __used __section(__objtool_ignore_func) \
+		*__objtool_ignore_func_##_func = _func
+
+#else /* !CONFIG_STACK_VALIDATION */
+
+#define STACK_FRAME_NON_STANDARD(_func)
+
+#endif /* CONFIG_STACK_VALIDATION */
+
+#endif /* _LINUX_OBJTOOL_H */
-- 
2.4.3

[toc] | [next] | [standalone]


#1342932

FromIngo Molnar <mingo@kernel.org>
Date2016-02-25 09:00 +0100
Message-ID<r5Z06-zs-23@gated-at.bofh.it>
In reply to#1342196
* Josh Poimboeuf <jpoimboe@redhat.com> wrote:

> Add a new objtool ignore macro, STACK_FRAME_NON_STANDARD, which can be
> used to tell objtool to skip validation of a function.
> 
> Signed-off-by: Josh Poimboeuf <jpoimboe@redhat.com>
> ---
>  MAINTAINERS                   |  1 +
>  arch/x86/kernel/vmlinux.lds.S |  5 ++++-
>  include/linux/objtool.h       | 22 ++++++++++++++++++++++
>  3 files changed, 27 insertions(+), 1 deletion(-)
>  create mode 100644 include/linux/objtool.h
> 
> diff --git a/MAINTAINERS b/MAINTAINERS
> index 7c7cebd..43a940e 100644
> --- a/MAINTAINERS
> +++ b/MAINTAINERS
> @@ -7782,6 +7782,7 @@ OBJTOOL
>  M:	Josh Poimboeuf <jpoimboe@redhat.com>
>  S:	Supported
>  F:	tools/objtool/
> +F:	include/linux/objtool.h
>  
>  OMAP SUPPORT
>  M:	Tony Lindgren <tony@atomide.com>
> diff --git a/arch/x86/kernel/vmlinux.lds.S b/arch/x86/kernel/vmlinux.lds.S
> index 92dc211..6038fe0 100644
> --- a/arch/x86/kernel/vmlinux.lds.S
> +++ b/arch/x86/kernel/vmlinux.lds.S
> @@ -343,7 +343,10 @@ SECTIONS
>  
>  	/* Sections to be discarded */
>  	DISCARDS
> -	/DISCARD/ : { *(.eh_frame) }
> +	/DISCARD/ : {
> +		*(.eh_frame)
> +		*(__objtool_ignore_*)
> +	}
>  }
>  
>  
> diff --git a/include/linux/objtool.h b/include/linux/objtool.h
> new file mode 100644
> index 0000000..cce9d67
> --- /dev/null
> +++ b/include/linux/objtool.h

So I think this should really be in asm/frame.h, not in an objtool specific 
header.

> @@ -0,0 +1,22 @@
> +#ifndef _LINUX_OBJTOOL_H
> +#define _LINUX_OBJTOOL_H
> +
> +#ifdef CONFIG_STACK_VALIDATION
> +/*
> + * This C macro tells objtool to ignore the function when doing stack metadata
> + * validation.  It should only be used in special cases where you're 100% sure
> + * it won't affect the reliability of frame pointers and kernel stack traces.
> + *
> + * For more information, see tools/objtool/Documentation/stack-validation.txt.
> + */
> +#define STACK_FRAME_NON_STANDARD(_func) \
> +	static void __used __section(__objtool_ignore_func) \
> +		*__objtool_ignore_func_##_func = _func

Likewise, this section should be named __func_non_standard_stack_frame or so, with 
objtool one (but not the only possible) consumer of it.

> +#else /* !CONFIG_STACK_VALIDATION */
> +
> +#define STACK_FRAME_NON_STANDARD(_func)
> +
> +#endif /* CONFIG_STACK_VALIDATION */
> +
> +#endif /* _LINUX_OBJTOOL_H */

The CONFIG_STACK_VALIDATION dependency can be kept.

Thanks,

	Ingo

[toc] | [prev] | [next] | [standalone]


#1343459

FromJosh Poimboeuf <jpoimboe@redhat.com>
Date2016-02-25 21:30 +0100
Message-ID<r6aHV-HU-17@gated-at.bofh.it>
In reply to#1342932
On Thu, Feb 25, 2016 at 08:51:49AM +0100, Ingo Molnar wrote:
> > diff --git a/include/linux/objtool.h b/include/linux/objtool.h
> > new file mode 100644
> > index 0000000..cce9d67
> > --- /dev/null
> > +++ b/include/linux/objtool.h
> 
> So I think this should really be in asm/frame.h, not in an objtool specific 
> header.

I agree that it shouldn't be in an objtool-specific header, but
asm/frame.h wouldn't work unless we added that file to all the arches.
And the macro's functionality is arch-independent anyway.  So I'm
renaming the file to include/linux/frame.h.

-- 
Josh

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web