Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1331112 > unrolled thread
| Started by | Jiri Olsa <jolsa@redhat.com> |
|---|---|
| First post | 2016-02-10 13:30 +0100 |
| Last post | 2016-02-10 15:30 +0100 |
| Articles | 3 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH 14/23] perf ui/stdio: Implement hierarchy output mode Jiri Olsa <jolsa@redhat.com> - 2016-02-10 13:30 +0100
Re: [PATCH 14/23] perf ui/stdio: Implement hierarchy output mode Jiri Olsa <jolsa@redhat.com> - 2016-02-10 13:40 +0100
Re: [PATCH 14/23] perf ui/stdio: Implement hierarchy output mode Namhyung Kim <namhyung@kernel.org> - 2016-02-10 15:30 +0100
| From | Jiri Olsa <jolsa@redhat.com> |
|---|---|
| Date | 2016-02-10 13:30 +0100 |
| Subject | Re: [PATCH 14/23] perf ui/stdio: Implement hierarchy output mode |
| Message-ID | <r0C4a-28R-1@gated-at.bofh.it> |
On Fri, Feb 05, 2016 at 10:01:46PM +0900, Namhyung Kim wrote:
SNIP
>
> - for (nd = rb_first(&hists->entries); nd; nd = rb_next(nd)) {
> + for (nd = rb_first(&hists->entries); nd; nd = rb_hierarchy_next(nd)) {
> struct hist_entry *h = rb_entry(nd, struct hist_entry, rb_node);
> float percent;
>
> @@ -542,6 +614,9 @@ print_entries:
> MAP__FUNCTION, fp);
> fprintf(fp, "%.10s end\n", graph_dotted_line);
> }
> +
> + if (symbol_conf.report_hierarchy)
> + h->unfolded = true;
what's this for?
thanks,
jirka
[toc] | [next] | [standalone]
| From | Jiri Olsa <jolsa@redhat.com> |
|---|---|
| Date | 2016-02-10 13:40 +0100 |
| Message-ID | <r0CdQ-2bY-9@gated-at.bofh.it> |
| In reply to | #1331112 |
On Wed, Feb 10, 2016 at 01:23:45PM +0100, Jiri Olsa wrote:
> On Fri, Feb 05, 2016 at 10:01:46PM +0900, Namhyung Kim wrote:
>
> SNIP
>
> >
> > - for (nd = rb_first(&hists->entries); nd; nd = rb_next(nd)) {
> > + for (nd = rb_first(&hists->entries); nd; nd = rb_hierarchy_next(nd)) {
> > struct hist_entry *h = rb_entry(nd, struct hist_entry, rb_node);
> > float percent;
> >
> > @@ -542,6 +614,9 @@ print_entries:
> > MAP__FUNCTION, fp);
> > fprintf(fp, "%.10s end\n", graph_dotted_line);
> > }
> > +
> > + if (symbol_conf.report_hierarchy)
> > + h->unfolded = true;
>
> what's this for?
>
ah it's stdio, we need to show everything.. ok ;-)
I was thinking of putting this 'force un/fold' logic into the
rb_hierarchy_next interface, because it's also not nice in
hists__filter_hierarchy function..
maybe having extra argument telling the walk preference
would be easier to read, like:
rb_hierarchy_next(&h->rb_node, FORCE_UNFOLD);
rb_hierarchy_next(&h->rb_node, FORCE_FOLD);
rb_hierarchy_next(&h->rb_node, DEFAULT);
with some better names of course
just an idea.. it might turn horrible as well ;-)
thanks,
jirka
[toc] | [prev] | [next] | [standalone]
| From | Namhyung Kim <namhyung@kernel.org> |
|---|---|
| Date | 2016-02-10 15:30 +0100 |
| Message-ID | <r0DWj-3jE-31@gated-at.bofh.it> |
| In reply to | #1331117 |
On Wed, Feb 10, 2016 at 01:29:31PM +0100, Jiri Olsa wrote:
> On Wed, Feb 10, 2016 at 01:23:45PM +0100, Jiri Olsa wrote:
> > On Fri, Feb 05, 2016 at 10:01:46PM +0900, Namhyung Kim wrote:
> >
> > SNIP
> >
> > >
> > > - for (nd = rb_first(&hists->entries); nd; nd = rb_next(nd)) {
> > > + for (nd = rb_first(&hists->entries); nd; nd = rb_hierarchy_next(nd)) {
> > > struct hist_entry *h = rb_entry(nd, struct hist_entry, rb_node);
> > > float percent;
> > >
> > > @@ -542,6 +614,9 @@ print_entries:
> > > MAP__FUNCTION, fp);
> > > fprintf(fp, "%.10s end\n", graph_dotted_line);
> > > }
> > > +
> > > + if (symbol_conf.report_hierarchy)
> > > + h->unfolded = true;
> >
> > what's this for?
> >
>
> ah it's stdio, we need to show everything.. ok ;-)
Right. :)
>
> I was thinking of putting this 'force un/fold' logic into the
> rb_hierarchy_next interface, because it's also not nice in
> hists__filter_hierarchy function..
>
> maybe having extra argument telling the walk preference
> would be easier to read, like:
>
> rb_hierarchy_next(&h->rb_node, FORCE_UNFOLD);
> rb_hierarchy_next(&h->rb_node, FORCE_FOLD);
> rb_hierarchy_next(&h->rb_node, DEFAULT);
>
> with some better names of course
>
> just an idea.. it might turn horrible as well ;-)
Seems like a good idea. I'll think about it in the next spin.
Thanks,
Namhyung
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web