Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1244932 > unrolled thread
| Started by | Ian Abbott <abbotti@mev.co.uk> |
|---|---|
| First post | 2015-10-12 19:10 +0200 |
| Last post | 2015-10-12 19:40 +0200 |
| Articles | 4 — 3 participants |
Back to article view | Back to linux.kernel
[PATCH 0/2] staging: comedi: comedidev.h: fix some checkpatch issues Ian Abbott <abbotti@mev.co.uk> - 2015-10-12 19:10 +0200
[PATCH 2/2] staging: comedi: comedidev.h: spaces preferred around that '*' Ian Abbott <abbotti@mev.co.uk> - 2015-10-12 19:10 +0200
Re: [PATCH 0/2] staging: comedi: comedidev.h: fix some checkpatch issues Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2015-10-12 19:30 +0200
RE: [PATCH 0/2] staging: comedi: comedidev.h: fix some checkpatch issues Hartley Sweeten <HartleyS@visionengravers.com> - 2015-10-12 19:40 +0200
| From | Ian Abbott <abbotti@mev.co.uk> |
|---|---|
| Date | 2015-10-12 19:10 +0200 |
| Subject | [PATCH 0/2] staging: comedi: comedidev.h: fix some checkpatch issues |
| Message-ID | <qiOLL-5l6-3@gated-at.bofh.it> |
Fix some checkpatch issues in "comedidev.h". There are still some CamelCase warnings, but since those are for the use of "mA" and it represents "milliamps", I think I'll leave them alone. 1) staging: comedi: comedidev.h: add comments to spin-lock and mutex 2) staging: comedi: comedidev.h: spaces preferred around that '*' drivers/staging/comedi/comedidev.h | 18 +++++++++--------- 1 file changed, 9 insertions(+), 9 deletions(-) -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [next] | [standalone]
| From | Ian Abbott <abbotti@mev.co.uk> |
|---|---|
| Date | 2015-10-12 19:10 +0200 |
| Subject | [PATCH 2/2] staging: comedi: comedidev.h: spaces preferred around that '*' |
| Message-ID | <qiOLM-5l6-31@gated-at.bofh.it> |
| In reply to | #1244932 |
Fix the checkpatch.pl issues:
CHECK: spaces preferred around that '*' (ctx:VxV)
Signed-off-by: Ian Abbott <abbotti@mev.co.uk>
---
drivers/staging/comedi/comedidev.h | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/comedi/comedidev.h b/drivers/staging/comedi/comedidev.h
index 7a62e97..1158072 100644
--- a/drivers/staging/comedi/comedidev.h
+++ b/drivers/staging/comedi/comedidev.h
@@ -580,12 +580,12 @@ int comedi_check_chanlist(struct comedi_subdevice *s,
/* range stuff */
-#define RANGE(a, b) {(a)*1e6, (b)*1e6, 0}
-#define RANGE_ext(a, b) {(a)*1e6, (b)*1e6, RF_EXTERNAL}
-#define RANGE_mA(a, b) {(a)*1e6, (b)*1e6, UNIT_mA}
-#define RANGE_unitless(a, b) {(a)*1e6, (b)*1e6, 0}
-#define BIP_RANGE(a) {-(a)*1e6, (a)*1e6, 0}
-#define UNI_RANGE(a) {0, (a)*1e6, 0}
+#define RANGE(a, b) {(a) * 1e6, (b) * 1e6, 0}
+#define RANGE_ext(a, b) {(a) * 1e6, (b) * 1e6, RF_EXTERNAL}
+#define RANGE_mA(a, b) {(a) * 1e6, (b) * 1e6, UNIT_mA}
+#define RANGE_unitless(a, b) {(a) * 1e6, (b) * 1e6, 0}
+#define BIP_RANGE(a) {-(a) * 1e6, (a) * 1e6, 0}
+#define UNI_RANGE(a) {0, (a) * 1e6, 0}
extern const struct comedi_lrange range_bipolar10;
extern const struct comedi_lrange range_bipolar5;
--
2.6.1
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Greg Kroah-Hartman <gregkh@linuxfoundation.org> |
|---|---|
| Date | 2015-10-12 19:30 +0200 |
| Subject | Re: [PATCH 0/2] staging: comedi: comedidev.h: fix some checkpatch issues |
| Message-ID | <qiP58-5HG-5@gated-at.bofh.it> |
| In reply to | #1244932 |
On Mon, Oct 12, 2015 at 05:22:29PM +0000, Hartley Sweeten wrote:
> On Monday, October 12, 2015 10:03 AM, Ian Abbott wrote:
> > Fix some checkpatch issues in "comedidev.h". There are still some
> > CamelCase warnings, but since those are for the use of "mA" and it
> > represents "milliamps", I think I'll leave them alone.
> >
> > 1) staging: comedi: comedidev.h: add comments to spin-lock and mutex
> > 2) staging: comedi: comedidev.h: spaces preferred around that '*'
> >
> > drivers/staging/comedi/comedidev.h | 18 +++++++++---------
> > 1 file changed, 9 insertions(+), 9 deletions(-)
>
> Thanks!
>
> Reviewed-by: H Hartley Sweeten <hsweeten@visionengravers.com>
>
> Ian,
>
> Just a comment...
>
> The checkpaatch.pl noise about "mA" defines are a bit annoying but
> I agree that those defines are clearer than "{foo}_milliamps".
I agree, checkpatch is just a "hint", feel free to ignore it when it
says stupid things. Like this.
thanks,
greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Hartley Sweeten <HartleyS@visionengravers.com> |
|---|---|
| Date | 2015-10-12 19:40 +0200 |
| Subject | RE: [PATCH 0/2] staging: comedi: comedidev.h: fix some checkpatch issues |
| Message-ID | <qiP58-5HG-7@gated-at.bofh.it> |
| In reply to | #1244932 |
On Monday, October 12, 2015 10:03 AM, Ian Abbott wrote:
> Fix some checkpatch issues in "comedidev.h". There are still some
> CamelCase warnings, but since those are for the use of "mA" and it
> represents "milliamps", I think I'll leave them alone.
>
> 1) staging: comedi: comedidev.h: add comments to spin-lock and mutex
> 2) staging: comedi: comedidev.h: spaces preferred around that '*'
>
> drivers/staging/comedi/comedidev.h | 18 +++++++++---------
> 1 file changed, 9 insertions(+), 9 deletions(-)
Thanks!
Reviewed-by: H Hartley Sweeten <hsweeten@visionengravers.com>
Ian,
Just a comment...
The checkpaatch.pl noise about "mA" defines are a bit annoying but
I agree that those defines are clearer than "{foo}_milliamps".
But, even though they don't cause a CamelCase warning for some
Reason, the "RANGE_ext" and "RANGE_unitless" could be renamed
to "RANGE_EXT" (or RANGE_EXTERNAL for clarity) and "RANGE_UNITLESS".
There is currently only 1 driver that uses RANGE_unitless and 5 that use
RANGE_ext.
Regards,
Hartley
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web