Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1244947

RE: [PATCH 0/2] staging: comedi: comedidev.h: fix some checkpatch issues

From Hartley Sweeten <HartleyS@visionengravers.com>
Newsgroups linux.kernel
Subject RE: [PATCH 0/2] staging: comedi: comedidev.h: fix some checkpatch issues
Date 2015-10-12 19:40 +0200
Message-ID <qiP58-5HG-7@gated-at.bofh.it> (permalink)
References <qiOLL-5l6-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Monday, October 12, 2015 10:03 AM, Ian Abbott wrote:
> Fix some checkpatch issues in "comedidev.h".  There are still some
> CamelCase warnings, but since those are for the use of "mA" and it
> represents "milliamps", I think I'll leave them alone.
>
> 1) staging: comedi: comedidev.h: add comments to spin-lock and mutex
> 2) staging: comedi: comedidev.h: spaces preferred around that '*'
>
>  drivers/staging/comedi/comedidev.h | 18 +++++++++---------
>  1 file changed, 9 insertions(+), 9 deletions(-)

Thanks!

Reviewed-by: H Hartley Sweeten <hsweeten@visionengravers.com>

Ian,

Just a comment...

The checkpaatch.pl noise about "mA" defines are a bit annoying but
I agree that those defines are clearer than "{foo}_milliamps".

But, even though they don't cause a CamelCase warning for some
Reason, the "RANGE_ext" and "RANGE_unitless" could be renamed
to "RANGE_EXT" (or RANGE_EXTERNAL for clarity) and "RANGE_UNITLESS".
There is currently only 1 driver that uses RANGE_unitless and 5 that use
RANGE_ext.

Regards,
Hartley

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH 0/2] staging: comedi: comedidev.h: fix some checkpatch issues Ian Abbott <abbotti@mev.co.uk> - 2015-10-12 19:10 +0200
  [PATCH 2/2] staging: comedi: comedidev.h: spaces preferred around that '*' Ian Abbott <abbotti@mev.co.uk> - 2015-10-12 19:10 +0200
  Re: [PATCH 0/2] staging: comedi: comedidev.h: fix some checkpatch  issues Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2015-10-12 19:30 +0200
  RE: [PATCH 0/2] staging: comedi: comedidev.h: fix some checkpatch  issues Hartley Sweeten <HartleyS@visionengravers.com> - 2015-10-12 19:40 +0200

csiph-web