Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1242581 > unrolled thread
| Started by | Vladimir Davydov <vdavydov@virtuozzo.com> |
|---|---|
| First post | 2015-10-08 18:10 +0200 |
| Last post | 2015-10-14 04:40 +0200 |
| Articles | 3 — 3 participants |
Back to article view | Back to linux.kernel
[PATCH 1/3] slab_common: rename cache create/destroy helpers Vladimir Davydov <vdavydov@virtuozzo.com> - 2015-10-08 18:10 +0200
Re: [PATCH 1/3] slab_common: rename cache create/destroy helpers Christoph Lameter <cl@linux.com> - 2015-10-08 19:00 +0200
Re: [PATCH 1/3] slab_common: rename cache create/destroy helpers David Rientjes <rientjes@google.com> - 2015-10-14 04:40 +0200
| From | Vladimir Davydov <vdavydov@virtuozzo.com> |
|---|---|
| Date | 2015-10-08 18:10 +0200 |
| Subject | [PATCH 1/3] slab_common: rename cache create/destroy helpers |
| Message-ID | <qhlVv-8s5-3@gated-at.bofh.it> |
do_kmem_cache_create, do_kmem_cache_shutdown, and do_kmem_cache_release
sound awkward for static helper functions that are not supposed to be
used outside slab_common.c. Rename them to create_cache, shutdown_cache,
and release_caches, respectively. This patch is a pure cleanup and does
not introduce any functional changes.
Signed-off-by: Vladimir Davydov <vdavydov@virtuozzo.com>
---
mm/slab_common.c | 37 ++++++++++++++++++-------------------
1 file changed, 18 insertions(+), 19 deletions(-)
diff --git a/mm/slab_common.c b/mm/slab_common.c
index 113a6fd597db..c8d2ed7f8330 100644
--- a/mm/slab_common.c
+++ b/mm/slab_common.c
@@ -316,10 +316,10 @@ unsigned long calculate_alignment(unsigned long flags,
return ALIGN(align, sizeof(void *));
}
-static struct kmem_cache *
-do_kmem_cache_create(const char *name, size_t object_size, size_t size,
- size_t align, unsigned long flags, void (*ctor)(void *),
- struct mem_cgroup *memcg, struct kmem_cache *root_cache)
+static struct kmem_cache *create_cache(const char *name,
+ size_t object_size, size_t size, size_t align,
+ unsigned long flags, void (*ctor)(void *),
+ struct mem_cgroup *memcg, struct kmem_cache *root_cache)
{
struct kmem_cache *s;
int err;
@@ -418,9 +418,9 @@ kmem_cache_create(const char *name, size_t size, size_t align,
goto out_unlock;
}
- s = do_kmem_cache_create(cache_name, size, size,
- calculate_alignment(flags, align, size),
- flags, ctor, NULL, NULL);
+ s = create_cache(cache_name, size, size,
+ calculate_alignment(flags, align, size),
+ flags, ctor, NULL, NULL);
if (IS_ERR(s)) {
err = PTR_ERR(s);
kfree_const(cache_name);
@@ -448,7 +448,7 @@ out_unlock:
}
EXPORT_SYMBOL(kmem_cache_create);
-static int do_kmem_cache_shutdown(struct kmem_cache *s,
+static int shutdown_cache(struct kmem_cache *s,
struct list_head *release, bool *need_rcu_barrier)
{
if (__kmem_cache_shutdown(s) != 0) {
@@ -469,8 +469,7 @@ static int do_kmem_cache_shutdown(struct kmem_cache *s,
return 0;
}
-static void do_kmem_cache_release(struct list_head *release,
- bool need_rcu_barrier)
+static void release_caches(struct list_head *release, bool need_rcu_barrier)
{
struct kmem_cache *s, *s2;
@@ -536,10 +535,10 @@ void memcg_create_kmem_cache(struct mem_cgroup *memcg,
if (!cache_name)
goto out_unlock;
- s = do_kmem_cache_create(cache_name, root_cache->object_size,
- root_cache->size, root_cache->align,
- root_cache->flags, root_cache->ctor,
- memcg, root_cache);
+ s = create_cache(cache_name, root_cache->object_size,
+ root_cache->size, root_cache->align,
+ root_cache->flags, root_cache->ctor,
+ memcg, root_cache);
/*
* If we could not create a memcg cache, do not complain, because
* that's not critical at all as we can always proceed with the root
@@ -615,14 +614,14 @@ void memcg_destroy_kmem_caches(struct mem_cgroup *memcg)
* The cgroup is about to be freed and therefore has no charges
* left. Hence, all its caches must be empty by now.
*/
- BUG_ON(do_kmem_cache_shutdown(s, &release, &need_rcu_barrier));
+ BUG_ON(shutdown_cache(s, &release, &need_rcu_barrier));
}
mutex_unlock(&slab_mutex);
put_online_mems();
put_online_cpus();
- do_kmem_cache_release(&release, need_rcu_barrier);
+ release_caches(&release, need_rcu_barrier);
}
#endif /* CONFIG_MEMCG_KMEM */
@@ -655,12 +654,12 @@ void kmem_cache_destroy(struct kmem_cache *s)
goto out_unlock;
for_each_memcg_cache_safe(c, c2, s) {
- if (do_kmem_cache_shutdown(c, &release, &need_rcu_barrier))
+ if (shutdown_cache(c, &release, &need_rcu_barrier))
busy = true;
}
if (!busy)
- do_kmem_cache_shutdown(s, &release, &need_rcu_barrier);
+ shutdown_cache(s, &release, &need_rcu_barrier);
out_unlock:
mutex_unlock(&slab_mutex);
@@ -668,7 +667,7 @@ out_unlock:
put_online_mems();
put_online_cpus();
- do_kmem_cache_release(&release, need_rcu_barrier);
+ release_caches(&release, need_rcu_barrier);
}
EXPORT_SYMBOL(kmem_cache_destroy);
--
2.1.4
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [next] | [standalone]
| From | Christoph Lameter <cl@linux.com> |
|---|---|
| Date | 2015-10-08 19:00 +0200 |
| Message-ID | <qhmHV-UH-33@gated-at.bofh.it> |
| In reply to | #1242581 |
On Thu, 8 Oct 2015, Vladimir Davydov wrote: > do_kmem_cache_create, do_kmem_cache_shutdown, and do_kmem_cache_release > sound awkward for static helper functions that are not supposed to be > used outside slab_common.c. Rename them to create_cache, shutdown_cache, > and release_caches, respectively. This patch is a pure cleanup and does > not introduce any functional changes. Acked-by: Christoph Lameter <cl@linux.com> -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | David Rientjes <rientjes@google.com> |
|---|---|
| Date | 2015-10-14 04:40 +0200 |
| Message-ID | <qjk8V-1uB-9@gated-at.bofh.it> |
| In reply to | #1242581 |
On Thu, 8 Oct 2015, Vladimir Davydov wrote: > do_kmem_cache_create, do_kmem_cache_shutdown, and do_kmem_cache_release > sound awkward for static helper functions that are not supposed to be > used outside slab_common.c. Rename them to create_cache, shutdown_cache, > and release_caches, respectively. This patch is a pure cleanup and does > not introduce any functional changes. > > Signed-off-by: Vladimir Davydov <vdavydov@virtuozzo.com> Acked-by: David Rientjes <rientjes@google.com> -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web