Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1232956 > unrolled thread
| Started by | Linus Walleij <linus.walleij@linaro.org> |
|---|---|
| First post | 2015-09-25 19:20 +0200 |
| Last post | 2015-09-25 19:20 +0200 |
| Articles | 1 — 1 participant |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH v4 1/2] pinctrl: Add driver for Alphascale asm9260 pinctrl Linus Walleij <linus.walleij@linaro.org> - 2015-09-25 19:20 +0200
| From | Linus Walleij <linus.walleij@linaro.org> |
|---|---|
| Date | 2015-09-25 19:20 +0200 |
| Subject | Re: [PATCH v4 1/2] pinctrl: Add driver for Alphascale asm9260 pinctrl |
| Message-ID | <qcEP7-7Rs-3@gated-at.bofh.it> |
On Tue, Sep 8, 2015 at 10:55 PM, Oleksij Rempel <linux@rempel-privat.de> wrote: > [Me] >> Why is it necessary for the driver to copy one description of >> the pin into another? > > If i understand it correctly, pinctrl_pin_desc is essential part of > pinmux framework. Theoretically i should define just statical array of > this struct, but by this number of pins and functions it hard to keep it > readable and error free. So i decided to create asm9260_mux_table which > contains every thing i need. The side effect is higher memory usage > since i need to create pinctrl_pin_desc on fly. > > May be i miss some thing? I don't see how having code copying data from one data container to another makes things "more readable and error free". Go for *one* static definition. Also the memory waste is a total no-no. Yours, Linus Walleij -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to top | Article view | linux.kernel
csiph-web