Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1223710 > unrolled thread

[PATCH 1/2] btrfs: avoid passing int param to start_transaction which takes u64

Started byAlexandru Moise <00moses.alexander00@gmail.com>
First post2015-09-13 17:50 +0200
Last post2015-09-22 15:50 +0200
Articles 4 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH 1/2] btrfs: avoid passing int param to start_transaction  which takes u64 Alexandru Moise <00moses.alexander00@gmail.com> - 2015-09-13 17:50 +0200
    Re: [PATCH 1/2] btrfs: avoid passing int param to start_transaction  which takes u64 David Sterba <dsterba@suse.cz> - 2015-09-22 15:20 +0200
      Re: [PATCH 1/2] btrfs: avoid passing int param to start_transaction  which takes u64 Alexandru Moise <00moses.alexander00@gmail.com> - 2015-09-22 15:40 +0200
        Re: [PATCH 1/2] btrfs: avoid passing int param to start_transaction  which takes u64 David Sterba <dsterba@suse.cz> - 2015-09-22 15:50 +0200

#1223710 — [PATCH 1/2] btrfs: avoid passing int param to start_transaction which takes u64

FromAlexandru Moise <00moses.alexander00@gmail.com>
Date2015-09-13 17:50 +0200
Subject[PATCH 1/2] btrfs: avoid passing int param to start_transaction which takes u64
Message-ID<q8hHs-3uW-9@gated-at.bofh.it>
Signed-off-by: Alexandru Moise <00moses.alexander00@gmail.com>
---
v2: Forgot to add transaction.h when I made the commit, many thanks
Holger for pointing it out.

 fs/btrfs/transaction.c | 2 +-
 fs/btrfs/transaction.h | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/fs/btrfs/transaction.c b/fs/btrfs/transaction.c
index 8f259b3..8a83acd 100644
--- a/fs/btrfs/transaction.c
+++ b/fs/btrfs/transaction.c
@@ -570,7 +570,7 @@ reserve_fail:
 }
 
 struct btrfs_trans_handle *btrfs_start_transaction(struct btrfs_root *root,
-						   int num_items)
+						   u64 num_items)
 {
 	return start_transaction(root, num_items, TRANS_START,
 				 BTRFS_RESERVE_FLUSH_ALL);
diff --git a/fs/btrfs/transaction.h b/fs/btrfs/transaction.h
index edc2fbc..51ba39f 100644
--- a/fs/btrfs/transaction.h
+++ b/fs/btrfs/transaction.h
@@ -182,7 +182,7 @@ static inline void btrfs_clear_skip_qgroup(struct btrfs_trans_handle *trans)
 int btrfs_end_transaction(struct btrfs_trans_handle *trans,
 			  struct btrfs_root *root);
 struct btrfs_trans_handle *btrfs_start_transaction(struct btrfs_root *root,
-						   int num_items);
+						   u64 num_items);
 struct btrfs_trans_handle *btrfs_start_transaction_lflush(
 					struct btrfs_root *root, int num_items);
 struct btrfs_trans_handle *btrfs_join_transaction(struct btrfs_root *root);
-- 
2.5.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1230177

FromDavid Sterba <dsterba@suse.cz>
Date2015-09-22 15:20 +0200
Message-ID<qbvEe-6p9-33@gated-at.bofh.it>
In reply to#1223710
On Sun, Sep 13, 2015 at 06:47:20PM +0000, Alexandru Moise wrote:
> Signed-off-by: Alexandru Moise <00moses.alexander00@gmail.com>
> ---
> v2: Forgot to add transaction.h when I made the commit, many thanks
> Holger for pointing it out.
> 
>  fs/btrfs/transaction.c | 2 +-
>  fs/btrfs/transaction.h | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/fs/btrfs/transaction.c b/fs/btrfs/transaction.c
> index 8f259b3..8a83acd 100644
> --- a/fs/btrfs/transaction.c
> +++ b/fs/btrfs/transaction.c
> @@ -570,7 +570,7 @@ reserve_fail:
>  }
>  
>  struct btrfs_trans_handle *btrfs_start_transaction(struct btrfs_root *root,
> -						   int num_items)
> +						   u64 num_items)

I think it's better to do it the other way around, ie. let all the
equivalents of 'num_items' be an int. We know that this is a small
number, using u64 for that is an overkill. As the number is always
positive, please make it 'unsigned'.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1230207

FromAlexandru Moise <00moses.alexander00@gmail.com>
Date2015-09-22 15:40 +0200
Message-ID<qbvXA-6LG-29@gated-at.bofh.it>
In reply to#1230177
On Tue, Sep 22, 2015 at 03:09:33PM +0200, David Sterba wrote:
> On Sun, Sep 13, 2015 at 06:47:20PM +0000, Alexandru Moise wrote:
> > Signed-off-by: Alexandru Moise <00moses.alexander00@gmail.com>
> > ---
> > v2: Forgot to add transaction.h when I made the commit, many thanks
> > Holger for pointing it out.
> > 
> >  fs/btrfs/transaction.c | 2 +-
> >  fs/btrfs/transaction.h | 2 +-
> >  2 files changed, 2 insertions(+), 2 deletions(-)
> > 
> > diff --git a/fs/btrfs/transaction.c b/fs/btrfs/transaction.c
> > index 8f259b3..8a83acd 100644
> > --- a/fs/btrfs/transaction.c
> > +++ b/fs/btrfs/transaction.c
> > @@ -570,7 +570,7 @@ reserve_fail:
> >  }
> >  
> >  struct btrfs_trans_handle *btrfs_start_transaction(struct btrfs_root *root,
> > -						   int num_items)
> > +						   u64 num_items)
> 
> I think it's better to do it the other way around, ie. let all the
> equivalents of 'num_items' be an int. We know that this is a small
> number, using u64 for that is an overkill. As the number is always
> positive, please make it 'unsigned'.

So you'd want it to be "unsigned int" or "u32"?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1230226

FromDavid Sterba <dsterba@suse.cz>
Date2015-09-22 15:50 +0200
Message-ID<qbw7g-6Xg-31@gated-at.bofh.it>
In reply to#1230207
On Tue, Sep 22, 2015 at 04:33:07PM +0300, Alexandru Moise wrote:
> > I think it's better to do it the other way around, ie. let all the
> > equivalents of 'num_items' be an int. We know that this is a small
> > number, using u64 for that is an overkill. As the number is always
> > positive, please make it 'unsigned'.
> 
> So you'd want it to be "unsigned int" or "u32"?

'unsigned int' please
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web