Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1326186 > unrolled thread

Re: [PATCH] staging: wilc1000: Move Macro definition

Started by"gregkh@linuxfoundation.org" <gregkh@linuxfoundation.org>
First post2016-02-04 00:30 +0100
Last post2016-02-04 06:20 +0100
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH] staging: wilc1000: Move Macro definition "gregkh@linuxfoundation.org" <gregkh@linuxfoundation.org> - 2016-02-04 00:30 +0100
    Re: [PATCH] staging: wilc1000: Move Macro definition "Gujulan Elango, Hari Prasath (H.)" <hgujulan@visteon.com> - 2016-02-04 06:20 +0100

#1326186 — Re: [PATCH] staging: wilc1000: Move Macro definition

From"gregkh@linuxfoundation.org" <gregkh@linuxfoundation.org>
Date2016-02-04 00:30 +0100
SubjectRe: [PATCH] staging: wilc1000: Move Macro definition
Message-ID<qYf23-oH-43@gated-at.bofh.it>
On Mon, Jan 18, 2016 at 01:42:35PM +0000, Gujulan Elango, Hari Prasath (H.) wrote:
> From: Hari Prasath Gujulan Elango <hgujulan@visteon.com>
> 
> This patch move's a macro defined in the middle of a structure
> definition to make it more readable.
> 
> Signed-off-by: Hari Prasath Gujulan Elango <hgujulan@visteon.com>
> ---
>  drivers/staging/wilc1000/wilc_sdio.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/staging/wilc1000/wilc_sdio.c b/drivers/staging/wilc1000/wilc_sdio.c
> index e961b50..875ea68 100644
> --- a/drivers/staging/wilc1000/wilc_sdio.c
> +++ b/drivers/staging/wilc1000/wilc_sdio.c
> @@ -29,12 +29,12 @@ static const struct sdio_device_id wilc_sdio_ids[] = {
>  };
>  
>  #define WILC_SDIO_BLOCK_SIZE 512
> +#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */
>  
>  typedef struct {
>  	bool irq_gpio;
>  	u32 block_size;
>  	int nint;
> -#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */

No, this is a very common way to show that this define is for this field
in the structure, please don't change that.

sorry,

greg k-h

[toc] | [next] | [standalone]


#1326405

From"Gujulan Elango, Hari Prasath (H.)" <hgujulan@visteon.com>
Date2016-02-04 06:20 +0100
Message-ID<qYkuJ-4bg-5@gated-at.bofh.it>
In reply to#1326186
On Wed, Feb 03, 2016 at 03:19:50PM -0800, gregkh@linuxfoundation.org wrote:
> On Mon, Jan 18, 2016 at 01:42:35PM +0000, Gujulan Elango, Hari Prasath (H.) wrote:
> > From: Hari Prasath Gujulan Elango <hgujulan@visteon.com>
> > 
> > This patch move's a macro defined in the middle of a structure
> > definition to make it more readable.
> > 
> > Signed-off-by: Hari Prasath Gujulan Elango <hgujulan@visteon.com>
> > ---
> >  drivers/staging/wilc1000/wilc_sdio.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/drivers/staging/wilc1000/wilc_sdio.c b/drivers/staging/wilc1000/wilc_sdio.c
> > index e961b50..875ea68 100644
> > --- a/drivers/staging/wilc1000/wilc_sdio.c
> > +++ b/drivers/staging/wilc1000/wilc_sdio.c
> > @@ -29,12 +29,12 @@ static const struct sdio_device_id wilc_sdio_ids[] = {
> >  };
> >  
> >  #define WILC_SDIO_BLOCK_SIZE 512
> > +#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */
> >  
> >  typedef struct {
> >  	bool irq_gpio;
> >  	u32 block_size;
> >  	int nint;
> > -#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */
> 
> No, this is a very common way to show that this define is for this field
> in the structure, please don't change that.
> 
> sorry,
> 
> greg k-h

Thanks Greg,I got the message clear.Please discard this patch.
Regards,
Hari

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web