Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1326186
| From | "gregkh@linuxfoundation.org" <gregkh@linuxfoundation.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] staging: wilc1000: Move Macro definition |
| Date | 2016-02-04 00:30 +0100 |
| Message-ID | <qYf23-oH-43@gated-at.bofh.it> (permalink) |
| References | <qSilY-1kA-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, Jan 18, 2016 at 01:42:35PM +0000, Gujulan Elango, Hari Prasath (H.) wrote:
> From: Hari Prasath Gujulan Elango <hgujulan@visteon.com>
>
> This patch move's a macro defined in the middle of a structure
> definition to make it more readable.
>
> Signed-off-by: Hari Prasath Gujulan Elango <hgujulan@visteon.com>
> ---
> drivers/staging/wilc1000/wilc_sdio.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/wilc1000/wilc_sdio.c b/drivers/staging/wilc1000/wilc_sdio.c
> index e961b50..875ea68 100644
> --- a/drivers/staging/wilc1000/wilc_sdio.c
> +++ b/drivers/staging/wilc1000/wilc_sdio.c
> @@ -29,12 +29,12 @@ static const struct sdio_device_id wilc_sdio_ids[] = {
> };
>
> #define WILC_SDIO_BLOCK_SIZE 512
> +#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */
>
> typedef struct {
> bool irq_gpio;
> u32 block_size;
> int nint;
> -#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */
No, this is a very common way to show that this define is for this field
in the structure, please don't change that.
sorry,
greg k-h
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
Re: [PATCH] staging: wilc1000: Move Macro definition "gregkh@linuxfoundation.org" <gregkh@linuxfoundation.org> - 2016-02-04 00:30 +0100 Re: [PATCH] staging: wilc1000: Move Macro definition "Gujulan Elango, Hari Prasath (H.)" <hgujulan@visteon.com> - 2016-02-04 06:20 +0100
csiph-web