Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1323340 > unrolled thread

[PATCH RFC 03/15] ASoC: qcom: rename rdmactl_audif_start to dmactrl_audif_start

Started bySrinivas Kandagatla <srinivas.kandagatla@linaro.org>
First post2016-02-01 18:30 +0100
Last post2016-02-03 10:00 +0100
Articles 3 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  [PATCH RFC 03/15] ASoC: qcom: rename rdmactl_audif_start to dmactrl_audif_start Srinivas Kandagatla <srinivas.kandagatla@linaro.org> - 2016-02-01 18:30 +0100
    Re: [alsa-devel] [PATCH RFC 03/15] ASoC: qcom: rename  rdmactl_audif_start to dmactrl_audif_start Kenneth Westfield <kwestfie@codeaurora.org> - 2016-02-03 01:40 +0100
      Re: [alsa-devel] [PATCH RFC 03/15] ASoC: qcom: rename  rdmactl_audif_start to dmactrl_audif_start Srinivas Kandagatla <srinivas.kandagatla@linaro.org> - 2016-02-03 10:00 +0100

#1323340 — [PATCH RFC 03/15] ASoC: qcom: rename rdmactl_audif_start to dmactrl_audif_start

FromSrinivas Kandagatla <srinivas.kandagatla@linaro.org>
Date2016-02-01 18:30 +0100
Subject[PATCH RFC 03/15] ASoC: qcom: rename rdmactl_audif_start to dmactrl_audif_start
Message-ID<qXqsy-6bL-15@gated-at.bofh.it>
This patch renames rdmactl_audif_start to dmactrl_audif_start as this
is common for both rdma and wrdma. Without this patch the name would be
bit misleading to the readers.

Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
---
 sound/soc/qcom/lpass-platform.c | 2 +-
 sound/soc/qcom/lpass.h          | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/sound/soc/qcom/lpass-platform.c b/sound/soc/qcom/lpass-platform.c
index a6dce1b..bfc9de6 100644
--- a/sound/soc/qcom/lpass-platform.c
+++ b/sound/soc/qcom/lpass-platform.c
@@ -91,7 +91,7 @@ static int lpass_platform_pcmops_hw_params(struct snd_pcm_substream *substream,
 	unsigned int channels = params_channels(params);
 	unsigned int regval;
 	int bitwidth;
-	int ret, rdma_port = pcm_data->i2s_port + v->rdmactl_audif_start;
+	int ret, rdma_port = pcm_data->i2s_port + v->dmactl_audif_start;
 
 	bitwidth = snd_pcm_format_width(format);
 	if (bitwidth < 0) {
diff --git a/sound/soc/qcom/lpass.h b/sound/soc/qcom/lpass.h
index ab684a8..7c3367f 100644
--- a/sound/soc/qcom/lpass.h
+++ b/sound/soc/qcom/lpass.h
@@ -79,7 +79,7 @@ struct lpass_variant {
 	 * on SOCs like APQ8016 the channel control bits start
 	 * at different offset to ipq806x
 	 **/
-	u32	rdmactl_audif_start;
+	u32	dmactl_audif_start;
 	/* SOC specific intialization like clocks */
 	int (*init)(struct platform_device *pdev);
 	int (*exit)(struct platform_device *pdev);
-- 
1.9.1

[toc] | [next] | [standalone]


#1324780 — Re: [alsa-devel] [PATCH RFC 03/15] ASoC: qcom: rename rdmactl_audif_start to dmactrl_audif_start

FromKenneth Westfield <kwestfie@codeaurora.org>
Date2016-02-03 01:40 +0100
SubjectRe: [alsa-devel] [PATCH RFC 03/15] ASoC: qcom: rename rdmactl_audif_start to dmactrl_audif_start
Message-ID<qXTEg-2Um-43@gated-at.bofh.it>
In reply to#1323340
On Mon, Feb 01, 2016 at 09:28:28AM -0800, Srinivas Kandagatla wrote:
> diff --git a/sound/soc/qcom/lpass-platform.c
> b/sound/soc/qcom/lpass-platform.c
> index a6dce1b..bfc9de6 100644
> --- a/sound/soc/qcom/lpass-platform.c
> +++ b/sound/soc/qcom/lpass-platform.c
> @@ -91,7 +91,7 @@ static int lpass_platform_pcmops_hw_params(struct
> snd_pcm_substream *substream,
>  	unsigned int channels = params_channels(params);
>  	unsigned int regval;
>  	int bitwidth;
> -	int ret, rdma_port = pcm_data->i2s_port + v->rdmactl_audif_start;
> +	int ret, rdma_port = pcm_data->i2s_port + v->dmactl_audif_start;

I was wondering why rdma_port had not been changed as well, until I saw
that in a later patch.  Would it make sense to combine all changes
related to removing read-only indications from identifiers to one patch?

-- 
Kenneth Westfield
Qualcomm Innovation Center, Inc.
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum, 
a Linux Foundation Collaborative Project

[toc] | [prev] | [next] | [standalone]


#1325070 — Re: [alsa-devel] [PATCH RFC 03/15] ASoC: qcom: rename rdmactl_audif_start to dmactrl_audif_start

FromSrinivas Kandagatla <srinivas.kandagatla@linaro.org>
Date2016-02-03 10:00 +0100
SubjectRe: [alsa-devel] [PATCH RFC 03/15] ASoC: qcom: rename rdmactl_audif_start to dmactrl_audif_start
Message-ID<qY1s6-83z-23@gated-at.bofh.it>
In reply to#1324780

On 03/02/16 00:35, Kenneth Westfield wrote:
> On Mon, Feb 01, 2016 at 09:28:28AM -0800, Srinivas Kandagatla wrote:
>> diff --git a/sound/soc/qcom/lpass-platform.c
>> b/sound/soc/qcom/lpass-platform.c
>> index a6dce1b..bfc9de6 100644
>> --- a/sound/soc/qcom/lpass-platform.c
>> +++ b/sound/soc/qcom/lpass-platform.c
>> @@ -91,7 +91,7 @@ static int lpass_platform_pcmops_hw_params(struct
>> snd_pcm_substream *substream,
>>   	unsigned int channels = params_channels(params);
>>   	unsigned int regval;
>>   	int bitwidth;
>> -	int ret, rdma_port = pcm_data->i2s_port + v->rdmactl_audif_start;
>> +	int ret, rdma_port = pcm_data->i2s_port + v->dmactl_audif_start;
>
> I was wondering why rdma_port had not been changed as well, until I saw
> that in a later patch.  Would it make sense to combine all changes
> related to removing read-only indications from identifiers to one patch?

Yep, I will see if I can merge this and also I need to fix the ordering, 
I got same report from 0day testing too.

>

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web