Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1323345 > unrolled thread

[PATCH RFC 09/15] ASoC: qcom: rename rdma_ch_bit_map to dma_ch_bit_map

Started bySrinivas Kandagatla <srinivas.kandagatla@linaro.org>
First post2016-02-01 18:30 +0100
Last post2016-02-03 09:50 +0100
Articles 3 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  [PATCH RFC 09/15] ASoC: qcom: rename rdma_ch_bit_map to dma_ch_bit_map Srinivas Kandagatla <srinivas.kandagatla@linaro.org> - 2016-02-01 18:30 +0100
    Re: [alsa-devel] [PATCH RFC 09/15] ASoC: qcom: rename  rdma_ch_bit_map to dma_ch_bit_map Kenneth Westfield <kwestfie@codeaurora.org> - 2016-02-03 01:40 +0100
      Re: [alsa-devel] [PATCH RFC 09/15] ASoC: qcom: rename rdma_ch_bit_map  to dma_ch_bit_map Srinivas Kandagatla <srinivas.kandagatla@linaro.org> - 2016-02-03 09:50 +0100

#1323345 — [PATCH RFC 09/15] ASoC: qcom: rename rdma_ch_bit_map to dma_ch_bit_map

FromSrinivas Kandagatla <srinivas.kandagatla@linaro.org>
Date2016-02-01 18:30 +0100
Subject[PATCH RFC 09/15] ASoC: qcom: rename rdma_ch_bit_map to dma_ch_bit_map
Message-ID<qXqsz-6bL-27@gated-at.bofh.it>
rdma_ch_bit_map can be reused for wrdma channel allocations as wrdma
channel numbering start after rdma channel numbers.
With capture support referring rdma_ch_bit_map for wrdma channel allocation
is confusing, so renaming rdma_ch_bit_map to dma_ch_bit_map makes sense.

Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
---
 sound/soc/qcom/lpass-apq8016.c | 6 +++---
 sound/soc/qcom/lpass.h         | 2 +-
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/sound/soc/qcom/lpass-apq8016.c b/sound/soc/qcom/lpass-apq8016.c
index 2d43842..df44f09 100644
--- a/sound/soc/qcom/lpass-apq8016.c
+++ b/sound/soc/qcom/lpass-apq8016.c
@@ -137,20 +137,20 @@ static int apq8016_lpass_alloc_dma_channel(struct lpass_data *drvdata,
 					   int direction)
 {
 	struct lpass_variant *v = drvdata->variant;
-	int chan = find_first_zero_bit(&drvdata->rdma_ch_bit_map,
+	int chan = find_first_zero_bit(&drvdata->dma_ch_bit_map,
 					v->rdma_channels);
 
 	if (chan >= v->rdma_channels)
 		return -EBUSY;
 
-	set_bit(chan, &drvdata->rdma_ch_bit_map);
+	set_bit(chan, &drvdata->dma_ch_bit_map);
 
 	return chan;
 }
 
 static int apq8016_lpass_free_dma_channel(struct lpass_data *drvdata, int chan)
 {
-	clear_bit(chan, &drvdata->rdma_ch_bit_map);
+	clear_bit(chan, &drvdata->dma_ch_bit_map);
 
 	return 0;
 }
diff --git a/sound/soc/qcom/lpass.h b/sound/soc/qcom/lpass.h
index 8475b60..30714ad 100644
--- a/sound/soc/qcom/lpass.h
+++ b/sound/soc/qcom/lpass.h
@@ -50,7 +50,7 @@ struct lpass_data {
 	struct lpass_variant *variant;
 
 	/* bit map to keep track of static channel allocations */
-	unsigned long rdma_ch_bit_map;
+	unsigned long dma_ch_bit_map;
 
 	/* used it for handling interrupt per dma channel */
 	struct snd_pcm_substream *substream[LPASS_MAX_DMA_CHANNELS];
-- 
1.9.1

[toc] | [next] | [standalone]


#1324764 — Re: [alsa-devel] [PATCH RFC 09/15] ASoC: qcom: rename rdma_ch_bit_map to dma_ch_bit_map

FromKenneth Westfield <kwestfie@codeaurora.org>
Date2016-02-03 01:40 +0100
SubjectRe: [alsa-devel] [PATCH RFC 09/15] ASoC: qcom: rename rdma_ch_bit_map to dma_ch_bit_map
Message-ID<qXTEe-2Um-1@gated-at.bofh.it>
In reply to#1323345
On Mon, Feb 01, 2016 at 09:29:07AM -0800, Srinivas Kandagatla wrote:
> rdma_ch_bit_map can be reused for wrdma channel allocations as wrdma
> channel numbering start after rdma channel numbers.
> With capture support referring rdma_ch_bit_map for wrdma channel
> allocation
> is confusing, so renaming rdma_ch_bit_map to dma_ch_bit_map makes sense.
> 
> Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
> ---
>  sound/soc/qcom/lpass-apq8016.c | 6 +++---
>  sound/soc/qcom/lpass.h         | 2 +-
>  2 files changed, 4 insertions(+), 4 deletions(-)

As stated in my comments on patch 3 (ASoC: qcom: rename
rdmactl_audif_start to dmactrl_audif_start), I believe this change could
be combined with that patch.  Or at the very least, have this patch be
sequenced directly after patch 3.

-- 
Kenneth Westfield
Qualcomm Innovation Center, Inc.
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum, 
a Linux Foundation Collaborative Project

[toc] | [prev] | [next] | [standalone]


#1325056 — Re: [alsa-devel] [PATCH RFC 09/15] ASoC: qcom: rename rdma_ch_bit_map to dma_ch_bit_map

FromSrinivas Kandagatla <srinivas.kandagatla@linaro.org>
Date2016-02-03 09:50 +0100
SubjectRe: [alsa-devel] [PATCH RFC 09/15] ASoC: qcom: rename rdma_ch_bit_map to dma_ch_bit_map
Message-ID<qY1iq-80l-37@gated-at.bofh.it>
In reply to#1324764

On 03/02/16 00:37, Kenneth Westfield wrote:
> On Mon, Feb 01, 2016 at 09:29:07AM -0800, Srinivas Kandagatla wrote:
>> rdma_ch_bit_map can be reused for wrdma channel allocations as wrdma
>> channel numbering start after rdma channel numbers.
>> With capture support referring rdma_ch_bit_map for wrdma channel
>> allocation
>> is confusing, so renaming rdma_ch_bit_map to dma_ch_bit_map makes sense.
>>
>> Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
>> ---
>>   sound/soc/qcom/lpass-apq8016.c | 6 +++---
>>   sound/soc/qcom/lpass.h         | 2 +-
>>   2 files changed, 4 insertions(+), 4 deletions(-)
>
> As stated in my comments on patch 3 (ASoC: qcom: rename
> rdmactl_audif_start to dmactrl_audif_start), I believe this change could
> be combined with that patch.  Or at the very least, have this patch be
> sequenced directly after patch 3.
Ok, I will give it a go in next version.
>

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web