Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1321799 > unrolled thread
| Started by | Gustavo Padovan <gustavo@padovan.org> |
|---|---|
| First post | 2016-01-29 15:50 +0100 |
| Last post | 2016-01-29 17:20 +0100 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH 00/11] sync framework de-staging: part 1 - clean up Gustavo Padovan <gustavo@padovan.org> - 2016-01-29 15:50 +0100
Re: [PATCH 00/11] sync framework de-staging: part 1 - clean up Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2016-01-29 17:20 +0100
| From | Gustavo Padovan <gustavo@padovan.org> |
|---|---|
| Date | 2016-01-29 15:50 +0100 |
| Subject | Re: [PATCH 00/11] sync framework de-staging: part 1 - clean up |
| Message-ID | <qWix3-4ym-1@gated-at.bofh.it> |
Hi, 2016-01-25 Maarten Lankhorst <maarten.lankhorst@linux.intel.com>: > Hey, > > Op 21-01-16 om 13:49 schreef Gustavo Padovan: > > From: Gustavo Padovan <gustavo.padovan@collabora.co.uk> > > > > Hi, > > > > The following patches are some clean ups on the sync framework before > > we start the actual de-staging. The main changes here are the move of > > SW_SYNC_USER to debugfs. Removal of struct sync_pt in favor of direct > > use of struct fence. And the rename of sync_fence to sync_file, a name > > to better reflect what it is for, a struct that connects struct fence(s) > > to a file. > > > > Please review. Thanks. > > > > Gustavo Padovan (11): > > staging/android: fix sync framework documentation > > staging/android: sync: remove interfaces that are not used > > staging/android: remove not used sync_timeline ops > > staging/android: create a 'sync' dir for debugfs information > > staging/android: move SW_SYNC_USER to a debugfs file > > staging/android: rename sync_fence to sync_file > > staging/android: rename 'sync_pt' to 'fence' in struct sync_fence_cb > > staging/android: remove struct sync_pt > > staging/android: remove unused var from sync_timeline_signal() > > staging/android: remove pointless sync_timeline_signal at destroy > > phase > > staging/android: remove sync_fence_create_dma() > > > For whole series: > Reviewed-by: Maarten Lankhorst <maarten.lankhorst@linux.intel.com> > > Renaming sync_fence to sync_file makes sense, it should hopefully reduce confusion. Poke. What is missing for this to go upstream? Do I need more review here? Thanks. Gustavo
[toc] | [next] | [standalone]
| From | Greg Kroah-Hartman <gregkh@linuxfoundation.org> |
|---|---|
| Date | 2016-01-29 17:20 +0100 |
| Message-ID | <qWjW9-5K3-13@gated-at.bofh.it> |
| In reply to | #1321799 |
On Fri, Jan 29, 2016 at 12:47:20PM -0200, Gustavo Padovan wrote: > Hi, > > 2016-01-25 Maarten Lankhorst <maarten.lankhorst@linux.intel.com>: > > > Hey, > > > > Op 21-01-16 om 13:49 schreef Gustavo Padovan: > > > From: Gustavo Padovan <gustavo.padovan@collabora.co.uk> > > > > > > Hi, > > > > > > The following patches are some clean ups on the sync framework before > > > we start the actual de-staging. The main changes here are the move of > > > SW_SYNC_USER to debugfs. Removal of struct sync_pt in favor of direct > > > use of struct fence. And the rename of sync_fence to sync_file, a name > > > to better reflect what it is for, a struct that connects struct fence(s) > > > to a file. > > > > > > Please review. Thanks. > > > > > > Gustavo Padovan (11): > > > staging/android: fix sync framework documentation > > > staging/android: sync: remove interfaces that are not used > > > staging/android: remove not used sync_timeline ops > > > staging/android: create a 'sync' dir for debugfs information > > > staging/android: move SW_SYNC_USER to a debugfs file > > > staging/android: rename sync_fence to sync_file > > > staging/android: rename 'sync_pt' to 'fence' in struct sync_fence_cb > > > staging/android: remove struct sync_pt > > > staging/android: remove unused var from sync_timeline_signal() > > > staging/android: remove pointless sync_timeline_signal at destroy > > > phase > > > staging/android: remove sync_fence_create_dma() > > > > > For whole series: > > Reviewed-by: Maarten Lankhorst <maarten.lankhorst@linux.intel.com> > > > > Renaming sync_fence to sync_file makes sense, it should hopefully reduce confusion. > > Poke. What is missing for this to go upstream? Do I need more review > here? Thanks. You just sent this, give me a chance to get to it, my staging patch queue is over 1000 patches at the moment :( greg k-h
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web